1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[UO Herald] New 3rd Party Program Approved For UO: UO Mapper

Discussion in 'UHall' started by UO News, Mar 13, 2012.

  1. UO News

    UO News RSS Feed RSS Feed

    We have added a new program to the list of approved 3rd party programs for UO.
    Ultima Mapper is the new mapping application for Ultima Online Classic and Enhanced clients that allows users to share the entire experience. It's features include:
    • Coordinate and Facet Tracking
    • Connected User Health Status
    • Automatically Marks Corpses Upon Death
    • Follow any Player on the Map
    • Crystal and Corrupt Crystal Portal Commands
    • Boat Commands
    • And much more

    A list of all approved 3rd party programs can be found here in the EA knowledgebase.

    Continue reading...
    Shelleybean likes this.
  2. S.P.A

    S.P.A Journeyman

    Congratulations to the folks that made Ultima Mapper.

    And :eek: that the UO Pro 3rd Party Approval Programme has reopened after all these years!
    Viquire likes this.
  3. Viquire

    Viquire Babbling Loonie

    Hmmmmm Is UO pro reopened? Is this a release from mythic/uo, or who gets cudos? Sounds nifty.
  4. S.P.A

    S.P.A Journeyman

    No, Ultima Mapper is something that has crept in from the alternate universe. It used to require a program whose name can't be mentioned here, but it was later modified to work with the Enhanced client and then via the UOAssist API to work with the Classic client in the same way UOAM and UO Cartographer used to receive data from the Classic client.
    Viquire likes this.
  5. S.P.A

    S.P.A Journeyman

    By the way, you got the name right in the post but the title of this thread is wrong, it is Ultima Mapper not UO Mapper. There is something else out there in Asia called UO Mapper which I presume our Japanese friends can explain to us far better than I.
  6. MalagAste

    MalagAste Stratics Legend

    Congratulations to the makers of Ultima Mapper. And what a nice bonus for 2d users with the corpse locations.
  7. elspeth

    elspeth Seasoned Veteran

    Indeed! Grats to UO Mapper. And, does anyone have experience with it? I want to download it and see there is a client and server version. Do i have to be running a server to have access to all the features?
  8. Gilmour

    Gilmour Certifiable

    What's this?

    [​IMG]
  9. S.P.A

    S.P.A Journeyman

    1. McAfee is not reporting it as a threat
    2. MalwareBytes AntiMalware is not reporting it as a threat
    3. You would only need the server if you plan on hosting an Ultima Mapper server, not just running the client for personal use, was that your intention?
      • Even with UO AutoMap and UO Cartographer, only a tiny fraction of users ran mapping servers, most just ran clients
  10. Gilmour

    Gilmour Certifiable

    so what you saying is if only a few potentially install a virus its ok?

    i did plan to host one.
  11. Martyna Zmuir

    Martyna Zmuir Crazed Zealot

    Anyone know if this program accepts map coordinate files like UOAM and UOC did?
  12. Promathia

    Promathia Babbling Loonie

    Well, after 5 minutes of testing, it has decided to not track me or a guildy anymore. Ive tried everything, and it just wont track me anymore
  13. Vyal

    Vyal Slightly Crazed

    Glad my source got some use someplace not sure why when I tried to get approved they told me the program was shut down or something.
  14. S.P.A

    S.P.A Journeyman

    Gilmour,

    Really....

    Your Norton has reported it as a threat, not a virus, under the code "WS.Reputation.1".

    I've pointed out that neither McAfee nor MalwareBytes consider Ultima Mapper a threat.

    Furthermore, were you to Google the "WS.Reputation.1" status from Norton, you'd find that this is Norton's generic flag for any new software it hasn't tested, rather than being a positive confirmation of a virus. Read about it in a complaint from a Norton user here and Norton's official clarification here.

    Had you done your research as I have just done, you'd have known that all you've done is told us all that Norton doesn't recognise Ultima Mapper because it is brand new software and that there is no specific threat; and that Norton have the arrogance to demand that developers go beg them to stop classifying their brand new software as a threat!

    And knowing that, would you really have scaremongered the UO community this way? I hope not.

    What was it that Petra posted last year about Rule B? Read it here and think just how positive and community building your misinformation was.

    Thanks.
    Sevin0oo0 and elspeth like this.
  15. S.P.A

    S.P.A Journeyman

    Vyal,

    I suspect this has something to do with the latest Classic Client patch breaking dear old UO AutoMap so badly that it probably can't even be hacked back to life with the hex editor tricks.

    With UO AutoMap officially deceased and probably unhackable, and UO Cartographer abandoned by the developer and only available second-hand from a few fansites, and with Jeff's interview recently admitting that most users were still using the Classic Client, I rather think the broken mapping situation was just another nightmare that Messana would have had to face on top of the patching disaster, and perhaps she has had the wisdom to put some pressure on the powers-that-be to give us Classis Client users a break today.

    Expediency more than policy, I guess, but I'm happy with the result.

    Let's just hope that a rush of new users to Ultima Mapper works for the benefit of the whole community, and doesn't lead to whatever went wrong with UO Cartographer when it got mainstream that caused the developer to walk away.
  16. Cogniac

    Cogniac Grand Inquisitor

    I believe I've identified your problem: You're using Norton.
    To fix this issue, please remove all Symantec products from all of your computers and devices and never, ever, ever, ever, install them again.
    Chazztizer, Borric, Sevin0oo0 and 6 others like this.
  17. S.P.A

    S.P.A Journeyman

    I think we owe it to the wider community to explain a little more why Norton's use here is the cause; that's what I explained in my post so folks could see that Norton themselves were admitting what they were doing was a little left-field, instead of just slagging off Norton without explaining why.
  18. Sevin0oo0

    Sevin0oo0 Crazed Zealot

    I can't get it to track me at all. Is this EC only?
  19. S.P.A

    S.P.A Journeyman

    No, it is EC, or CC + UOAssist.
  20. S.P.A

    S.P.A Journeyman

    In case you didn't see this, from the Ultima Mapper FAQ:

  21. Sevin0oo0

    Sevin0oo0 Crazed Zealot

    maybe i'm doing it wrong... logged in game, assist up and working, Started app. clicked 'connect' in there somewhere, recalled around, just shows me in Brit throne-room

    Edit: thanks SPA... trying now
  22. MadMartyr

    MadMartyr Technical Administrator Administrator Staff

    I suppose, as the developer, I should chime in here. Norton has been reporting it as a virus for some time. If you check the FAQs and Blog, you'll see that I addressed this with VirusTotal results. Nothing else, to my knowledge, currently gives a false-positive on any portion of Ultima Mapper, be it server or client.

    I'm not sure what source you're talking about. This is a sole development, written entirely by me.
    Shelleybean, Daelomin and Syrus like this.
  23. Taylor

    Taylor President & CEO Board of Directors Administrator

    You've done a great job, Mad! I'm so impressed. Plus, I can say I know a UO celebrity. :D

    By the way, the false positive relates to the fact that it hasn't been widely installed. I know Mad and would certainly vouch for him. He does development work full-time. He's not going to risk his professional reputation. I'm still trying to find him a project to work on Stratics. :)
    Shelleybean likes this.
  24. MadMartyr

    MadMartyr Technical Administrator Administrator Staff

    Thanks, Syrus. It's a pleasure to be in such a great community.
    Syrus likes this.
  25. Promathia

    Promathia Babbling Loonie

    I just want to reiterate, the program for me and some guildies will no longer track us. The EC box is unchecked, it was working fine, but after we died (Testing the corpse markers) it wont track us anymore
  26. MadMartyr

    MadMartyr Technical Administrator Administrator Staff

    Did you try right-click > Center On Player?
  27. Promathia

    Promathia Babbling Loonie

    Yes, still wont track us.
  28. Gilmour

    Gilmour Certifiable

    the spite in my response was that you outlines that server was only required to host. i wasnt born yesterday and i well aware that is the case ;)

    but apoligize for that part.

    But, whereever it is a virus or not, getting warning on apps that official third party applications is bad.

    Byte Hero & Antiy-AVL says complain about it too.

    About the rule b, i am well aware of it. but thought it was important issue due to above stated reason. whereever its the case or not.

    i did install it myself, after disabling norton..
  29. S.P.A

    S.P.A Journeyman

    If you check the post immediately before yours, you'll see elspeth asking if she needed to install the server to access all the features, so it wasn't obvious to her that you could just run the client.

    On that basis, in my reply to you, I wanted to make it clear that you didn't need to install the server, for her benefit and for the benefit of anyone else similarly confused.

    You've clarified you personally weren't confused by that, but I am sure you can acknowledge from elspeth's post that others were or might have been.

    No offence taken by me, no apology necessary, and no offence intended by me to you.
  30. MadMartyr

    MadMartyr Technical Administrator Administrator Staff

    While some antivirus programs may flag the application as a virus, it is a false-positive. You have my assurances that there are no viruses present. Feel free to submit the executables to the respective anti-virus vendors. I did this some time ago with Norton, and received a generic response.

    Can you clarify? Is it not showing movement, or is the map not following you? Is the server still running? Are all clients still connected?
  31. Sevin0oo0

    Sevin0oo0 Crazed Zealot

    logged off my box & back, it opened normally exc w/ an additional small window
    "Select Client"
    # of Clients 1
    Current Client 1
    2 buttons: Close Next >>
    Clicking Next does nothing
    Clicking Close simply closes that little window
    neither affected the tracking

    Rt, click map> Settings - unchecked box, click OK
    Pop-up window says
    "choose client..."
    box inside is blank
    Clicking any of the buttons at the bottom does nothing, exc the cancel button.

    ...maybe until Tug updates assist, it's broken?
    EDIT: I started in Brit and it tracked, thru 2 moongates to ter mur, stopped in a field, logged the client & restarted, no tracking
  32. Conrad

    Conrad Journeyman

    I'm guessing he didn't know, thus the question "What's this?"

    Throwing Rule B in his face when he was asking an honest question isn't exactly living up to that rule, either. One might see that as an attempt to stifle his input (see what I did there?). His second response...well, I can understand it. Who is he to trust? His anti-virus software, or you? Is he supposed to simply ignore his AV protection because you say he should? You suggested he research it before providing "misinformation". Maybe that was what he was doing--going straight to the horse's mouth (the developer), so to speak?

    Personally, I think he was simply using this forum for it's intended purpose--connecting with the community and learning from others.

    Don't be too hasty to judge the intentions of others, lest they judge yours.
  33. MadMartyr

    MadMartyr Technical Administrator Administrator Staff

    Also, be sure to try re-selecting your client, if you're using CC:
    Right-Click > Select Client
  34. MadMartyr

    MadMartyr Technical Administrator Administrator Staff

    Can we not turn this in to a flame thread, please?
  35. MadMartyr

    MadMartyr Technical Administrator Administrator Staff

    Ah. Good find. That's a bug. Now if you right-click and choose "Select Client", it should work properly. That old window will be gone in the next release.
  36. MadMartyr

    MadMartyr Technical Administrator Administrator Staff

    For more information on the Norton false-positive, please check here. This is due to the installer used, which will be replaced in a future version, and specifically is in regards to the compression used to bundle the payload to the installer program.
    Sevin0oo0 and Syrus like this.
  37. Promathia

    Promathia Babbling Loonie

    I cant get that to work at all. The window comes up saying #of clients 1, current Client 1 but the Next button doesnt work.
  38. MadMartyr

    MadMartyr Technical Administrator Administrator Staff

    It is working, that's why it does nothing. It has selected the only available client. 1 of 1.
  39. Sevin0oo0

    Sevin0oo0 Crazed Zealot

    sometimes it tracks correctly, sometimes i have to select the facet first, sometimes it just doesn't move, even if I pick another facet- map changes, my position doesn't.
  40. S.P.A

    S.P.A Journeyman

    Conrad,

    You're entitled to your opinion; I'm entitled to mine.

    MadMartyr is active in this thread now and has asked that this not turn into a flame thread.

    I am delighted he's confirmed what I originally posted, that the Norton message is a false positive that has no basis in reality.

    That should satisfy everyone who gets this far in this thread.

    To be honest, I wonder if Gilmour should just edit away his huge scary post on page one of this thread in the light of what's been discussed subsequently, lest we scare off potential users?

    Mythic has done enough harm to the Classic Client user community in the last 24 hours, the last thing we need is them being misled into thinking we have no viable mapping solution as well by Norton's unfounded accusations against Ultima Mapper.
  41. Promathia

    Promathia Babbling Loonie

    Same here. It was working perfectly when I first downloaded it, but now its just not tracking at all.
  42. MadMartyr

    MadMartyr Technical Administrator Administrator Staff

    If you are experiencing the facet tracking issue, you must change facet on your character, and then back. This is an issue with the UOAssist API, and was also present in other Mapping programs that use this API.
  43. MadMartyr

    MadMartyr Technical Administrator Administrator Staff

    Without more specific information about what, exactly, you are experiencing, I can't do much. Please review my earlier questions. If all else fails, try restarting Ultima Mapper.
  44. Sevin0oo0

    Sevin0oo0 Crazed Zealot

    I'm glad MadMartyr has taken the time to come in person and help.
    Hell, i'd trust Sony before I'd trust Norton, and Sony is known for its rootkits
    When i do feel the need, I use the free Comodo suite
    Nalynn likes this.
  45. Promathia

    Promathia Babbling Loonie

    Running Windows 7, CC Client/UOAssist , running UO and Mapper as Admin, Center on Player checked, tried running around/changing facets, Mapper still does not track my movement. Use EC Client is unchecked. Restarted Mapper a million times, even tried uninstalling/reinstalling. I open UOCart, im tracked fine. Id rather use this program, but it simply isnt working for me or many of my guildmates.
  46. MadMartyr

    MadMartyr Technical Administrator Administrator Staff

    Interesting. This is the first report I've seen of this issue. Would you be opposed to allowing me to securely access your computer to troubleshoot the issue?
  47. kelmo

    kelmo UO Senior Moderator | (CLT) Staff Senior Moderator

    *smiles* That can be done.
    Sevin0oo0 likes this.
  48. Promathia

    Promathia Babbling Loonie

    Yea...Maybe Sevin will let you tho. I dont even know them and they seem to be having similar issues.
  49. Basara

    Basara UO Moderator Staff VIP

    Could the tracking issue be related to the changes in UO startup that have altered the UOA interaction with the CC?
  50. Sevin0oo0

    Sevin0oo0 Crazed Zealot

    Getting it to work better by selecting the facet.

    When i go thru the gate into SA, from the tomb of kings area, i have to
    reselect center on player, then select shard - tracking, until I go back thru gate

Share This Page