Hello!

Welcome to the Stratics community! Ready to talk games? Register today!

Sign Up
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Uomapper is ....

Discussion in 'UHall' started by Kage, Mar 24, 2012.

  1. Kage

    Kage Crazed Zealot

    Garbage. UOCartographer is 1000000x better...

    Even with my beastly cpu i lock up while fighting trying to run uomapper...
    kRUXCg7 likes this.
  2. Petra Fyde

    Petra Fyde UOSS M.E. | UO Community Liaison Board of Directors Administrator Senior Moderator

    There are better ways of phrasing that. Someone has taken the time and trouble to attempt to create a mapping program that is supported, where the existing two aren't. The fact that it runs poorly on your game set up would probably be of interest if you included details of the machine's configuration and the specific problem you are encountering.
    A number of other posters are already providing feedback to help the author improve his creation.
  3. Kage

    Kage Crazed Zealot

    That's nice... Sorry but I tell it how it is. That person wasted his or her time. And to be honest... I don't see why UOCartographer is not supported. It runs perfect but it's not supported that makes no sense at all... It's like they only support bad things...
    kRUXCg7 likes this.
  4. MalagAste

    MalagAste Belaern d'Zhaunil Stratics Pro

    Well hate to break it to you but the one who created UOCartographer no longer plays nor maintains it... much like the creator of UOAutomap... so whether or not one or the other is superior to another does not matter... Fact of the matter is only UOMapper still has someone who is working on it and maintaining it... so the choice left to the DEV's for granting it such a status is clear...

    Just saying. And I agree with Petra.... there are far better ways of saying it could use some assistance. Perhaps you are good enough at coding and all that you could fix it? If not I suggest you keep your opinions to yourself..

    I personally couldn't make any such program therefore leave that to those who can and thank those that do for their work and and am glad that they do things for the benefit of others.
  5. Sevin0oo0

    Sevin0oo0 Crazed Zealot

    There are better ways of describing your difficulty as well. This is Not a brand new program that was created last weekend, try several months ago, and in use by many users, To the OP, isn't it odd no one else is reporting this issue? it may be something unique to your pc, or may be something not related to uomapper.
    If there is certain circumstances causing it to lock, we'd all like to know. You came here to share a problem, help us to help you in reaching a resolve by listing a few more details please.

    for starters - has it ever worked correctly; OS; client version; are other aspects of the game functioning correctly, checked task manager for processes?
    MadMartyr likes this.
  6. Petra Fyde

    Petra Fyde UOSS M.E. | UO Community Liaison Board of Directors Administrator Senior Moderator

    When I said they are 'not supported' I meant by the people who developed them. In this context 'supported' refers to technical support for the program. No one supplies technical support for uoam and uocartographer because the developers have moved on and left the game.

    EA does not support any 3rd party program, including any that have been granted uopro status. That is entirely down to the person who created it.
  7. Raptor85

    Raptor85 Certifiable

    Mapper, as is, is riddled with security holes and some pretty nasty bugs, I would hazard a guess the developers didn't really expect EA to come out and approve it this fast, especially seeing as it has no real working server software yet. (I would advise anyone thinking of installing the server to hold off for now, the current server software is a remote exploit waiting to happen)

    The developer is not releasing the source code, so while it's not "impossible" for other people to modify it is 10000x harder (all you can see is memory addresses, none of the actual variable names, etc). The code to interface with UOAssist is quite simple though, I released this a while back to show anyone interested how to do it, in the hopes that someone would use it to build a full featured map program. openuomap - Free mapping program for Ultima Online - Google Project Hosting (I have no interest myself, I don't even use UOAM so it's useless to me, and without being paid to do so I don't really have the time).
  8. SirZ

    SirZ Journeyman

    Ok, but who needs this don't working peace of ****? :D
  9. MadMartyr

    MadMartyr Journeyman

    UWF

    I'm sorry you're having issues. Why didn't you contact me or submit a bug so we could address this?

    At any rate, please do so now. I have a couple of volunteers helping with the bug tracking and verification now, so hopefully we can get you sorted.
  10. MadMartyr

    MadMartyr Journeyman

    UWF

    How, exactly, is it a "remote exploit waiting to happen"? If you have discovered a security hole, why have you not reported it? I don't understand this desire to bash software you didn't create without a.) offering the developer the opportunity to address your concerns by voicing them to the the developer or b.) making some attempt to validate and prove your claims. Please, use the contact form on the Ultima Mapper website and let me hear your concerns. I'm always open to these discussions.

    The server software is 100% working. If you've read the other thread, many people have it working (including me, and I host it for a large guild).
    Hannes Erich and Flutter like this.
  11. MadMartyr

    MadMartyr Journeyman

    UWF

    You would be wrong. As I've stated previously, I've been working on the app since November, and it was submitted to EA in January. Many of the bugs reported thus far were issues created by the recent patch. Valid reproducible bugs to-date:
    • Lat/Long is off by 15deg along NS on Tram/Fel maps
    • Map resolution is too low
    • Marker actions may crash Mapper
    • EC Mod is incorrect (fixed, was due to updates after Pinco added support)
    • Installer false-positive in some AV packages (new installer forthcoming)
    • Installer does not automatically set 'Run As Administrator' flag on Vista (no way to address this currently, except an external manifest, which isn't an appropriate solution given certain development circumstances)
  12. Promathia

    Promathia EM Bennu Fanclub Stratics Pro

    Mapper seems to atleast be tracking more consistently, but it still randomly stops for a bunch of guildmates (That plus its so annoying how moving the map unchecks center on player).

    Once the Tilt Map gets put in, ill be having my guild use it (As the tracking issues are a bit more stable...)
  13. MadMartyr

    MadMartyr Journeyman

    UWF

    I would ensure that they have done the following:
    • Make sure Mapper is running as admin
    • Make sure both the client and UOA are fully patched up-to-date (some users had to force UOA to check for updates)
  14. Promathia

    Promathia EM Bennu Fanclub Stratics Pro


    Yup, It was working fine about 3 days ago, but in the middle of a fight myself and others had it just stop tracking during the fight (not all at once of course). Working fine right now (Except it wasnt showing the correct facet, I had to change facets before it tracked it correctly. That is something that just cant happen if I expect to have a pvp guild use it. Also something that doesnt work when 90% of the time we are on reds...)
  15. Promathia

    Promathia EM Bennu Fanclub Stratics Pro


    And of course I jinx myself, as I opened it again it will no longer track me...at all
  16. MadMartyr

    MadMartyr Journeyman

    UWF

    The facet tracking issue is a problem with UOA, and nothing I can do about that. UOCart had the same issue.
  17. Promathia

    Promathia EM Bennu Fanclub Stratics Pro

    I have never had an issue like that in UOCart...Or anyone in my guild

    And how would a guild full of reds remedy this issue? Seems switching facets fixes it...but obviously cant do that
  18. MadMartyr

    MadMartyr Journeyman

    UWF

    This issue should only happen when you are on a facet different than the previous one when attaching to a client. Once you switch facets, it's fixed, because UOA then (finally) sends the facet update message (which it only does when you change facets, not when an app attaches or when you connect). I could change the facet selection in the right-click menu to be preserved while tracking.
  19. Promathia

    Promathia EM Bennu Fanclub Stratics Pro

    I swear that has never happened to me in UOCart. In fact I just tried it, and it updated correctly. *shrugs*

    And Mapper is tracking me again, I keep trying to replicate how it stops tracking but I cant figure it out. It really just seems to happen randomly...
  20. Raptor85

    Raptor85 Certifiable

    the bug tracker disn't exist when i first tested it, and i haven't read each and every post in that multi-page thread as it came out so i was unaware of it's existance. While the server software technically runs it's far too insecure to run on a real server. Posted up a small bug list, I stopped looking after what i found in a hour as I couldn't run it as is, so i don't guarantee that's all there is. Personally i'd take the server software down until it's fixed a bit better, or at least put a "use at your own risk" disclaimer, for those that don't care but still want to run it for the time being.

    For the facet issue, the problem is you're only swapping on receiving a WM_USER+313 what you generally do is store the user as a hash with it's last recorded information, some of the flags (i dont remmeber offhand which, but I believe WM_USER+208, which requests for nearby housing info, also causes the facet check to happen, otherwise it's simply to use the current x-y values to sync and read it straight from UOAssists memory, but that's overkill, the other methods should be good enough)

    For the lat/lon issue, click here, main.cpp - openuomap - Free mapping program for Ultima Online - Google Project Hosting , i show how to translate it properly there, its quick and dirty though so definitely needs to be re-written for real use, it's just a simple implementation of the documentation from UOAM's site.
  21. Belshazzar

    Belshazzar Adventurer

    Greetings,
    I wanted to say first thank you for making a new map program to be utilized for the community since the map tiles are broken and uoam no longer works. I would like to report a bug well two actually dealing strictly with SOS, I have gone to add SOS to markers since there is no input and mark ability for sos.. I went into add marker, deleted out the x/y coords, and inputed the coords from the sos map itself. Well it changed the coords for me when i saved and put on other side of map. So then i right clicked and edited the sos coords. Still same problem. Moved another part of map. So was like let me grab a sextent and go do this very old school. So i did so, now this is the other bug. The map is off about 5 to 9 degrees on the E/W coordinates. I am not good at screen shotting but i had mapper up, the red dot on top left gave me my position, i verified by putting mouse over myself and i was a whole 5 to 9 degrees off from the coords entirely, i was popping up sextant, was able to do the sos via sextant but map coords were wrong. I can gladly duplicate this as well.

    If you are able to correct this problem and add ability - when i input coords for a sos that it will mark the spot on map or give me option to mark spot on map so i am able to go to that spot. Also entering coordinates in like i said was placing dots all over the place wrong.


    Computer is up to date with patches as of this night, using windows 7 in admin mode, uoassist was being used in admin mode.

    Standing by to test again..

    V/r
    Lord B​
    MadMartyr likes this.
  22. MadMartyr

    MadMartyr Journeyman

    UWF

    The marker system is currently undergoing a rewrite to fix a few different bugs and add some much-needed functionality at the same time.
  23. Sevin0oo0

    Sevin0oo0 Crazed Zealot

    MadMartyr, Back In the day I'd use a Japanese program that would draw a faint 8x8 grid across the map BMP's of UOAM (or any bmp for that matter), often useful in resource mining in x-ray mode. That's probably not possible with your, is it? [just askin, no complaints here]
  24. MadMartyr

    MadMartyr Journeyman

    UWF

    It will be soon enough. Both the markers and overlays are going to an open format (XML), so you'll be able to do all sorts of neat things, such as draw polygons on the map, etc.
    Sevin0oo0 likes this.
  25. Lord Frodo

    Lord Frodo Crazed Zealot

    That Grid was banned by UO.
  26. Lord Frodo

    Lord Frodo Crazed Zealot

    You may want to submit your ideas to UO befor doing a lot of different thing to your program. Just because you have an approved program with UO does not mean you can do what you want with it, just ask the maker of UIOAsist.
  27. Sevin0oo0

    Sevin0oo0 Crazed Zealot

    Yes, there was a program that is taboo, I have several versions of it, which can be used while AFK to perform various automatic functions. This one cannot. The one I was referring to draws a faint 1px-wide grid, permanently, on any .bmp and nothing else, similar in nature to an overlay or markers, such as the ore icons, and other user added. While possibly being designed with UO in mind with a matching 8 Pixel wide theme, that is it's only function, purely an art function, or Deco, so to speak. It does not 'find' anything, nor offer any automatic interactions. Not unlike changing to x-ray, or no-statics mode templates which UOAM had. It also has a different name than the banned one commonly thought of.
    I know of the now Reverted changes that assist endured, not even remotely similar. As Devs are not unaware of scripting method issues affecting their work, if there is a problem with something they approved, it won't last long, just as they have acted swiftly in the past.
  28. Flutter

    Flutter Marketing Assisstant Staff Moderator Stratics Supporter

    FLUT

    I await something better made by you sir.
    MadMartyr, Lord Frodo and Sevin0oo0 like this.
  29. Basara

    Basara UO Forum Moderator Staff Moderator

    Drawing a grid, ANY grid, on a UOAM map was illegal - not any specific program. I'm pretty sure the same is still true for UM (and UOC, for that matter). What is "cosmetic" to you, to the devs is "exposing an underlying part of the game code", and therefore a bannable offense.
  30. Vlaude

    Vlaude SC Reporter Staff

    Jesus man. Don't hurt the poor guy's feelings because there are a few mistakes.
  31. Sevin0oo0

    Sevin0oo0 Crazed Zealot

    Thanks Basara, that had a very strong ring of truth to it, going back many years, (not doubting you) I know someone said it, I just can't place who did. Since 'markers', even custom ones weren't illegal, by simply placing many to resemble a grid could be construed as illegal i suppose, even if I walked and counted every tile. seems a little silly. Back before the ores rotating, I'd mark every single tile along a mountainside with its color ore, typically always 8 tiles long, illegal since i saw patterns in 8 tile squares? . It's all a non-issue for me, i think my mining days are over anyways, but thanks again for taking me back to the old days.
  32. Digitali

    Digitali Visitor

    First off, thanks for taking the time to try to create a program to enhance players' gaming experience.

    (ramble time, skip to next paragraph if you want to avoid it lol.) I started UO shortly before T2A came out and quit after about 5 years. I enjoyed the game..over time I got lured away by friends who were playing other games. In the last week I have returned with a friend who has never played UO. I am enjoying the game....but I started to miss my UOA and UOAM features... UOAM (as established here) is dead in the water... I went looking for a replacement and stumbled across your program. I read through most of the thread and I see others are having the same issue I am having but I don't see a fix. My reason for getting this is so that I can show my new friends the wonders of fishing up sos etc. The mapping system in UO really lacks and that makes a program like this a requirement in my eyes if you want to enjoy any type of treasure hunting.

    My problem is that it won't track me anymore. It worked for a few minutes then stopped. Here's what happened as best as I can recollect:

    Loaded UOA which loaded UO then loaded Mapper (running as admin, yes I use Windows 7, fairly new system that handles modern gaming.)
    It correctly displayed my location. (at this point I was pretty happy because I thought it was going to work out)
    Then I started to poke and pinch at the program in attempt to figure out how to add SoS locations on the map so I could sail to them. This is where I encounter my first error...
    The program stops responding and freezes for over a minute. I start everything back up and it's no longer tracking. It won't even allow me to attempt to ADD locations now. (if you want more info about what I"m seeing here let me know and I'll go through it again.) So at this point I'm thinking great I broke something. I went to the site to try to figure out what and didn't find anything that helped me. I decided (in my true nature) to try to fix myself. So, I uninstalled, rebooted, installed again - noticed it saved user settings. I did uninstalled again and did a file search - removed some files - rebooted - installed again - which seemed to reset the "factory settings" (could you maybe add a restore defaults option?) - anyway it still wouldn't track me. I tried all suggested fixes and everything I thought might help 2-3x at least with no luck. I notice other users are having my same problem so I think it might all be linked...

    If I can do anything to help fix this issue or if I need to provide more information please let me know.
  33. Digitali

    Digitali Visitor

    Ok, I had everything shutdown while I was posting...I start it up (run admin as UOA, load UO, run admin as Mapper) and it correctly loads my character's location. I move around with the tiller feature it and updates it. I still however can't "add" markers. I'm not sure why. I enter the coors, name and facet (try to select a cat. to add to but it won't let me) then I hit ok but it doesn't close the options screen nor does it add. I'm not sure if I'm doing something wrong or not....
  34. MadMartyr

    MadMartyr Journeyman

    UWF

    It sounds like you were initially suffering from the issue(s) that many were experiencing when UOA wasn't behaving properly due to the patch problems.

    As far as markers go, the marker system is a bit crazy due to some changes in the framework upon which Mapper is built. In the other thread (and on the UltimaMapper.com News page), I've announced that the marker system will be rewritten for the next release to address many (if not all) of these issues.

    I'm glad you have it working. If there's anything else I can help with, please let me know.
  35. Irulia Darkaith

    Irulia Darkaith Seasoned Veteran

    I had the same problem. Not sure why, but you can't use the pull down feature on the "Add To:" instead you have to type it and let it find it that way. Then it should save. That worked for me.
  36. Digitali

    Digitali Visitor

    Thanks for the response. Yeah...add to doesn't work and when I try to edit an existing one...it causing the program to stop responding and closes it. I am pleased to announce (with the help of destination feature) I was able to "sort of" mark one sos and with some work....found my first SoS location exactly. (yay!) Now I just wait for friend to log on so I can show him what fishing up sos is all about. I'm just happy I have a map that shows me where I am on a large scale....no way I'd even semi enjoy fishing up mibs w/o one. Hopefully, it keeps tracking me for another one later. :)
  37. MadMartyr

    MadMartyr Journeyman

    UWF

    Glad to hear it! A few more fixes, creation of a new load process for first-time users, and the next release will be rolling out the door.
  38. Kojak

    Kojak Lore Keeper

    just in case some people didn't know - I posted a perfectly working copy of automap in the UOAM thread on the uhall (it's the exact one I use myself - has the changes to new haven and hythloth in trammel too)

    in case you need something to run until mapper is good enough or you just prefer automap :)
  39. MadMartyr

    MadMartyr Journeyman

    UWF

    Excellent. Thanks for cross-posting. I've played many hours of UO with UOAM, and am glad you've found a workaround to keep a long-running staple of the community functional.

Share This Page