1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

Enhanced Client 2 new functions not working

Discussion in 'Fixed List' started by Pinco, Jan 4, 2013.

  1. Pinco

    Pinco UOEC Modder
    Stratics Veteran Stratics Legend

    Joined:
    Jul 25, 2005
    Messages:
    5,675
    Likes Received:
    865
    PlaySoundByID and GetTerrainType seems to be non-existent or not accessible from lua

    When used returns:
    attempt to call global 'PlaySoundByID' (a nil value)
    attempt to call global 'GetTerrainType' (a nil value)

     
  2. Pinco

    Pinco UOEC Modder
    Stratics Veteran Stratics Legend

    Joined:
    Jul 25, 2005
    Messages:
    5,675
    Likes Received:
    865
    tested with the new client version and still not working, any news on this? :p
     
    Storm likes this.
  3. Pinco

    Pinco UOEC Modder
    Stratics Veteran Stratics Legend

    Joined:
    Jul 25, 2005
    Messages:
    5,675
    Likes Received:
    865
    another client patch and the functions still not working...
     
  4. Pinco

    Pinco UOEC Modder
    Stratics Veteran Stratics Legend

    Joined:
    Jul 25, 2005
    Messages:
    5,675
    Likes Received:
    865
    I wonder if they ever gonna fix this and the distance from player....
     
  5. Pinco

    Pinco UOEC Modder
    Stratics Veteran Stratics Legend

    Joined:
    Jul 25, 2005
    Messages:
    5,675
    Likes Received:
    865
    another patch and those functions still not working, quite sad :(
     
  6. Pinco

    Pinco UOEC Modder
    Stratics Veteran Stratics Legend

    Joined:
    Jul 25, 2005
    Messages:
    5,675
    Likes Received:
    865
    and after 2 months.... nothing changed :facepalm:
     
  7. Pinco

    Pinco UOEC Modder
    Stratics Veteran Stratics Legend

    Joined:
    Jul 25, 2005
    Messages:
    5,675
    Likes Received:
    865
    You can mark this as fixed, the problem was just a mistyping in the publish notes, the real function names are:
    PlaySound
    LuaGetTerrainType