1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

2D client not saving speech macros ?

Discussion in 'UHall' started by popps, Jan 22, 2010.

  1. popps

    popps Always Present
    Stratics Veteran Stratics Legend

    Joined:
    Feb 27, 2004
    Messages:
    13,445
    Likes Received:
    461
    Now, this is odd.

    I made a speech macro linked to ALT-F7 to say something in game.

    As soon as I make it, press APPLY and then also OK buttons to make sure (ALT-O) if I press the keys combination (ALT-F7) the speech macro playes just fine and the speech appears on the screen.

    But if I close the client and then log back in the macro is not there.

    It was not saved. Yet, I did press APPLY and OK various times to make sure.

    I repeated this several times and yet, when I close client and restart it the speech macro is no longer there.

    I tried to edit the file manually but under the Desktop Folder, character's name, there is only 1 macro.txt file which contains none of my speech macros. I am not sure under which file and where they may be so I cannot manually edit it.

    Anyone has a clue about what is going on and how I can fix this ?

    Thanks.
     
  2. Serine

    Serine Guest

    you have same macro combo keys on something in uoa ?
     
  3. popps

    popps Always Present
    Stratics Veteran Stratics Legend

    Joined:
    Feb 27, 2004
    Messages:
    13,445
    Likes Received:
    461
    No, I checked, and the key combination I was trying to save the 2D text macron on (ALT+F7) is not used by anything.

    Yet, I cannot save it, period. Each time I close the 2D client the macro is lost and I have to make it anew when I restart the client.

    It is getting annoying.
     
  4. Scooby_Snacks

    Scooby_Snacks Journeyman
    Stratics Veteran

    Joined:
    Aug 3, 2003
    Messages:
    254
    Likes Received:
    0
    This has happened to me in the past and I had to re-install the client
     
  5. Tazar

    Tazar Guest

    Are you closing the client with the red X in the top right of the game window? Or are you logging out? I believe that closing with the Red X sometimes causes macro's to not save.
     
  6. popps

    popps Always Present
    Stratics Veteran Stratics Legend

    Joined:
    Feb 27, 2004
    Messages:
    13,445
    Likes Received:
    461

    Regularly with Paperdoll gump up and button LOG OUT, No red X at all.

    I cannot figure out why this macro won't save.
     
  7. GarthGrey

    GarthGrey Crazed Zealot
    Stratics Veteran Stratics Legend GoT

    Joined:
    Mar 18, 2003
    Messages:
    3,628
    Likes Received:
    1,390
    You must have really long fingers to have an alt/f7 macro...
     
  8. popps

    popps Always Present
    Stratics Veteran Stratics Legend

    Joined:
    Feb 27, 2004
    Messages:
    13,445
    Likes Received:
    461


    Or a small keyboard............
     
  9. ingsmsico

    ingsmsico Visitor

    Joined:
    Oct 17, 2009
    Messages:
    484
    Likes Received:
    0
    i dont have an alt F7 but my alt F8 is rez spell. really depends what u put there and how often it is needed.
     
  10. ingsmsico

    ingsmsico Visitor

    Joined:
    Oct 17, 2009
    Messages:
    484
    Likes Received:
    0
    i dont have an alt F7 but my alt F8 is res. really depends what u put there and how often it is needed.
     
  11. popps

    popps Always Present
    Stratics Veteran Stratics Legend

    Joined:
    Feb 27, 2004
    Messages:
    13,445
    Likes Received:
    461
    Incredible.

    I still have been unable to get this text macroes problem with the 2D client fixed.

    Now it is happening also with another character on a different shard.

    I make the text macro, link it to a keys combination but when I exit UO it is not saved no matter what.

    When I log back in I have to make the macro again anew.

    I tried locating the macro.txt files to add the text manually but I cannot seem to find in the macro.txt files I have on desktop any of the text at all....

    Apparently, the text is saved in some other files ?

    And no, as I said, the key combination is NOT used by UOAssist so I have no clue whatsoever why the 2D client is not saving it.
     
  12. Arch Magus

    Arch Magus Guest

    yes Incredible

    game breaking even
    :pancakes:
     
  13. Petra Fyde

    Petra Fyde Peerless Chatterbox
    Stratics Veteran Alumni Stratics Legend

    Joined:
    Jan 5, 2001
    Messages:
    30,882
    Likes Received:
    5,165
    I can't reproduce this.
    I logged in.
    I made a macro: 'say' 'all stay' set to 'ctrl' + 'W'
    I opened the file C:\Documents and Settings\me\My Documents\EA Games\Ultima Online Legacy\User Data\accountname\shard\charname\macros2d.txt
    The entry:
    W 1 0 0
    +S a y a l l s t a y
    ########
    clearly visible
    I totally closed the client. Re logged, macro still there.

    What keys are you setting your macro to? There are known problems with setting macros to the number pad.
     
  14. Arch Magus

    Arch Magus Guest

    why do you even help him anymore?

    it's the same crap i was reading years ago
     
  15. Petra Fyde

    Petra Fyde Peerless Chatterbox
    Stratics Veteran Alumni Stratics Legend

    Joined:
    Jan 5, 2001
    Messages:
    30,882
    Likes Received:
    5,165
    Because it is my nature to try to be helpful :)
     
  16. popps

    popps Always Present
    Stratics Veteran Stratics Legend

    Joined:
    Feb 27, 2004
    Messages:
    13,445
    Likes Received:
    461

    Just to make you an example, I went to one of the characters NOT saving macroes and the file (under DESKTOP --> Account --> Server --> Character name) is named macro2d.txt

    Inside this file I have :


    This is the ENTIRE content of the macro2d.txt file.

    Yet, I DO have way more macros I am using which are playing when I press the keys.
    How is this possible when the file does not have them as recorded at all ?

    The only answer to me would be if the rest of the content is stored in some other file which, apparently, is not saving some of the macros I am using.

    For text macroes I usually use either ALT + F#s or CTRL + F#s
    (F#s = any of the F1 --> F12 keys...).
     
  17. Harlequin

    Harlequin Babbling Loonie
    Stratics Veteran

    Joined:
    Jun 11, 2008
    Messages:
    2,716
    Likes Received:
    32
    The old desktop folder is no longer used. You are looking at the wrong macro file.


    1) For the Legacy client, both uo.cfg and macros.txt are now found in

    C:\Documents and Settings\<Your windows login>\My Documents\EA Games\Ultima Online Legacy\User Data\<Your UO account>\<Your shard>\<Your character name>\

    instead of

    <UO program folder>\Desktop\[accountname]\[shardname]\[charactername]

    2) macros.txt has been renamed to macros2d.txt



    Next, my question is, if you try another key combination, say something simple like F1, does the macro remain after restarting UO?
     
  18. popps

    popps Always Present
    Stratics Veteran Stratics Legend

    Joined:
    Feb 27, 2004
    Messages:
    13,445
    Likes Received:
    461

    Thanks !

    That helped me at least find the right files (I hope).

    Question, I have a Legacy Folder but also have a Stygian Abyss Folder.

    I still want the macro2d.txt files in the Legacy, NOT the SA folder ?

    I opened up the macro2d.txt file in the Legacy folder (User data) and it looks more complete with the other txt macroes I was using though, missing the ones which don't get saved.

    Question #2 is, I have some macroes in japanese txt which in UO look ok but with the text editor (notepad) look like this


    Now, clearly that is not japanese but apparently it is what notepad sees it as....

    Japanese would be, for example...

    I also tried using Word to load up the macro2d.txt file but even though I do get a prompt to codify the text used for japanese, then the file actually loads up in word the text is just a bunch of unreadable characters......

    Given this problem, how the hell do I add the japanese text I want the macro to say, manually ?

    I would REALLY much prefer if UO just saved my darn text macroes and forget about it....

    I cannot figure out why it is not saving some of them.
     
  19. Harlequin

    Harlequin Babbling Loonie
    Stratics Veteran

    Joined:
    Jun 11, 2008
    Messages:
    2,716
    Likes Received:
    32
    Correct. Edit the ones in the Legacy folder.

    The ones in the SA folder is for the EC client. There are no macro2d.txt files there.



    First, the simple way. When you create a macro and exit UO, the macro2d.txt file is actually updated. Invalid macros are only removed from the file when you start UO again.

    So create you macro, then exit the client normally.

    Now, before doing anything, make a backup of the macro2d.txt file. That way if you screw up something, you can revert to the backup.

    Next, open the file and look for your new macro, if the macro is recorded correctly, this should be there at the bottom of the file:

    Code:
    ########
    F7 0 1 0
    +Y e l l n04XT0Ñ‘o0ASRg0o0j0O0Áy‚0¢0¤0Æ0à0’0ÖS‹0S0h0L0g0M0~ 0Y00Áyn0×0í0Õ0£0ü0ë0’0‹‰‹0
    ########
    
    The second line stands for "alt+F7".


    If it's there, close the file and start UO (it's a good habit to close it because UO sometimes crashes if the file is locked).

    Login to your char, then exit the client. Re-open the macros2d.txt file. See if the macro is still there. If it still is, there's nothing wrong with the new macro. It's not triggering due to something else. Only thing I can think is that you have another macro set to the same key combo. Search the file for this.



    If the macro gets removed after re-starting UO/login/exit, then the key combo is invalid.

    If it doesn't even save at all, then something is interfering with the UO client writing to the macros2d.txt. Could be the Vista runas-admin issue, file permissions, read-only attribute or even your AV proggy locking it. Though this normally should crash the client whenever you exit UO.



    To see Japanese characters properly in notepad, you need to install support for east asian languages. (control panel->regional and language->languages->tick the "install files for East Asian Languages".

    Editing the macros2d.txt file to add a new macro is a pain, esp for speech as you need to insert a space between each char. Try to create it the UO client first and edit it in notepad.

    Extra note, if you edit the file after this and try to save, notepad may ask you to save it in "unicode" format, it is wise to do so normally. However, I am not sure how the UO client will react. If it doesn't work, just revert to the backup and try not saving in unicode.