1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

2D patch client and win7

Discussion in 'UHall' started by Clog|Mordain, Oct 4, 2010.

  1. Clog|Mordain

    Clog|Mordain Lore Master
    Stratics Veteran

    Joined:
    May 21, 2008
    Messages:
    1,135
    Likes Received:
    9
    I've recently upgraded my PC and OS. Ever since then, I cant get UO2D to patch. The program hangs at client 7.0.0.0. I've tried running as normal and as admin.... Tried uninstalling and reinstalling also


    Any help would be great
     
  2. Snakeman

    Snakeman UO Forum Moderator
    Moderator Professional Premium Wiki Moderator Stratics Veteran Stratics Legend

    Joined:
    Jun 13, 2002
    Messages:
    4,961
    Likes Received:
    165
  3. jtw1984

    jtw1984 Seasoned Veteran
    Stratics Veteran

    Joined:
    Jun 12, 2008
    Messages:
    301
    Likes Received:
    1
    Some of these solutions are kind of weak.

    1.) Did you try disabling any anti virus software?
    2.) Did you allow UO2D patcher threw firewall?
    3.) Try turning off UAC.
    4.) If that fails, dont you wish EA allowed patches to be downloaded via torrent? haha
     
  4. Lady CaT

    Lady CaT Seasoned Veteran
    Stratics Veteran

    Joined:
    Mar 24, 2010
    Messages:
    498
    Likes Received:
    407
    I think you need to change the programs compatability mode and change a few settings.

    Right click the UO icon select properties.
    Go to the Compatability mode tab.
    Choose Windows XP (Service Pack 3)
    then check the following
    Disable Visual themes.
    Disable Desktop Composition.

    If I recall its the Visual themes narfing up the 2D client updating.
     
  5. Petra Fyde

    Petra Fyde Peerless Chatterbox
    Stratics Veteran Alumni Stratics Legend

    Joined:
    Jan 5, 2001
    Messages:
    30,889
    Likes Received:
    5,175
    I'm playing CC on win 7. Go through the folder and set client.exe, patch.exe and uo.exe all as 'adminstrator'.
     
  6. Mandrake of DF

    Mandrake of DF Lore Keeper
    Stratics Veteran

    Joined:
    Oct 13, 2009
    Messages:
    854
    Likes Received:
    323
    This is because you installed it in prob c:\program files\ea games or ultima online

    Easiest way to do it, is find the install folder, right click it, choose properties. Go to security tab, on permissions choose edit. Add 'everyone' to that and check for full control.

    Then you never get a security problem anymore or have to run as administrator.

    Reason for this is that all programs that are placed in *program files* folder, get security settings to only be modified by administrators.

    If you had choosen another path for the install, like d:\games you would not have this problem.