1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

Been having a problem with mage casting in EC.

Discussion in 'UO Enhanced Client Discussion' started by Garrett, Feb 22, 2010.

  1. Garrett

    Garrett Guest

    So I'm not exactly sure what is going on when I try to cast. I'm 2/6 and casting simple things/combos I know I can do in the 2D client, but when I try them in EC the spells won't show up. I get no message about waiting to recover and if I hit the hotkey multiple times it will eventually go off but I am assuming that's now how it's supposed to be.

    Any ideas what might be wrong?
     
  2. Gildar

    Gildar Babbling Loonie
    Stratics Veteran

    Joined:
    Apr 22, 2004
    Messages:
    2,354
    Likes Received:
    4
    My guess is you're messing up with targeting.

    There is some info about that here:
    http://spellweave.com/samacrosactions.html
     
  3. Garrett

    Garrett Guest

  4. Zero Day

    Zero Day Guest

    If you are using the new targetting system instead of legacy this will throw spell timing off.
    This isn't so much on the fault of the client.
    New targeting system is really similar to casting a spell while holding down your last target macro.
     
  5. Garrett

    Garrett Guest

    It does it with both targeting systems. and it's more the delay between spells than how fast they are. In 2D i can just *cast**target**cast* while in EC I have to *cast**target**wait**cast* or the spell never shows.
     
  6. Clog|Mordain

    Clog|Mordain Lore Master
    Stratics Veteran

    Joined:
    May 21, 2008
    Messages:
    1,135
    Likes Received:
    9
    I am having this same problem.

    Anyone know the cause? and a fix?

    This is the only problem(client side) that sends me back to 2D with frustration
     
  7. Cloak&Dagger

    Cloak&Dagger Guest

    I think this is a visual limitation, you are use to how the 2d client registers. I suggest it this way because for awhile I had issues with casting (would over cast constantly, and then to prevent this would cast to slow) but after (I dunno how long I have been using the EC) I am getting the hang of it, granted I can still perform better in the classic client but then....12 years or more using it so I would hope I knew how to do it.
     
  8. Cetric

    Cetric Grand Inquisitor
    Stratics Veteran

    Joined:
    Aug 1, 2008
    Messages:
    4,110
    Likes Received:
    907
    You are having the same problem i had in the other thread it sounds.


    A dev said he would be looking into it this week.

    Its like you cannot chain spells, exp fs, weaken weaken weaken weaken, magic arrow fireball, etc etc. All of this unless you pause inbetween your spells instead of hitting last target immediately when the cursor comes up.



    Try this. I'm assuming you are using last target on your mouse wheel like i am. Make a key for last target and try it. To me it worked fine like this, but not right on the mouse wheel =(


    With the new targeting system you can cast spells smooth by just hitting the spell key. The spell will auto target your "target". But it sucks because it is semi complicated compared to 2d to switch targets, target ground, teleport, etc etc etc
     
  9. Cloak&Dagger

    Cloak&Dagger Guest

    I use one of my mouse buttons for target self and target last so I can not really say if what I posted above is what is happening to you or not, perhaps I will try it with my mouse wheel...except that messes me all up heh.
     
  10. Cetric

    Cetric Grand Inquisitor
    Stratics Veteran

    Joined:
    Aug 1, 2008
    Messages:
    4,110
    Likes Received:
    907
    i just thought of something, and i dunno if its the case until i go home today.

    But i wonder if its something from spinning the mouse wheel? like you hit last target 3 or 4 items technically by moving the mouse wheel forward vs simply hitting a key? and maybe there is something with that in the ec?