1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. The Broadsword team is seeking alternative castle designs! Learn more and discuss here!
    Dismiss Notice
  4. Publish 97 is currently on TC1! They are currently focusing on the pet customization aspect of the pet revamp. Head to TC1 and send in your feedback or discuss here!
    Dismiss Notice
  5. Broadsword is hosting a 20th Anniversary Party for UO this September! Learn more here. Will you be there, Guest?
    Dismiss Notice
  6. A new State of Stratics is up. Check it out here!
    Dismiss Notice

Bone Machete Quest Prob

Discussion in 'UO Europa' started by Shazzam Kabarr, Sep 20, 2009.

  1. Hi guys,

    I'm kinda stuck on this quest. I'm at the part where I have to hand in 10 bones to the guy in jhelom, 'Already Dead' part of the questline.

    I have the bones, but just get a single 'ding' when I mark them as a quest item, like it wants more. Needless to say, the guy won't accept them. I tried everything I can think of, retook the quest, restarted the entire questline, logged out, got new bones, quest marked bones singly and in a stack. You name it, I think I tried it.

    I sent a help request and got a canned response, re tried and was told to bug report it and not to expect a response. Doesn't really help me much though in getting the recipe.

    Can anyone help please?
  2. cheerful

    cheerful Guest

    *like it wants more*
    have you tried giving more ?
  3. yes, from 10 to over 200.
  4. all sorted. 3rd time lucky with the petition :).
  5. Risso

    Risso Babbling Loonie
    Stratics Veteran

    May 15, 2008
    Likes Received:
    Did you have other quests active?