1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. The Broadsword team is seeking alternative castle designs! Learn more and discuss here!
    Dismiss Notice
  4. Broadsword is hosting a 20th Anniversary Party for UO this September! Learn more here. Will you be there, Guest?
    Dismiss Notice
  5. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice

[Blacksmithing] Can't turn in BODs for some reason

Discussion in 'UO Craftsman' started by TG_Owned, Oct 13, 2008.

  1. TG_Owned

    TG_Owned Guest

    I try to give a BOD to the blacksmith (tried 10 different towns) and they all say, Thou art giving me a bulk order deed? I'm not interested.

    I tried it on my other character and it works just fine. First started happening last night, same thing this morning.

    I haven't work BODs for about 3 years, is there something changed?
     
  2. miss uo

    miss uo Guest


    Left click on your char, if theres a quest log there, you have an unfinished quest. Either finish the quest or cancel it.
    I know there has been a issue around for a long time, concerning handing in bods and certain quest.
     
  3. TG_Owned

    TG_Owned Guest

    :bowdown::bowdown::bowdown:

    That was the problem!!!

    Thanks so much. :D
     
  4. miss uo

    miss uo Guest

    Good boding to you. Enjoy