1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

[BUG] CRASH on Start

Discussion in 'UO Enhanced Client Discussion' started by Caelas, Aug 20, 2009.

  1. Caelas

    Caelas Guest

    After the 191MB patch tonight, I see the spashscreen with the Gargoyles...then the client closes. Kinda sucks, need some help. Running Vista, everything was fine earlier today.
     
  2. Same prob here too, running on xp
     
  3. BTeng_Mythic

    BTeng_Mythic UO Legend
    VIP Stratics Veteran

    Joined:
    Sep 2, 2008
    Messages:
    118
    Likes Received:
    0
    Locate the folder where you installed the Enhanced Client in (default location is \Program Files\Electronic Arts\Ultima Online Stygian Abyss).

    In that folder, there is a file called "mft.myp". This is the manifest file that keeps track of the versioning of each file that the patcher updates.

    Delete that file and try patching again. Let me know if there are any new files that get patched up after this process and if the crash is still happening.
     
  4. kamiiyu22

    kamiiyu22 Visitor
    Stratics Veteran Stratics Legend

    Joined:
    Sep 23, 2004
    Messages:
    21
    Likes Received:
    4
    Hi,

    Delete the file "mft.myp", run uosa.exe, patcher re-create the file "mft.myp", no files got patch, still crash to desktop after the pressing "Play".

    OS is Window 7 Ultimate 64 bit.
     
  5. BTeng_Mythic

    BTeng_Mythic UO Legend
    VIP Stratics Veteran

    Joined:
    Sep 2, 2008
    Messages:
    118
    Likes Received:
    0
    Gonna look into this first thing tomorrow. Sorry for the inconvenience.
     
  6. kamiiyu22

    kamiiyu22 Visitor
    Stratics Veteran Stratics Legend

    Joined:
    Sep 23, 2004
    Messages:
    21
    Likes Received:
    4
    Hi Billy,

    I can send you the log if that's gonna help, I can't post it on here since it's too big 129K. Please leave email address here or pm me your email address so I can send it over.

    Thanks for looking into this.
     
  7. IanJames

    IanJames Certifiable
    Stratics Veteran Alumni

    Joined:
    May 19, 2008
    Messages:
    1,769
    Likes Received:
    101
    I'm on Vista, patched successfully, no client crash here.
     
  8. Barry Gibb

    Barry Gibb Of Saintly Patience
    Stratics Veteran

    Joined:
    May 24, 2008
    Messages:
    1,429
    Likes Received:
    235
    I am having the same issue. My PC is running XP. I was going to give the client another try today too :sad4:

    Stayin Alive,

    BG
     
  9. htapro

    htapro Visitor
    Stratics Veteran Stratics Legend

    Joined:
    Jan 16, 2006
    Messages:
    8
    Likes Received:
    0
    Client is doing the same for me as well after todays patch. Running XP Pro.
    Not sure if this is related: the first attempt to patch failed, the second attempt was successful. Patcher log is filled with errors from the first attempt, but has no errors from the second.
    Cheers!
     
  10. pgcd

    pgcd Guest

    Same here, running win7. Will try patching again (but i see no log).

    Ok, I tried patching, to no avail: no file was patched - this is what the patcher's log has to say about it:
    Code:
    [2009/08/21 17:47:39] libpatchclient initialized.
    [2009/08/21 17:47:39] Currently running as [C:\Program Files\Electronic Arts\Ultima Online Stygian Abyss\uopatch.exe]
    [2009/08/21 17:47:40] Currently running as [C:\Program Files\Electronic Arts\Ultima Online Stygian Abyss\uopatch.exe]
    [2009/08/21 17:47:40] Notification of restart with alternate filename
    [2009/08/21 17:47:41] libpatchclient initialized.
    [2009/08/21 17:47:41] Currently running as [C:\Program Files\Electronic Arts\Ultima Online Stygian Abyss\uopatch.bin]
    [2009/08/21 17:47:42] Nothing to patch for [EAMythic Patcher]
    [2009/08/21 17:50:54] Nothing to patch for [UO Test]
    [2009/08/21 17:50:54] Patch Operation Complete.
    
     
  11. BTeng_Mythic

    BTeng_Mythic UO Legend
    VIP Stratics Veteran

    Joined:
    Sep 2, 2008
    Messages:
    118
    Likes Received:
    0
    Absolutely. Send the log to: [email protected]

    Thanks, it's much appreciated.

    To the rest of the folks, just want to let you guys know, we're still looking into this.
     
  12. EnigmaMaitreya

    EnigmaMaitreya Crazed Zealot
    Stratics Veteran

    Joined:
    May 12, 2008
    Messages:
    3,402
    Likes Received:
    0
    Just Curious ....

    While BT is working his magic .....

    First off, I run Windows 7 32 Bit on one machine and Windows 7 64 Bit on the other machine.

    The 32 Bit version is running a Celeron D CPU
    The 64 Bit version is running a Core 2 Quad Core CPU.

    Both work just fine for the Enhanced Client, the KR client, the Enhanced Classic 2D Client and the 2D client.

    Some questions,

    1) Are your Video Drivers up to date in specific and more generally speaking are there any outstanding updates you have not applied to your Windows 7 RTM

    2) Is your computer a single or multi core processor.

    3) What is the Video Card your using.

    4) What is the sound system your using and do you ever hear the SA music.

    Now I am trying to remember if the UAC gets involved AGAIN after the patcher. Naughty me, I just turn the dumb thing off and I think the MS Firewall only gets involved once but it may be twice asking if it should allow the program(s) to access the internet.
     
  13. BTeng_Mythic

    BTeng_Mythic UO Legend
    VIP Stratics Veteran

    Joined:
    Sep 2, 2008
    Messages:
    118
    Likes Received:
    0
    Got my hands on the log. Thanks, kamiiyu22.
     
  14. htapro

    htapro Visitor
    Stratics Veteran Stratics Legend

    Joined:
    Jan 16, 2006
    Messages:
    8
    Likes Received:
    0
    Just tried it again "for kicks" ... seems like another small patch came through, and all is working fine now!
    Many thanks :)
     
  15. BTeng_Mythic

    BTeng_Mythic UO Legend
    VIP Stratics Veteran

    Joined:
    Sep 2, 2008
    Messages:
    118
    Likes Received:
    0
    It looks like certain files did not patch up gracefully for a small percentage of you.

    We enabled a one-time only full file check on our end, so the next time you run the patcher for the client, it will run a verification step on all existing game files to see if they're correct.

    Let us know if this solves the issue for you guys. It looks like one person already has things straightened out. :)
     
  16. Kiminality

    Kiminality Guest

    Couldn't we get an option on the patcher to trigger a verification ourselves?
     
  17. pgcd

    pgcd Guest

    Ehm - I guess I'm part of the small percentage, as even the latest patch did nothing to solve my issue. First time I ran it, tho, I got a popup message about a corrupted server-side file (TerrainDefinition.uop), and the log shows something along those lines.
    I'm sending a zipped copy of the log to the mail you provided, but I should warn you that I made a few experiments earlier, renaming those files that seemed to have had troubles with patching, to force a new download.
     
  18. Caelas

    Caelas Guest

    The tester is working, I can verify that. It's checking my files...It works! THANK YOU!

    Edit....WTF the coastlines are BRIGHT PINK! The tan area going up to the grass...yeah...like, punk rocker PINK...oOMG all the tan areas are PINK!!!

    [​IMG]
     
  19. Caelas

    Caelas Guest

    More pink LOL

    [​IMG]
     
  20. htapro

    htapro Visitor
    Stratics Veteran Stratics Legend

    Joined:
    Jan 16, 2006
    Messages:
    8
    Likes Received:
    0
    LOL ... for me too. As attached image shows, hillside art is displaying as: "BAD ART ID CONTACT ENGINEERING"
     

    Attached Files:

  21. BTeng_Mythic

    BTeng_Mythic UO Legend
    VIP Stratics Veteran

    Joined:
    Sep 2, 2008
    Messages:
    118
    Likes Received:
    0
    Got the log. Thanks. We'll keep looking into this.
     
  22. Caelas

    Caelas Guest

    Even better inside the Malas Mines...

    [​IMG]

    Dr. Raymond Stantz: So you think there's a link between this Viggo person and the uh...slime?
    Dr. Egon Spengler: Is the atomic weight of Cobalt 58.9?
     
  23. Supreem

    Supreem Founder, Citadel Studios
    VIP Stratics Veteran

    Joined:
    Sep 2, 2008
    Messages:
    153
    Likes Received:
    25
    We rebuilt and repushed the patch out. Please try again and let us know if you are good.
     
  24. Hildebrand

    Hildebrand Certifiable
    Stratics Veteran Stratics Legend

    Joined:
    Oct 12, 2005
    Messages:
    1,697
    Likes Received:
    1
    How about looking into the Crash on Exit now?
    Game runs perfect for me, but exiting will always give the windows error message on my Vista 64. It sends report back.
     
  25. Ereon

    Ereon Guest

    I'm still getting the crash on startup here. Got patch errors a couple of times (i can't remember specifically what file was the error though), but it then finalised properly after a couple of attempts. I have tried deleting the mft.myp file and trying again. The patching completes but the client still exits as soon as it gets to the Gargoyle splashscreen. I'm using Vista 32bit

    Any ideas?
     
  26. Caelas

    Caelas Guest

    Still pink, didn't see my client grab any new patch. I'm assuming you guys have a way to tell the client the patch is different...
     
  27. kamiiyu22

    kamiiyu22 Visitor
    Stratics Veteran Stratics Legend

    Joined:
    Sep 23, 2004
    Messages:
    21
    Likes Received:
    4
    HI Billy and Supreem,

    Download the patch, all files patched according to patcher, run client and no crash to desktop.
    Read the log and it show a bunch of corrupted files.
    Exit client, no error message either.
    Have the pink problem, please see attached picture.
    Patch log provided as well.
    OS: Window 7 Ultimate 64bit

    Thanks for the help.
     

    Attached Files:

  28. Sweeney

    Sweeney Guest

    Getting this in my patch log (patch fails after downloading uopatch.exe)

    [2009/08/21 19:46:39] libpatchclient initialized.
    [2009/08/21 19:46:39] Currently running as [C:\Program Files\Electronic Arts\Ultima Online Stygian Abyss\uopatch.exe]
    [2009/08/21 19:46:39] Currently running as [C:\Program Files\Electronic Arts\Ultima Online Stygian Abyss\uopatch.exe]
    [2009/08/21 19:46:41] Notification of restart with alternate filename
    [2009/08/21 19:46:42] libpatchclient initialized.
    [2009/08/21 19:46:42] Currently running as [C:\Program Files\Electronic Arts\Ultima Online Stygian Abyss\uopatch.bin]
    [2009/08/21 19:46:42] Patch size is 353039
    [2009/08/21 19:46:45] Failed local write for remote file [base/unpacked/3673c7b744e84ee9].
    [2009/08/21 19:46:45] Failed [1] files for product [EAMythic Patcher].
    [2009/08/21 19:46:45] Failed to patch stage [main].
    [2009/08/21 19:46:45] Failed to patch patcher product.

    Is this problem on my end? It was working fine before.
     
  29. pgcd

    pgcd Guest

    No patch here after the "forced check" one.

    And no luck either - will try uninstalling and reinstalling.
     
  30. Sweeney

    Sweeney Guest

    Bump.......
    Pleae fix this I haven't even reset my 2d macros yet after reformatting my HD. I love SA/EC.. fix it :bored:
     
  31. pgcd

    pgcd Guest

    Uninstalled and reinstalled, got more patching errors in the process, but now everything seems to work (didn't have time to check for textures tho).
     
  32. I got the pink colour all over the screen too now with the art probs, tried deleting the "mft.myp" file and still same ...too bad this happened on the weekend
     
  33. Der Rock

    Der Rock Guest

    :)the game runs fine again on my Vista computer ;) thx
     
  34. BTeng_Mythic

    BTeng_Mythic UO Legend
    VIP Stratics Veteran

    Joined:
    Sep 2, 2008
    Messages:
    118
    Likes Received:
    0
    The suggestion at this point is to re-install the client if you are still running into issues. Your macros and user settings will be unaffected by this process, but if you wish to back these files up, it is located in: \My Documents\EA Games\Ultima Online Stygian Abyss

    We are continuing to work with other engineers to figure out the root of this problem so that the patching process will go smoothly for all players in the future.

    Apologies to those who are affected by this issue.
     
  35. EnigmaMaitreya

    EnigmaMaitreya Crazed Zealot
    Stratics Veteran

    Joined:
    May 12, 2008
    Messages:
    3,402
    Likes Received:
    0
    Something I noticed .... when running UBUNTU.WineX was that the client would crash like being described.

    What the solution was .... was to copy the directx dll into the correct directory. That solved that problem.
     
  36. Re-installing fixed the problem! And all macros were there too(i backed em up just incase) no more pink and missing art!
     
  37. Sweeney

    Sweeney Guest

    A 1.8 gig download each time the patcher screws up? Ouch, for me that's a 5 hour download.
     
  38. kamiiyu22

    kamiiyu22 Visitor
    Stratics Veteran Stratics Legend

    Joined:
    Sep 23, 2004
    Messages:
    21
    Likes Received:
    4
    Re-install fix the problem, still got patch error and have to restart the patcher.
    All the pink area are back to normal.

    Thanks.
     
  39. Sweeney

    Sweeney Guest

    About to test it myself.. it's a sad thing though, if a redownload of 1.8 gigs is required each time there is a screw up.
     
  40. Sweeney

    Sweeney Guest

    It worked.. nice to know personally, but terrible considering the cost, 1.8 gigs of download.
     
  • About Us

    Stratics is the oldest continually running MMORPG Fansite on the Internet. Founded in 1997 Stratics has served the Ultima Online Community for 18 years. We strive to provide the most complete social experience for Ultima Online players.
  • Subscribe Now!

    Want to provide Continual Support? Subscribe and gain additional benefits as a patron of Stratics.com!
    Subscribe Now!

    Stratics Professional Accounts feature the following advantages:

    • Ad-Free Browsing of our Forums
    • Upload a custom Profile Cover
    • Unlimited media upload storage space
    • Use of the theme styler
    • Ability to collapse the sidebar
    • Premium background themes to choose from
    • Access to additional features of the Classifieds System
    • Ability to Customize Your User Title
    • No Post Delays
    • Additional Signature Allowances:
    • Special Professional Banner Display with your Account
    • PM Allowance Upgrade
    • Additional Thread Allowances
  • Support Us!

    Don't feel like subscribing? Donations to benefit the further development of Stratics and for purchase and inclusion of additional features are always welcome.

    Donate to us!