1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

Did I miss something?

Discussion in 'EA Land/The Sims Online Stratics Forums' started by ayla02, Feb 19, 2008.

  1. ayla02

    ayla02 Guest

    or is just me that I cannot log into the game?
     
  2. Just keep trying is all I can tell ya. If you don't have any luck, maybe post some specifics on whats happening because there are a few here that have been very helpful to me with many problems i've had.
    Good luck with it!
     
  3. ayla02

    ayla02 Guest

    Been trying all morning. Getting the "Could not connect to server error" and an error updating the updater." Last night I logged into the production cities to changed my property names and this morning I can't get back to EALand.
     
  4. philw1

    philw1 Guest

    find the tsoclient icon in your ealand or tso folder and use that to log in. It skips the updater which apparently broken again.
     
  5. ayla02

    ayla02 Guest

    Takes me to production cities
     
  6. dinaj

    dinaj Guest

    I can't get in either ... [​IMG]
     
  7. ayla02

    ayla02 Guest

    OK! Going on three hours here of trying to connect and not being able to. WTHeck EA?????
     
  8. Guest

    Guest Guest

    There is a problem with the updater as reported in this thread. Are you having the same issue? It is being worked on, hang in there.