1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

Disable Pathfinding in EC?

Discussion in 'UO Enhanced Client Discussion' started by kitiara-atlantic, Feb 18, 2013.

  1. kitiara-atlantic

    kitiara-atlantic Lore Master
    Stratics Veteran Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    1,058
    Likes Received:
    77
    Hi everybody,

    Is there a way to disable pathfinding and auto-run in EC? You know... the thing that makes you automatically walk after your mouse when you (accidentally) double right click the mouse?

    I see the "Auto-run Enabled" checkbox in Settings (I'm also using Pinco's). I have it UN-checked.

    I don't see a setting for pathfinding in the Settings within the client, but I did find this in my character's user data file (and set them all to false instead of true).

    <AlwaysRun enabled="false" />
    <EnableAutorun enabled="false" />
    <EnablePathfinding enabled="false" />

    Nothing changes. I still manage to constantly auto-run or pathfind or whatever it is called when your character automatically follows your mouse without having any mouse buttons pressed. I don't want this to happen.

    Help! I can't stand pathfinding!! Please make it stop! I've been fighting it for years!

    Thanks [​IMG]
     
  2. Storm

    Storm UO Forum Moderator
    Moderator Professional Premium Wiki Moderator Stratics Veteran Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    7,469
    Likes Received:
    361
    I run into this problem when running into my house when the video card draws my interior for some reason it makes me auto follow drives me nuts. Not figured out a solution yet!
     
  3. kitiara-atlantic

    kitiara-atlantic Lore Master
    Stratics Veteran Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    1,058
    Likes Received:
    77
    I've figured out that it's when I accidentally click the left mouse button while holding the right one (like when I'm walking, and then go to click to open a door or visit a vendor).

    I submitted an EC bug report, though I don't expect anything of it. :(
     
    Storm likes this.
  4. Leira of Asrai

    Stratics Veteran Stratics Legend

    Joined:
    Jun 6, 2005
    Messages:
    686
    Likes Received:
    51
    That's not a bug. It's intended. Holding right mouse, clicking left mouse will allow you to walk w/o holding down the mouse buttons. I don't like how a health bar will get stuck to your cursor if you hold the right mouse and left click the health bar.