1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

Disable Pathfinding in EC?

Discussion in 'UHall' started by kitiara-atlantic, Mar 1, 2013.

  1. kitiara-atlantic

    kitiara-atlantic Lore Master
    Stratics Veteran Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    1,058
    Likes Received:
    77
    Hi everybody,

    Is there a way to disable pathfinding and auto-run in the Enhanced Client? You know... the thing that makes you automatically walk after your mouse without holding the mouse button down?

    I see the "Auto-run Enabled" checkbox in Settings (I'm also using Pinco's UI). I have it UN-checked.

    I don't see a setting for pathfinding in the Settings within the client, but I did find this in my character's user data file (and set them all to false instead of true).

    <AlwaysRun enabled="false" />
    <EnableAutorun enabled="false" />
    <EnablePathfinding enabled="false" />

    Nothing changes. I still manage to constantly (accidentally) auto-run or pathfind or whatever it is called when your character automatically follows your mouse without having any mouse buttons pressed. I don't want this to happen.

    Help! I can't stand pathfinding!! Please make it stop! I've been fighting it for years!

    Thanks [​IMG]
     
  2. kongomongo

    kongomongo Lore Master
    Professional Campaign Supporter

    Joined:
    Sep 10, 2012
    Messages:
    1,039
    Likes Received:
    233
    Enable Autorun enables the following: if you hold down right mouse button to walk and then press the left mouse button while holding down right mouse button you will automatically walk without having to hold down mouse button.

    You can enable/disable in settings as you have written.

    BUT: there is a bug in the games event processing that sometimes when the game stutters a bit and you release right mouse button it will simply not receive that "button-up" event and continue to walk. Have to right click again to stop. It's a very annoying bug and cant be turned off atm.
     
  3. kitiara-atlantic

    kitiara-atlantic Lore Master
    Stratics Veteran Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    1,058
    Likes Received:
    77
    Thanks, kongomongo! That must be the bug I am encountering. It did "feel" a bit different once I set those three values to false, but didn't eliminate the walking. I will keep my fingers crossed for a bug fix!