1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

Enhanced Client Performance

Discussion in 'UO Enhanced Client Discussion' started by Kiminality, Dec 13, 2009.

  1. Kiminality

    Kiminality Guest

    Something just occurred to me, and I'm kicking myself that I didn't consider it previously.

    Performance issues in the EC have been a little inconsistent, often with no apparent link to video hardware.
    It only took months, but it finally sunk in that the EC is based on the Gamebryo engine, and hence issues that have existed in other Gamebyro-based games may have been inherited.
    I used to have some performance issues in Oblivion, which also manifested in Fallout 3, which combined with generally worse performance on my less-than-top-of-the-line laptop, lead me to research a little.
    The remedy was simple, if non-intuitive - To turn down audio hardware acceleration in the Windows control panel.

    I couldn't even begin to say why that made a difference in those games, when the problem didn't exist in other engines.
    But, what worked for two Gamebryo games may work for a third, in some cases.
    I don't, personally, have any performance issues in the EC, though, so I can't exactly test the theory.
     
  2. Der Rock

    Der Rock Guest

    where i find this :)


    on one computer, (with nvidia card) i have problems if i enter undead sound areas,
    would be interesting if this change help.


    thx
     
  3. Kiminality

    Kiminality Guest

    In XP, it's something like:
    Control Panel --> Sounds and Audio devices --> The "audio" tab
    Click the "advanced" button under the "Sound Playback" section
    Then, the "performance" tab, and there should be a slider

    Adjusting it seems to have very little impact on sound quality, none that I could notice anyway.
     
  4. Nenime

    Nenime Guest

    Hmm... wouldn't turn off the hardware acceleration lead to more software driven impact and thus to more CPU load?

    Anyway, with every patch EC is working worse for me (on both computers) and I'm so desperate I will try almost anything. Thanks for the tip though, Kim. I will tell you if that helps.
     
  5. Fink

    Fink Guest

    Thanks for the tip! I doubt many people would have thought of that solution or associated it with EC performance.

    I had hardware acceleration on full; it's now on none. I didn't have many issues with the EC on my new computer, but I'll play-test the hell out of it on my old one and see if there's any improvement there.
     
  6. Kiminality

    Kiminality Guest

    I had the exact same reaction, when I read about that for Oblivion and Fallout 3. It just straight-up didn't make a whole lot of sense.
    But, the change took me from unplayable stuttering in combat (which is tough when you use magic, and have no natural magicka regen (thanks, Atronarch!)), to basically only having consistent light stuttering from lowish hardware.

    I don't think it will help with any of the display bugs or glitches, if it makes any difference at all.
    If anything, it would likely only help with circumstantial stuttering.

    The problem I'm seeing with the theory is that this computer, which had the issues with the other games, hasn't ever had similar issues with the EC.
    Although, a P4 1.6 with 512MB RAM and a GeForce 4 MX desktop used to run KR without any problems, either. That computer had some variety of Creative sound card, which if the hardware acceleration is an issue, may explain why it didn't have any issues (this laptop has some terrible onboard SigmaTel card).
     
  7. Fink

    Fink Guest

    EC had massive stuttering issues on my old PC, but that same one ran KR fine.

    It doesn't seem to be patching at the moment, so.. I'll have to figure that out first.