1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. The Broadsword team is seeking alternative castle designs! Learn more and discuss here!
    Dismiss Notice
  4. Publish 97 is currently on TC1! They are currently focusing on the pet customization aspect of the pet revamp. Head to TC1 and send in your feedback or discuss here!
    Dismiss Notice
  5. Broadsword is hosting a 20th Anniversary Party for UO this September! Learn more here. Will you be there, Guest?
    Dismiss Notice
  6. A new State of Stratics is up. Check it out here!
    Dismiss Notice

fixed

Discussion in 'UHall' started by The Home Guild, Oct 17, 2009.

  1. sablestorm

    sablestorm Certifiable
    Stratics Veteran

    Joined:
    Aug 23, 2008
    Messages:
    1,994
    Likes Received:
    339
    Re: Upgraded to Sa just now and can't go there?

    I suspect there's an issue with the account server right now. I tried activating an account yesterday for RP purposes and it said my billing address was wrong, despite the fact I verified and tried several times. I wound up with 7 $1 charges pending on my bank statement, no doubt pre-authorizations. I was curious as to why the pre-authorizations would go through and not the regular charge, however.

    At any rate, with the Return to Britannia promotion winding down, it's a prime time for hiccups to occur which is what I figure is happening.