1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

[Gardening] FoF - QA Requests Plant Bug Reports

Discussion in 'UO Botany and Nutrition' started by Hyssmaye, Aug 22, 2008.

  1. Hyssmaye

    Hyssmaye Seasoned Veteran
    Stratics Veteran Stratics Legend

    Joined:
    Aug 16, 2004
    Messages:
    342
    Likes Received:
    9
    From the FoF:

    "QA Request of the Week

    QA has seen some complaints that plants don't always behave as intended - sometimes they lose health or die suddenly even when they're being properly taken care of - and they would love to see some detailed reports from people who've experienced the problem. Please include things like what the expected result was, what the actual result was, what kind of seed was used, whether fertile dirt was used, and as many other details as could possibly be relevant. Thanks!"
     
  2. Hyssmaye

    Hyssmaye Seasoned Veteran
    Stratics Veteran Stratics Legend

    Joined:
    Aug 16, 2004
    Messages:
    342
    Likes Received:
    9
    Borrowed the following bug-reporting info from one of Fayled Dhreams' posts:

    You can email bugs to:

    uobugs AT uo DOT com

    Bug reports should contain the following information:

    * Client Version Number. This is located at the bottom of the main UO login screen.
    * Server(shard) Name
    * Detailed Bug Description (step-by-step, tell us what you did and what happened)
    * Date/Time of Occurrence
    * Location (Sextant coordinates, facet, and city location)
    * On-site references (If you spoke with any official OSI representative, what was his/her name and what were you told?)

    OR to report a bug in-game:

    2D Client: Help -> other -> report a bug (2D)
    KR Client: Main menu -> bug report (KR)
     
  3. Flora Green

    Flora Green Guest

    Unfortunately I didn't pay attention to the time I planted my last batch or keep close enough notes, but my growth cycles are all over the place. I do know that when I plant a batch it's always within seconds of each other and then they are grouped into a certain area. Couple days later I do it again, etc. I have plants within the same batch that are still saplings while others are thriving. I have diseased and wilted and vibrant. It's very strange. I'll be planting more tomorrow and will keep track of time, seed type, etc. I didn't use fertile dirt for any of them.
     
  4. Eslake

    Eslake Guest

    Given the nature of the problem(s), it will be difficult to track down short of an obvious coding mistake.

    This seems to hit at random, so those most likely to be effected are those who also have the most plants growing at any given time, and therefore the least ability to accurately track the specifics of all of their plants.

    I am going to begin keeping a journal, and suggest others - who wish to help find the bug and have the time to - do the same.
    Since we are trying to find the cause, we need to consider every factor we can.

    Shard / Facet / and Location (backpack, bank, lockdown)
    Time of planting
    Type of soil used
    Type and Color of seed (and whether or not it is identified as such)
    Source of the seed
    Potions applied
    And a daily entry for markers and further potions/watering.

    I know it looks like a massive undertaking for anyone handling more than a handfull of plants, but short of a random lucky discovery on their end I don't see any other way to find the source of the problem.

    I would simply write a program to monitor it all, but they have not been approving apps for a long time and I won't take that kind of risk. :(
     
  5. feath

    feath Guest

    i just finished gathering 150 mixed seeds - color, named, un-named, plain - and was going to plant them today.
    i'll take notes. lots of notes.
    i had felt the growth rate better - at least, not as dramatic as when i first noticed it. but, due to the sheer amount of plants i got going at any one time, without notes, its impossible to say for SURE there's something off.
    just a couple of 'hey, these should be giving resources by now' kind of feelings.

    Well, should have some results in a couple of weeks.
     
  6. Flora Green

    Flora Green Guest

    I can list all of the factors suggested by Eslake except seed source. Obviously if I take it off of a plant I can, but I have chests full of loose seeds I need to get rid of. If I find a plain campion on a vendor for 25 gp I buy it and people give seeds as well. I really have no clue where half of those seeds came from. :)
     
  7. Hunters' Moon

    Hunters' Moon Grand Inquisitor
    Stratics Veteran

    Joined:
    Oct 19, 2004
    Messages:
    4,271
    Likes Received:
    120
    It seems to me that the problem is not just with plants. My aquarium has read "overfed" the last 8 days even though I have not added any food at all to the tank.
     
  8. Ashyn

    Ashyn Guest

    I'm not "testing" this problem. It's not my job (nor did I sign up for gardner's beta).

    However, I'll say this. Planted ONE plant last week (normal dirt). Added the standard water and potions and the following day I had a bowl of hard dirt. That was enough for me to know a problem existed and it wasn't worth my time to try to find out what exists in coding I can't see nor understand.

    All I know is that it just doesn't work.
     
  9. Hunters' Moon

    Hunters' Moon Grand Inquisitor
    Stratics Veteran

    Joined:
    Oct 19, 2004
    Messages:
    4,271
    Likes Received:
    120
    Getting "hard dirt" is normal and is intended after each server up.
     
  10. DHMagicMan_1

    DHMagicMan_1 Guest

    Getting "Hard Dirt" with a sappling or something in it would be normal, if it's only "Hard Dirt" and the seed and plant are gone completely that wouldn't be normal I wouldn't think.

    I'm not sure if that's what Ashyn meant though.
     
  11. Flora Green

    Flora Green Guest

    A power outage resulted in my not being able to tend to the plants so any info I had is skewed now. However, I have to say I'm in agreement with Ashyn that it's not my place to test this. I'll report a bug, but I'm not doing the job of the QA department. Besides, I barely have time to care for the plants and check vendors.
     
  12. feath

    feath Guest

    i tried this for 3 days - it turned my fun, mindless gardening into grinding, nasty work. i hate the phrase "it's not my job", but by god, it's not my job.
    i'm a player, not tech.
    i did notice it's not until day 5 things go glitchy. i noticed on a char NOT the one i was using for this bug report, that all my day 5s are on their second day 5.
    i'm taking screen shots of all the open pot reports, and lining them up. 1 photo, 20 plants.
    i'll just keep taking screen shots of this lot over the days, and send them in.
     
  13. feath

    feath Guest

    well, i replicated the bug, just not on the char i'd intended to ;)

    photo evidence of doing day 5 twice, skipping day 6, jumping to day 7. random jumps from vibrant to healthy. (considering EVERY SINGLE PLANT in every char was 'vibrant' this morning, i consider that abnormal)
    i'll give it to day 8, tomorrow, and send the pics in to bug control.
    i did mess up on 2 plants this morning, hitting the wrong potion control, but in a way thats good - see if it responds appropriately tomorrow.
     
  14. Spellbound

    Spellbound Lore Keeper
    Stratics Veteran

    Joined:
    May 12, 2008
    Messages:
    810
    Likes Received:
    90
    Are you folks with buggy growth using recycled plant bowls, as in emptied out and refilled, or did they have fertile dirt in them at any time? Thinking of residual contamination causing extra growth. I know Feath is using a backpack for growth checks. Is anyone getting messed up growth from ones locked down in a house, or from ones grown in a bankbox or packy? The checks for plant growth was documented as every 24 hours, after server maintenance for locked down in house/bank box, and after at least 24 hrs from when a player last logged in if grown in their backpack. Was there a change once from 24hrs to 23 hour checks, around 2 or 3 years ago? A 23 hr check combined with an unsaved character and contents update due to server downtime/ character not logged in long enough (at least a half hour?) might result in a skipped day and drop in health status. Thus the gardener could be logging in essence 2 days later and finding a very sick young seedling.
    Some thoughts on deco plants dying for no reason. Anyone getting dead plants(deco/frozen growth) in a house secure container? The few buggy ones that died inexplicably for me in the past were all locked down in deco mode, 2 of them died on the same tile!
     
  15. feath

    feath Guest

    first, if i'd feel inclined to do a huge datebase to include all that information, i would. take a wild guess ;) i'm not drawing a paycheck here.
    second, as all my pots are on a char backpack, the lovely thing about that is i can skip days, and they just wait for me. i've done this without getting dinged.
    third, there is likely 1 or 3 other people sending in lockdown/bank/paki information. they can contribute their bit to my bit.

    honestly, there are so many huge variables in plant making, theres no way one person can do it all. send in what you got. let the professionals figure it out. Stop making it more complicated than it is, or people will throw up their hands and say no way i'm doing this.
     
  16. Beastmaster

    Beastmaster Guest

    I started 15 plants in my toon's backpack this week. Used new bowls with normal dirt. I'm trying to track my activity with them in a spreadsheet. The only weirdness I've seen so far is in the time it takes it to grow. Planted them at 7:30PM EST on the 25th. Last night, 27th, they didn't grow until 8:30PM. So its been like 24.5 hours each day. If it's 9PM tonight then I'll feel confident about the timeline. That would lead me to believe its 24 hours plus server downtime since that is roughly 1/2 hour for my shard each day.

    We'll see.

    edit: Plants finally grew at 10PM EST.
     
  17. feath

    feath Guest

    as far as i - the player layman - can tell, the bug starts on day 4. The random factor of which plants are effected (while some in the same pack are not) I can't tell.

    It has to start on day 4, because some plants end up dead on day 7, so it needs '3' days of stats for this to happen.

    day 4 - you're plants are vibrant and healthy. you 'care' for them. The system doesn't see this care. (thinking about this, that means the plant is stuck on day 3 info, cause you're not effecting day 4 plant prodduction at all)

    day 5 - the -same- data from day 4 is displayed on day 5. everything is 'vibrant' and 'healthy' (which can be considered 'normal', in that 1 day of not getting cared for doesn't impact the plant -that much-.) perhaps a few things slip down one grade. player notices no difference in plant production. player 'cares' for the plant, but this information is not seen by the program.

    SECOND day 5. Now its getting tricky. The casual player doesn't notice the second day 5 stats. The plants STILL show day 4 info (now two days past) and 'cares' for the plant. This information is not seen by the program. This is technically day 6, but the plant gump show day 5, which is old data from day 4, two days previous.

    day 7 - pop - the program info kicks back in. It ignores anything you did from day 4 to day 7, as it never saw it. (OR, it saw 'everything' and added it up. Up to 6 poison potions in one day? What's that going to do to your plant, hum?)

    so, you have 3 days of uncared for plants. Some slipped from vibrant to wilted. Or healthy to dying. or... dead.

    For the planter, that means, he could open his pack on day 7 and find his pack full of wilted or dead plants 'over night'.

    yeah, i put in the bug info.
     
  18. DHMagicMan_1

    DHMagicMan_1 Guest

    Just out of curiosity, I haven't seen this bug yet. I'm growing about 200 plants in backpacks on toons and in blue bugs the toons are riding and logging out on.

    I put about 4 packs on the toon with roughly 4 rows of 5 or 6 plants in each on the toon and then use UOA to "Use Once Agent" on each pack to process every plant. Then swap the packs for the ones on the bug and use UOA to do the same for the second set of packs.

    So far nothings missed a day and nothings dropped unexpectedly as if I hadn't tended it.

    For the people who are having the problem, are use using the "use once agent" in UOA or going through each plant manually?
     
  19. Beastmaster

    Beastmaster Guest

    Still seeing timing issues with plant growth cycles.

    Planted 5 fire seeds yesterday in fertile dirt at 11:00AM EST They have not grown as of now, 12:27PM EST 25.5 hours and no growth. Plants have been kept in my backpack the whole time.
     
  20. feath

    feath Guest

    The first day is 'free' - or, in other words, you wont see any growth. you'll see it tomorrow, on day 2.
     
  21. Beastmaster

    Beastmaster Guest


    Nope! That's not right either. I just logged in again at 1:20PM and they have grown. They say day 2 and have the + So the timing is almost right but off a couple of hours. Growth to day 2 was about 26.25 hours.

    I have a batch of 20 planted yesterday at 2:20PM that missed the 23 hour mark just now. I'll be checking them regulary to see when they hit day 2. If the above is any indication it should be about 4:30 - 4:40.
     
  22. Beastmaster

    Beastmaster Guest


    Well, my 2:20PM batch from yesterday hasn't grown as of 5:00PM. I think the growth cycle thing is just totally whacked right now.
     
  23. kittykat

    kittykat Journeyman
    Stratics Veteran

    Joined:
    May 11, 2001
    Messages:
    287
    Likes Received:
    0
    just a quick question - when you log out with the plants, are you logging right back in or waiting a while? (or is your char logged out for hours till you log them in to check out the plants)

    such complete whackiness...
     
  24. Beastmaster

    Beastmaster Guest

    I tried logging out briefly then back in, no luck. I tried recalling to a different subserver, no luck. Logged off for 40 minutes then back in and they grew.
     
  25. kittykat

    kittykat Journeyman
    Stratics Veteran

    Joined:
    May 11, 2001
    Messages:
    287
    Likes Received:
    0
    okay - something that might be affecting your timing is if you just log off briefly. I *think* your character needs to be out of the world for several minutes before he/she will actually be considered out of the world (even if there is instant logging). I've been making a point of not logging on for at least 5 minutes after I've logged off - and have gotten all my growths like I should.

    It's possible that it's somehow tied to the shard backups which I believe occur roughly every 15 minutes. (whacky, but that may be affecting it all)
     
  26. Teeshy

    Teeshy Guest

    Oh, that's really odd - as I posted in the other thread, mine are definitely on 23 hours (I had to wait til today to double check and make sure)

    I *think* the first day (as in from seed planting to first growth) was different, but I can't be sure though, my memory is crap =P

    Might have to plant some more today and check tomorrow.

    *edits* Oh, that won't work - tomorrow is the first day of my "weekend" so I won't be on at the same times =P At least - I HOPE I'll be sleeping in ;) LOL!
     
  27. kittykat

    kittykat Journeyman
    Stratics Veteran

    Joined:
    May 11, 2001
    Messages:
    287
    Likes Received:
    0
    yeah Teeshy, that's been my experience as well. I have some vague memory of the first growth having to be 24 hours but that 23 worked on any growth after that (but it's been years since that was implimented so I can't recall it for certain).
     
  28. I had a problem with my short hedge's. For some reason yesterday (same day in growth cycle that they popped into plants from the bowl) the short hedges plant menu refused to record that I was giving it poison potions. I did it on each plant that needed it but the menu showed 0 poison potions. Today those same plants showed the red cross on the left I gave each one 2 potions which were recorded. Very strange. All the other plants showed the potions they were given yesterday. These were from the same potion kegs so the problem was not with the potion.
     
  29. Beastmaster

    Beastmaster Guest

    Where were they growing? In a secure? Locked down? You backpack? Your beetle?
     
  30. Beastmaster

    Beastmaster Guest

    I have more sets to do tonight so I'll be testing those. I don't have any more growing from day 1 to day 2 tonight though and I think that is the most troublesome growth period. Have to check some more tomorrow on those.
     
  31. shanshu

    shanshu Seasoned Veteran
    Stratics Veteran

    Joined:
    Jun 8, 2008
    Messages:
    304
    Likes Received:
    1
    Just wanted to add my feedback, my apologies if it has been captured already.

    I am noticing that none of my new plants are getting older than 9 days. I planted on the first day and all are vibrant and healthy, but ones I planted on the 5th day are now as old as the ones from the first, and rarely did any of them miss a growth cycle. They all say 9.

    I used:
    new bowls
    fertile dirt
    grown in bowls until the plant sprouted
    kept in backpack after plant sprouted

    I also noticed that the plant cycles are not following the shard maintenance. My plants update several hours after the shard does.
     
  32. Beastmaster

    Beastmaster Guest

    9 is the highest day you will see on any plant.

    Plants grown in your backpack or pet's backpack update at your login IF it has been at least 23 hours (except for first growth day which is >24 hours).
     
  33. Flora Green

    Flora Green Guest

    I'm also still having growth issues. Mainly it is the original plants. I have several plants that are now behind on their growth cycle. They were vibrant on Tuesday and Wednesday. Last night they were wilted and required potions and two waters. Others from that same batch are still on shedule and vibrant.:coco:
     
  34. feath

    feath Guest

    i had a plant go wilted on day 3.
    i have a pack with about 1/2 the plants going red over night.
    i'd say the bug was still quite active.
     
  35. Spellbound

    Spellbound Lore Keeper
    Stratics Veteran

    Joined:
    May 12, 2008
    Messages:
    810
    Likes Received:
    90
    Bad luck on new type locked down plants at various stages of growth when locked down in houses of my friend and I too. Twenty four hour timer not working for friend in Malas, as she had cared for them yesterday morning, yet when I looked at them last night only a few were hard dirt again and dropped to healthy status. Had a few locked down in Trammel home, on day 7 go wilted from red fungus/disease. They were vibrant and cared for on day 6.
     
  36. Gwenyth

    Gwenyth Guest

    Well I got hit with the bug today. I had 24 plants locked down in my house, all planted in fertile dirt and all doing well until today. Yesterday when I attended the plants, 4 of them had blossomed so I moved them into my character's backpack. The remaining 20 plants were ALL on either day 5 or day 6 of growth yesterday. They were ALL vibrant or healthy. Today when I logged in to attend them, every single plant is on day 6, even the ones that were on day 6 yesterday are still on day 6. All were in need of water and/or potions. But, in addition to the screwy growth, I had 3 plants go nuts on the health meter. One plant is dying, yet is only needs one water and one poison potion. One plant is wilted, but only needs one water. And one plant is healthy but it needs 2 waters and 2 cure potions. So now I have no idea what to expect tomorrow and it's really unnerving.
     
  37. Beastmaster

    Beastmaster Guest

    All my anomalies were planted in fertile dirt. Wonder if that's a common denominator?
     
  38. Teeshy

    Teeshy Guest

    Oh, just as I read your post Beastmaster, it occured to me that that's probably exactly what it is.

    I had a couple plants go nuts on me too, and though they are in a bag with 40 others, I know I only had a few in fertile dirt, and I hadn't ever had a problem before, and this was the first time I ever used fertile dirt too.

    Fertile dirt essentially makes them grow "twice" in one day doesn't it? two growth checks at the same time?

    So (as an example) my plants that suddenly had red + poison, and were wilted, would be because the double growth check would make them poisoned twice? And wilted because it hadn't been watered between the two growths?

    Dunno if I typed that out in a way that makes sense to anyone other than me =P
     
  39. feath

    feath Guest

    where fertile dirt might be part of the answer, its not THE answer. all my plants are in normal dirt.
     
  40. Beastmaster

    Beastmaster Guest

    That's what I was leaning towards too, but it doesn't explain what Feath is seeing so it must be a combination of things. I used fertile dirt on alot of the new plants and on about 36 naturalist seeds.
    I followed Eslake's logic of planting in fertile dirt and dosing with 2 strengths each day. Each day a vibrant plant can after growth check require any combination of 1 water, 1 poison, 1 cure. And a double growth can occur with fertile dirt. So the 2 strengths counteract any combination of 2 poison/cure requirements that would otherwise negate the double growth. In otherwords I tried to make sure I got the double growth. But, I noticed using this method that I still occasionally got poison/cure needs. As I type this I realize that to totally defeat and poison/cure needs would require using 4 strengths. Can you overdose the plant with strengths?

    I could see with a plant getting hit with needing poison, cure, and water from the first day of a 2 day growth spurt (ie. no strengths applied at all) that you could have a dying plant.
     
  41. AnneNomilly

    AnneNomilly Seasoned Veteran
    Professional Stratics Veteran Alumni Stratics Legend Campaign Patron

    Joined:
    May 17, 2003
    Messages:
    495
    Likes Received:
    156
    Not sure if anyone else noticed this but a couple of weird things I've seen that have never happened before:

    - Naturalist plants and snake plants planted in fertile dirt get the single or double growth but require NO water or potions or, possibly, a potion but no water. Maybe that's normal but I've never seen it before.

    - If a plant goes to wilted state, even when fully tended, there seems to be NO way to bring it back. Had one plant in my first group that went straight from vibrant to wilted. This happened on day four. I tended it every day for seven days and it still went to dying even when only showing it needed ONE potion, one water. No combination of potions helped. It was planted in fertile dirt.

    I've now stopped using fertile dirt on the new plants. I'll monitor the group of Naturalist/Snakes that I've got growing and see what happens.

    **Edit - ALL plants are grown on three characters in backpacks and beetles. None locked down on floors.
     
  42. kittykat

    kittykat Journeyman
    Stratics Veteran

    Joined:
    May 11, 2001
    Messages:
    287
    Likes Received:
    0

    I had forgotten until reading this that years ago there was some weirdness with fertile dirt. Like what's being experienced now, plants in fertile dirt would randomly (and only rarely back then) experience the freaky double growth check on health without actually double growing (as I recall) - and then end up in sicker states. It wasn't consistant enough that it was even very reproduceable or able to pinpoint when and why it was happening.

    Wondering now (just throwing out ideas here) that it was a bug with plants in general, but that fertile dirt made show up more - and that now something has changed that makes the bug more prevelant so that it's showing up everywhere.

    (so trying to say here - that I'm wondering if it's actually an old bug that is now showing up more)
     
  43. Lady Tia

    Lady Tia Certifiable
    Stratics Veteran Alumni Stratics Legend

    Joined:
    May 26, 2004
    Messages:
    1,708
    Likes Received:
    114
    Roughly the first 75 plants I grew were planted in fertile dirt and a small percentage of them showed an extra day of growth. But, I was giving them 2 greater strength pots each day so that kept them healthy. I never had any that were anything but vibrant.
     
  44. Dame Judi

    Dame Judi Guest

    As of yesterday, all my "new" plants; in all modes -deco or growing, all seeds and all cocoa pods, are now displaying: Error (MegaCliloc) : Stringld Not Found.

    Not sure if this has been mentioned before. If so, I missed it. Sorry.
     
  45. Beastmaster

    Beastmaster Guest

    Are you patched up to date? If so, did you by chance do a Windows system restore recently?
     
  46. Dame Judi

    Dame Judi Guest

    OMGosh.. yes, yes I did.

    Had to do it last Saturday because something happened to one of my chars on one of my accounts which caused her folder to become a read only. I was getting a fatal error anytime I tried to change anything in Options. I was even getting it when I tried to log her out.

    What happened? Or more importantly, what happens now?
     
  47. Beastmaster

    Beastmaster Guest

    You have to repatch.
     
  48. Dame Judi

    Dame Judi Guest

    At the risk of sounding like a total idiot, how does one go about repatching ?
     
  49. Calla Lily

    Calla Lily Guest

    I've reproduced this bug four days in a row now. I have over 180 plants growing currently, and have been growing plants for years, but I've never had this come up before.

    On ONE of my plain fern plants, every day that I click it open, there's a red "-" by the water button. Everyday I give it two drinks of water, which resolves the water issue for the day.

    The next day when I open it again, again there is a red "-" by the water button. Today, this being the 4th day of this anomaly, there is also a red "+" asking for a poison potion. Yesterday it required no potions.

    It's like this one plant is skipping a day of growth, except that the number of seeds it has on it is the same as every other plant in the same group. All of my plants are planted in regular soil, and all of the seeds for this group came from boglings, they weren't bred from other plants. What's with this one plant?

    Oh, and all of the pots are locked down in my house and haven't been moved since they were planted.

    (Edit: Three days later 10/6, and that one plant is still misbehaving. It's still requiring twice sips of water per day, and on one day has required double does of potions even though none were required the day before.)
     
  50. Beastmaster

    Beastmaster Guest

    Fresh bug report.

    I'm growing bright green snake plants in 6 backpacks inside 1 backpack which is in my main backpack.

    Plant backpacks #1 & #2 contain seeding/thorning plants and are doing fine.

    Plant backpacks #3 & #4 contain 6 plants each planted from seeds from the plants in #1 & #2. They were supposed to reach day 3 today at around 4PM EST. They are still showing day 2 and have not absorbed yesterday's potions.

    Plant backpacks #5 & #6 contain 9 plants each planted from seeds from the plants in #1 & #2. They were supposed to reach day 2 today after 4PM EST. They grew as expected and are on day 2 now.

    So the 12 plants in bags #3 & #4 are bugged. They should have definitely grown before bags #5 & #6 as those were planted yesterday after #3 & #4 were tended. #3 & #4 should have been between 1 and 2 hours ahead of #5 & #6.

    Edit: I kept logging in and checking plants every 1/2 hour and they finally grew at 6:30 PM.