1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

[BUG] Font Problem

Discussion in 'UO Enhanced Client Discussion' started by Aagaron, Jul 17, 2011.

  1. Aagaron

    Aagaron Guest

    Problem solved, check post #11.
    __________

    Hi there!

    I just downloaded the enhanced client and logged on.
    But there are some fonts I can read, and some I cant.
    I already checked the faq and searched for font problems, but havent found anything. And this problem does not occur on other applications.

    [​IMG]
    [​IMG]

    Well, any suggestions?

    :confused:
     
  2. Aagaron

    Aagaron Guest

    post #2...

    (sorry, need a post count of "3 or greater" for posting pics :mad: )
     
  3. Aagaron

    Aagaron Guest

    ...and post #3...
     
  4. Pinco

    Pinco UOEC Modder
    Stratics Veteran Stratics Legend

    Joined:
    Jul 25, 2005
    Messages:
    5,675
    Likes Received:
    865
    probably something goes wrong during the install, try to reinstall the game...
     
  5. Barok

    Barok Grand Inquisitor
    Stratics Veteran Stratics Legend

    Joined:
    Aug 27, 2004
    Messages:
    4,894
    Likes Received:
    330
    That's what I see when I go to an asian shard. What language does your system use vs what language did you install EC with? Looks like they don't match.
     
  6. Aagaron

    Aagaron Guest

    Thx for the quick response Pinco and Barok!

    I'm currently reinstalling the EC. Dunno if I had to or have chosen a language while installing it the first time, I think I only changed the install directory.
    Anyway, OS is a german Windows 7 x64.

    And I also install the classic client atm.

    edit:
    There are no other options than choosing a different path or "show all drives" during install of the EC. So... :confused:
     
  7. Barok

    Barok Grand Inquisitor
    Stratics Veteran Stratics Legend

    Joined:
    Aug 27, 2004
    Messages:
    4,894
    Likes Received:
    330
    Are there optional font packages that you can install with the German version of Windows 7?

    I've never installed any version other than the US one.

    It definitely looks like a conflict between the code page of the OS and the font that is used in the EC.

    Maybe try installing in XP mode?

    Can't think of anything else. Maybe try asking in one of the European forums.
     
  8. Aagaron

    Aagaron Guest

    After an extended search, it looks like the problem is caused by the default EC language setting:

    - Both english and german use latin characters
    - my OS says "language = german" to the EC (I guess the EC checks a Environment variable)
    - the EC does not understand this and sets the default language to an asian language (dunno why... :confused: maybe because "a" comes before "e" or "g" ?)
    - I have no asian language installed, so I see this placeholder characters
    - I guess I have to change the client language manually ingame (or in a config file... but in which? Is there one?)

    Still 500MB to go (EC download, awfully slow...)

    :rant2:
     
  9. Barok

    Barok Grand Inquisitor
    Stratics Veteran Stratics Legend

    Joined:
    Aug 27, 2004
    Messages:
    4,894
    Likes Received:
    330
    Try this: in your "Regional and Language Settings", try changing your language to english, then install EC.
     
  10. Barok

    Barok Grand Inquisitor
    Stratics Veteran Stratics Legend

    Joined:
    Aug 27, 2004
    Messages:
    4,894
    Likes Received:
    330
    (In XP, not sure if the directory name is exactly the same under Win7) Under your "My Documents" directory, the EC client stores all the user info:
    C:\Documents and Settings\Aagaron\My Documents\EA Games\Ultima Online Stygian Abyss\User Data

    (Replace "Aagaron" with whatever account name you are logged into windows with)

    In that directory should be a file called "UserSettings.xml"

    Find a line that says "Language"

    Mine says:
    Code:
        <Options>
            <Language type="English" useEngli****emNames="true" />
        </Options>
    
    Try changing the language there.

    Edit: seems the stratics censor is getting in the way, replace the UseEngli****emNames with "UseEnglish ItemNames" without the space.
     
  11. Aagaron

    Aagaron Guest

    Thanks, those are the exact settings I had to change!
    But with a new install of the EC, there is no "UserSettings.xml". I guess it's created after a player actually joins a shard and then exits the game.
    (I started the client, exited it, and there was still no "UserSettings.xml".)
    In the ig-menu, I can choose between English, Japanese and Chinese. As my OS reports german, either Japanese or Chinese was chosen from the client (regardless of the fact, that I only have german and english laguages installed on my OS; So languages with a character set other than latin will not be displayed...)

    It's a quite old problem (first reported over a year ago), and common in some german UO forums. And I bet it is also common for players with a OS language other than the three named.

    Well, already reported it on the support section of uoherald.com, maybe it will be changed one day (And I'm curious if I will get a response or not).

    Problem solved, back to character creation!