1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. The Broadsword team is seeking alternative castle designs! Learn more and discuss here!
    Dismiss Notice
  4. Broadsword is hosting a 20th Anniversary Party for UO this September! Learn more here. Will you be there, Guest?
    Dismiss Notice

Bug Found a bug in the wiki? Report it here!

Discussion in 'Stratics Wiki' started by BrianFreud, Aug 31, 2016.

  1. BrianFreud

    BrianFreud Lead Wiki Mod & Doer of Crazy Things
    Professional Wiki Editor Wiki Moderator Campaign Supporter

    Joined:
    Oct 2, 2013
    Messages:
    7,983
    Likes Received:
    3,489
    Other than items with the wrong image, or missing items, if you've found something you think is a bug, or if something isn't displaying properly, report it here so it can be fixed.

    Thanks,
    Brian
     
  2. Ru TnT

    Ru TnT Seasoned Veteran
    Stratics Veteran TnT/TnA

    Joined:
    Aug 12, 2008
    Messages:
    467
    Likes Received:
    144
    I ran into a few problems.

    1. I entered the pack instincts for the Blood Fox, but it's showing as unknown, it should be canine.

    Blood Fox Pack Instincts.PNG

    2. I entered some lore readings for the tamable dinosaurs, Dimetrosaur, Saurosaurus, Najasaurus, and Gallusaurus, but something went wrong with it. The charts are all still showing "unknown," instead of the entered data. It looks like all of the info is at the bottom of the page, below the Taxonomy area. I also entered some info for the Triceratops at the same time, but that seems to have worked okay.

    Gallusaurus Lore Reading.PNG

    3. I can't find the form for entering loot and special abilities. When I go to "Edit," this is what I get.

    Mob Editor.PNG
     
    BrianFreud likes this.
  3. BrianFreud

    BrianFreud Lead Wiki Mod & Doer of Crazy Things
    Professional Wiki Editor Wiki Moderator Campaign Supporter

    Joined:
    Oct 2, 2013
    Messages:
    7,983
    Likes Received:
    3,489
    Thanks @Ru TnT;

    #1) I'll look into it; hopefully it'll be fixed by tomorrow.

    #2) If a mob was edited, and didn't yet have any lore info submitted, the editor was adding the 'end template' }} in the wrong place. That bug's been fixed, and I've fixed all the affected pages that I could find, but if you see that blob of text at the bottom of any mob's page, like

    [​IMG]

    then post that mob's name here and I'll go fix it. It's a quick thing to fix, once I know a page needs to be fixed. :)

    For #3, it sounds like your browser isn't loading the editor. Can you tell me which browser and OS you're running?

    Also, there's a bug #4 I'm working on at the moment; if you submit a partial lore report, it should ignore any empty fields, but they don't seem to be correctly ignored at the moment. Go ahead and keep entering lores; I'll hopefully have that one fixed by tomorrow as well. :)
     
  4. Ru TnT

    Ru TnT Seasoned Veteran
    Stratics Veteran TnT/TnA

    Joined:
    Aug 12, 2008
    Messages:
    467
    Likes Received:
    144
    Microsoft Edge on Windows 10.
     
  5. BrianFreud

    BrianFreud Lead Wiki Mod & Doer of Crazy Things
    Professional Wiki Editor Wiki Moderator Campaign Supporter

    Joined:
    Oct 2, 2013
    Messages:
    7,983
    Likes Received:
    3,489
    This bug has now been fixed, as well as a similar bug with preferred foods.

    I've also fixed the bug @MissEcho reported, with the 'subdued' text not always showing (or not showing) when it should or shouldn't.

    If you guys notice any further problems with those bits, let me know. :)

    @Ru TnT, at the moment, I don't have access to a computer with Edge and Win 10 installed. But I'll see what I can do to try to find one to debug with. If the lore tool is working, the editor should be as well, so I'll have to look into it. Meantime, can you try going to the URL 'about:flags', and turning on the 'Experimental JavaScript Features' checkbox, to see if that perhaps gets it working for now for you?
     
  6. Ru TnT

    Ru TnT Seasoned Veteran
    Stratics Veteran TnT/TnA

    Joined:
    Aug 12, 2008
    Messages:
    467
    Likes Received:
    144
    No luck, everything seems to be the same.
     
  7. BrianFreud

    BrianFreud Lead Wiki Mod & Doer of Crazy Things
    Professional Wiki Editor Wiki Moderator Campaign Supporter

    Joined:
    Oct 2, 2013
    Messages:
    7,983
    Likes Received:
    3,489
    I managed to get it to open in Edge on browserstack. Give it a try now. :) (*heads over to jquery.com to file a bug report :p)
     
  8. Ru TnT

    Ru TnT Seasoned Veteran
    Stratics Veteran TnT/TnA

    Joined:
    Aug 12, 2008
    Messages:
    467
    Likes Received:
    144
    It's working. Thank you!
     
    BrianFreud likes this.
  9. BrianFreud

    BrianFreud Lead Wiki Mod & Doer of Crazy Things
    Professional Wiki Editor Wiki Moderator Campaign Supporter

    Joined:
    Oct 2, 2013
    Messages:
    7,983
    Likes Received:
    3,489
    Fixed the other bug @MissEcho reported, which kicked in if you submitted "full" lores, then some partial lores, and the "unknowns" from the partial would still show. The empty fields from partial lores should now fully be ignored.

    As a side technical note, for 10 of the fields from animal lore reports, the only reading that matters for what is displayed on the page is the most recent non-empty report. This is to allow those fields to be entered in the lore tool (since they're given on a lore gump), but to be easily fixed if needed:
    • barding difficulty
    • all 5 types of damage
    • base damage (min and max)
    • control slots (min and max)

    If any of those are incorrect, they can be fixed simply by submitting a new lore reading which includes the correct #s in those fields.

    ----

    That's all the bugs I know of at the moment fixed. :) If anyone notices any others, or finds any more mob pages with that blob of buggy text way at the bottom, please post! :)

    -Brian
     
    Ru TnT likes this.
  10. Ru TnT

    Ru TnT Seasoned Veteran
    Stratics Veteran TnT/TnA

    Joined:
    Aug 12, 2008
    Messages:
    467
    Likes Received:
    144
    Gallusaurus still has the blob of text.
     
    BrianFreud likes this.
  11. BrianFreud

    BrianFreud Lead Wiki Mod & Doer of Crazy Things
    Professional Wiki Editor Wiki Moderator Campaign Supporter

    Joined:
    Oct 2, 2013
    Messages:
    7,983
    Likes Received:
    3,489
    Looks like the fix I put in to prevent and fix that worked; the bugged bit causing the text blob was fixed with your latest edits. :)
     
    Ru TnT likes this.
  12. Ru TnT

    Ru TnT Seasoned Veteran
    Stratics Veteran TnT/TnA

    Joined:
    Aug 12, 2008
    Messages:
    467
    Likes Received:
    144
    Awesome! Sorry to trouble you with that, but thank you for checking.
     
    BrianFreud likes this.
  13. BrianFreud

    BrianFreud Lead Wiki Mod & Doer of Crazy Things
    Professional Wiki Editor Wiki Moderator Campaign Supporter

    Joined:
    Oct 2, 2013
    Messages:
    7,983
    Likes Received:
    3,489
    No worries; if you spot any more, let me know and I'll give them a look/fix. :)
     
  14. Ru TnT

    Ru TnT Seasoned Veteran
    Stratics Veteran TnT/TnA

    Joined:
    Aug 12, 2008
    Messages:
    467
    Likes Received:
    144
    I can't find the control slot info, did it get moved, or is it just me?
     
    BrianFreud likes this.
  15. BrianFreud

    BrianFreud Lead Wiki Mod & Doer of Crazy Things
    Professional Wiki Editor Wiki Moderator Campaign Supporter

    Joined:
    Oct 2, 2013
    Messages:
    7,983
    Likes Received:
    3,489
    Fixed, thanks. The difference between 'tameable' and '{{{tameable}}}' when fixing another bug :p
     
    Ru TnT likes this.