1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest! Tonights Maintenance is complete and the Stratics Community Wiki is now live. Please see this thread for more details.
    Dismiss Notice

HELP!!! I can't play the game!

Discussion in 'Tech Advice' started by onlinerpggamer, Jul 9, 2008.

  1. Ok, here goes: I downloaded Star Wars Galaxies (which took 6 hours by the way,) and I went theough the whole installation process and everything. I start up SWG, and get all the way to the Station LaunchPad, and where it usually says "play," it says "updating." I know that's normal, but after it goes through the updating process (about a minute,) it starts over... Only this time, it says it will take about 8 hours to finish. And the "time remaining" counter is going up! I waited for over a day (it's been 2 days since I started my 14 day trial, and I haven't been able to play yet) and finally, it finished doing it's thing. But here's the catch: after it already says "download complete," still nothing. The button still says updating. Nothing is going on.

    I've done everything I can to fix it: Restarting the LaunchPad (many times,) reinstalling the LaunchPad twice, Restarting the computer, trying it on a different computer, looking up solutions online, completely uninstalling ALL of my anti-virus software, re-downloading the whole game, and using the email support feature of SOE

    I know that's a lot to read, but I really really really need someone's help! I just want to play the game!:grrr:
  2. BadgerSmaker

    BadgerSmaker Guest