1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest! Tonights Maintenance is complete and the Stratics Community Wiki is now live. Please see this thread for more details.
    Dismiss Notice

I need to contact customer support

Discussion in 'UHall' started by Helfgrim, May 14, 2009.

  1. Helfgrim

    Helfgrim Guest

    I've paid for an account with a house on it that won't refresh. The day I opened the account the house was "like new", I clicked the house sign and opened the front doors.

    Today a couple days later the house is "slightly worn" its not refreshing.

    GM's told me to call Billing.

    I would like any information anyone has on how to make a call to customer support as smooth as possible. If anyone has any solutions to offer please share them, I don't want the house to fall.
  2. Zodia

    Zodia Guest

    There is this new thing, it's called "google"! Just ask it a question and it spits out the answer!! AMAZING, no?

    Just messing with ya :)

    here is the number: 1-866-543-5435
  3. Olahorand

    Olahorand Slightly Crazed
    Stratics Veteran Stratics Legend

    Feb 27, 2004
    Likes Received:
    Cannot be a couple of days, since the condition like new lasts 15 minutes and then changes directly to slightly worn (which lasts around 34 hours).
    According to the support pages you should wait at least 24 hours for a refresh after account activation to happen.
    So as long as the house is still slightly or somewhat worn, no reason to panic.

  4. Tom_Builder

    Tom_Builder Slightly Crazed
    Stratics Veteran

    Dec 9, 2002
    Likes Received:

    Was it a grandfathered account? If so, did you place a new house?
  5. Helfgrim

    Helfgrim Guest

    Today the house is now somewhat worn, I haven't been able to speak to a person yet at billing to find out why its not refreshing.

    I own only this building and have owned it for 4 years.
  6. Im confused.

    If youve owned it for 4 years.....
  7. Helfgrim

    Helfgrim Guest

    the account was down for a month, I reopened it tuesday.
  8. Chrissay_

    Chrissay_ Guest

    Have you contacted EA Billing support? If so please PM me with the details.

  9. Gotcha.

    I was thinking you purchased an account off someone and they had placed another house, causing that one to decay.

  10. 4gregu

    4gregu Slightly Crazed
    Stratics Veteran Stratics Legend

    Feb 25, 2004
    Likes Received:
    Down for only one month? A friend of my stopped paying for his second account almost 2 months ago, and the house from that account still hasnt started to decay.
  11. Helfgrim

    Helfgrim Guest

    The oddest part is the house was not decaying while the account was down. It started to decay when I logged in after opening the account.
  12. Helfgrim

    Helfgrim Guest

    Big thanks to Chrissay and GM Thowe for your assistance with this. I appreciate the help you both offered.
  13. sablestorm

    sablestorm Certifiable
    Stratics Veteran

    Aug 23, 2008
    Likes Received:
    Does anyone else use your account? Family members perhaps? Letting your nephews play on another shard? If so, make sure they didn't place a house, even if it is on another shard.
  14. Helfgrim

    Helfgrim Guest

    No one has had access to the account other than myself and my wife, its a guild house so risking loosing it by placing anywhere else isn't something that would have happened.