1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

[Tech Help] In case anyone is wondering why EC performance went into the tank with the patch Friday

Discussion in 'UO Enhanced Client Discussion' started by Llewen, Oct 13, 2014.

  1. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    Intentionally or unintentionally the devs turned on software rendering with Friday's patch. That means all the graphics processing is being handled by your cpu. My guess is they turned it on for debugging purposes and neglected to turn it off, or turn on the 3D hardware acceleration, when they compiled the executable for Friday's patch.

    And while we're on the topic, I thought it was policy not to push a patch or publish out on a Friday. But let's do it on a long weekend when there's an extra day to endure if there's a major screw up.

    (edited to remove pointless crankiness...)
     
    #1 Llewen, Oct 13, 2014
    Last edited: Oct 18, 2014
  2. Storm

    Storm UO Forum Moderator
    Moderator Professional Premium Wiki Moderator Stratics Veteran Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    7,469
    Likes Received:
    361
    That is weird I have not had any issues at all other than my router starting to go out!
     
  3. Storm

    Storm UO Forum Moderator
    Moderator Professional Premium Wiki Moderator Stratics Veteran Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    7,469
    Likes Received:
    361
    That is weird I have not had any issues at all other than my router starting to go out!
     
  4. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    If you have a really fast cpu you might not notice much of a difference. Or maybe they made it hardware specific, such as software rendering for certain graphics processors.
     
    Storm likes this.
  5. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    You might not also notice a difference if your cpu is fast relative to your graphics processor (for example if you have a laptop with integrated graphics).
     
  6. Storm

    Storm UO Forum Moderator
    Moderator Professional Premium Wiki Moderator Stratics Veteran Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    7,469
    Likes Received:
    361
    Radeon HD 8650G amd A10 quad core 2.50 GHz ddr3 ram
     
  7. Storm

    Storm UO Forum Moderator
    Moderator Professional Premium Wiki Moderator Stratics Veteran Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    7,469
    Likes Received:
    361
    Radeon HD 8650G amd A10 quad core 2.50 GHz ddr3 ram laptop
     
  8. Klapauc

    Klapauc Sage
    Stratics Veteran

    Joined:
    Jul 28, 2009
    Messages:
    741
    Likes Received:
    69
    I got some fps issues here since friday as well. Did track it down to the point that performace degrades drastically after a certain amount of open hotbars, because on some chars it works just fine, on others it did not.
    And yes, i wanted to play siege a bit again, but will not with current state of ec.
     
  9. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    It's fixed. Thanks very much devs. :)
     
    Storm likes this.
  10. lucitus

    lucitus UOEC Modder
    Stratics Veteran

    Joined:
    May 13, 2008
    Messages:
    1,426
    Likes Received:
    45
    The performance is very bad i tested it with my UI and the new dault UI! But i figured that is not so much laggy when the backback is not open
     
  11. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    That's not what I'm experiencing. After pub 86 and before they turned on the software rendering my performance was much smoother, but I wasn't getting better fps. Now that they've turned on the 3D hardware acceleration again, I'm getting the kind of performance I was getting after pub 86, but my fps is up by 30 - 50%. So for me the performance of the client is vastly improved.