1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

Installing UO with Wine

Discussion in 'UO Resources' started by Merion, May 5, 2011.

  1. Merion

    Merion Lore Master
    Stratics Veteran

    Joined:
    Dec 1, 2009
    Messages:
    1,006
    Likes Received:
    9
    I would like to run UO (any client) on an openSUSE machine with WINE.

    After extracting and accepting the licences and all, the "install" button is grayed out. I read on a blog that removing the blanks etc. from the folder name might help. But if I try to change something in the destination line, the thing crashes and the command line says:
    wine: Unhandled page fault on read access to 0x00000000 at address 0x25895f8 (thread 0025), starting debugger

    So, any linux or wine pros around who can tell me what to do?
     
  2. Wenchkin

    Wenchkin Babbling Loonie
    Stratics Veteran Alumni

    Joined:
    May 16, 2008
    Messages:
    2,779
    Likes Received:
    434
    You can try the guide here and see how you get on.

    I take a really basic route with UO on linux, I run several distros on different partitions so there's always a working copy of UO that I can copy over. I tend to install Wine, then Winetricks and the items listed in Nexus' guide. Then I copy the UO installation folders over into .wine/drive_c/Program Files. For UOAssist, I follow Nexus' guide. IE7 never seems to install well for me in Wine, so if you have trouble with it, try IE6 instead.

    Good luck :D

    Wenchy
     
  3. Merion

    Merion Lore Master
    Stratics Veteran

    Joined:
    Dec 1, 2009
    Messages:
    1,006
    Likes Received:
    9
    I used that guide, but my problem is not covered by it. Got it to work with a very old install file for the CC: Utlima Online - Mondain's Legacy

    Still patching but looking good.

    Oh, and why would anyone want to use such old browsers? I just use opera or firefox on the linux machine and am pretty happy with it.
     
  4. Wenchkin

    Wenchkin Babbling Loonie
    Stratics Veteran Alumni

    Joined:
    May 16, 2008
    Messages:
    2,779
    Likes Received:
    434
    Eeks, you'll be patching for a while there :( I'm guessing you don't have an existing UO install you could copy?

    I don't use the browser for browsing, it's there purely to run UOAssist. I've got FF4 for "proper" browsing.

    Wenchy
     
  5. Nexus

    Nexus Site Support
    Administrator Professional Wiki Moderator Stratics Veteran Stratics Legend Campaign Patron

    Joined:
    Oct 1, 2006
    Messages:
    5,570
    Likes Received:
    1,835
    I know this is kind of an old topic but here's some info. EA/Bio-Mythic/Sham-a-lama-ding-dong or what ever they are being called these days have changed the installers since I wrote that page.......

    The new installers will work, but only if you have the Development version of WINE installed (1.3x), I never was able to get the newer installers to work using the Stable branch of WINE. After that, using it the installers work just fine for myself, I'm planning to get the page updated before too long. I'm sort of on a mini-UO vacation. I do play other games you know.....
     
    kRUXCg7 likes this.