1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

Is there a way to lock Alliance chat off so it stays off until turned back on?

Discussion in 'UHall' started by Tanivar, May 11, 2011.

  1. Tanivar

    Tanivar Crazed Zealot
    Stratics Veteran Stratics Legend

    Joined:
    May 28, 2003
    Messages:
    3,592
    Likes Received:
    1,461
    There is somone on Alliance chat I am tired of hearing make harrassing comments to someone else. It's gotten damn old. Is there a way to make Alliance chat stay turned off so that it doesn't turn itself back on everytime you log in? I'd like to stay with the Alliance but hearing the comments has hit my b.s. limit.

    Is my only option leaving the Alliance I'm part of, or is there an off switch for Alliance chat that stays off until it's turned back on deliberately?
     
  2. Vlaude

    Vlaude Lore Keeper
    Stratics Veteran Alumni Stratics Legend

    Joined:
    Aug 7, 2003
    Messages:
    817
    Likes Received:
    57
    I don't think there is a way (might be wrong), but rather than leaving the alliance you could just put the person you find annoying on ignore.
     
  3. Petra Fyde

    Petra Fyde Peerless Chatterbox
    Stratics Veteran Alumni Stratics Legend

    Joined:
    Jan 5, 2001
    Messages:
    30,888
    Likes Received:
    5,171
    Yes. Under the 'display' tab (paperdoll - options) scroll down past the screen resolution options to where you can change the text colours. There are 2 tick boxes. 'ignore guild chat' and 'ignore alliance chat'. tick that box.
     

    Attached Files:

  4. Basara

    Basara UO Forum Moderator
    Moderator Professional Wiki Moderator Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Jul 16, 2003
    Messages:
    8,464
    Likes Received:
    587
    Classic Client has in Options: Display (the tab that looks like an eyeball) a box for "Ignore Alliance Messages". There's also one for Guild messages.

    If you are marking this, and it resets back to being unmarked, you may have to do some manual editing of your .cfg files.

    Go to all the characters' folders in Documents/My Documents (depending on if you're using Vista/7, or XP), as well as into the client folder in Program Files (or the Vista/7 equivalent).

    Look for the file "uo.cfg" - there will be a version in the client program folder, as well as EVERY character's folder.

    Edit it with notepad

    Look for the line "IgnoreAllianceChat" -

    if "IgnoreAllianceChat=off" it means Alliance Chat is Turned On.

    Edit the file to change "off" to "on" and save in each chararacter folder, AND the one in the client folder.

    You have to edit the client folder one, because sometimes your computer will insist on using the client folder one's settings to overwrite your characters' settings.


    This should fix your problem, if using the classic client.

    If you're using the enhanced client, You need someone else's help.
     
  5. Tanivar

    Tanivar Crazed Zealot
    Stratics Veteran Stratics Legend

    Joined:
    May 28, 2003
    Messages:
    3,592
    Likes Received:
    1,461
    Thank you Basara. :)

    All 15 CC cfg files are now changed to on. I'll find out later today whether they stay off until I want Alliance chat on for an event. Not having to go into the options menu on log in to turn off the Alliance chat every time I log in 12 of my characters will be a nice change.

    EDIT: I have to recheck the Ignore Alliance box on the first log in each time I restart the client. The following characters then have the box checked. Shutting down the client and restarting it clears the checkmark from Ignore Alliance. The cfg file in the client folder remains set to 'on'. Having to do it just once per play session instead of with each character change is still a definite improvement. :)
     
  6. Basara

    Basara UO Forum Moderator
    Moderator Professional Wiki Moderator Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Jul 16, 2003
    Messages:
    8,464
    Likes Received:
    587
    check and see if any of the other .cfg files in the client and character folders have that as a setting in them as well. You might have to change them too to make it more permanent.
     
  7. Tanivar

    Tanivar Crazed Zealot
    Stratics Veteran Stratics Legend

    Joined:
    May 28, 2003
    Messages:
    3,592
    Likes Received:
    1,461
    Didn't find it in any other cfg file. Maybe a Dev will read this thread and fix the switch in a future publish. I can handle having to do it just once a play session instead of once every log in.
     
  8. Tina Small

    Tina Small Stratics Legend
    Stratics Veteran 4H

    Joined:
    May 12, 2008
    Messages:
    7,527
    Likes Received:
    1,914
    Maybe while they're looking at that stuff, they can figure out how to fix whatever resets the "run mouse in a separate thread" option. I need it left on permanently for all characters but every so often something goes haywire and it becomes unchecked on one character and every character you log on afterwards until you actually go in and check the option on a character. That stops the unchecking until the next time something hokey happens. I've never been able to locate that option in a .cfg file to experiment with trying to make sure it always stays checked.