1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. The Broadsword team is seeking alternative castle designs! Learn more and discuss here!
    Dismiss Notice
  4. Publish 97 is currently on TC1! They are currently focusing on the pet customization aspect of the pet revamp. Head to TC1 and send in your feedback or discuss here!
    Dismiss Notice
  5. Broadsword is hosting a 20th Anniversary Party for UO this September! Learn more here. Will you be there, Guest?
    Dismiss Notice
  6. A new State of Stratics is up. Check it out here!
    Dismiss Notice

Lag?

Discussion in 'UHall' started by Blood Ghoul, Jul 15, 2014.

  1. Blood Ghoul

    Joined:
    Oct 14, 2011
    Messages:
    679
    Likes Received:
    290
    I have to admit-- I am not a "computer guy" but it seems I am having a serious case of lag trying to play UO that I have never had in the past. Speed tests and everything else I try to do on the web seems fine.. Only UO is LAGGY!! ANyone else having any new issues?

    Thanks in advance
     
  2. Longtooths

    Longtooths Supreme Commander
    Stratics Veteran Alumni Stratics Legend LTC

    Joined:
    Jul 20, 2005
    Messages:
    3,191
    Likes Received:
    1,668
    I get the same thing and on the machien I use, I should have absolutely no problems...its frustrating and I think it is server side.