1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

LastSpell is Bugged (at least for me it is)

Discussion in 'UHall' started by Lefty, Apr 12, 2010.

  1. Lefty

    Lefty Lore Keeper
    Stratics Veteran

    Joined:
    May 17, 2008
    Messages:
    894
    Likes Received:
    67
    It doesn't matter what I cast, what key I assign the macro, the LastSpell always cast enchant.

    Anyone else get the same?
     
  2. Petra Fyde

    Petra Fyde Peerless Chatterbox
    Stratics Veteran Alumni Stratics Legend

    Joined:
    Jan 5, 2001
    Messages:
    30,888
    Likes Received:
    5,171
    No, I'm not having that problem. Last spell repeats whatever spell I last double clicked the icon for.
    It does ignore any spell that I've used from a macro though. I am using the classic client.
     
  3. Snakeman

    Snakeman UO Forum Moderator
    Moderator Professional Premium Wiki Moderator Stratics Veteran Stratics Legend

    Joined:
    Jun 13, 2002
    Messages:
    4,961
    Likes Received:
    165
    Same as Petra, it has to be a spell that you last Dbl Clicked to work.
     
  4. G.v.P

    G.v.P Stratics Legend
    Stratics Veteran Stratics Legend

    Joined:
    Jul 11, 2004
    Messages:
    9,644
    Likes Received:
    831
    dbl check your macros, or keys in UO to make sure there isn't a key combination macro that is duplicated. if you have two of the same combo macros it'll mess things up.
     
  5. Harlequin

    Harlequin Babbling Loonie
    Stratics Veteran

    Joined:
    Jun 11, 2008
    Messages:
    2,716
    Likes Received:
    32
    Which client are you using?

    Just to be sure, last spell only works if you have dbl clicked on a spell icon. Spells that you have just cast using another macro will not be remembered by the last spell macro.

    I'm guessing you have just set up the last spell macro? If so, you might have dbl clicked the enchant spell previously. Open your spellbook and dbl click on another spell, then hit your last spell macro and see if in casts the correct spell.

    I use last spell for non-combat spells that I normally don't use, but if used, may need to be cast repeatedly - eg mark, rez, exorcism etc