1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

[Tech Help] macro with unexpected effect.

Discussion in 'UO Enhanced Client Discussion' started by Petra Fyde, Aug 4, 2009.

  1. Petra Fyde

    Petra Fyde Peerless Chatterbox
    Stratics Veteran Alumni Stratics Legend

    Joined:
    Jan 5, 2001
    Messages:
    30,882
    Likes Received:
    5,165
    I have a 'kill' macro that gives me a target.
    I have a peace macro 'peace skill; cursor target current'. Both work as expected.
    But I have a 'kill; curser target current' which puts up the words 'all kill' twice and gives me a cursor as well as the pet attacking the correct target.

    Any idea why and how to fix it please?
     
  2. TheGrayGhost

    TheGrayGhost Guest

    What is the exact macro?

    I use All Kill, wait for target, Cursor Target Current and do not have that issue. I will check to be sure because I haven't used it since the recent patch so I will check to be sure it still works.
     
  3. TheGrayGhost

    TheGrayGhost Guest

    Tested and it's working, but I did find this for you posted in the SA Macro thread. It's a bit hidden oO.

    Seems you may need to add wait for target now. Having it already in my kill macro may be the reason I did not have an issue with it.
     
  4. Petra Fyde

    Petra Fyde Peerless Chatterbox
    Stratics Veteran Alumni Stratics Legend

    Joined:
    Jan 5, 2001
    Messages:
    30,882
    Likes Received:
    5,165
    thank you, I'll try that :)
     
  5. Petra Fyde

    Petra Fyde Peerless Chatterbox
    Stratics Veteran Alumni Stratics Legend

    Joined:
    Jan 5, 2001
    Messages:
    30,882
    Likes Received:
    5,165
    tried that, it didn't help, but since it works properly for you I'll assume it's my geriatric rig that's at fault.
     
  6. TheGrayGhost

    TheGrayGhost Guest

    Something like the macro's really shouldn't be effected by an older rig oO. What is your exact Macro so I can test it out on my end?
     
  7. Fink

    Fink Guest

    Petra, could it be you have two macros bound to the one keystroke? It's doable.

    I find the whole "check for used keystroke" thing to be very buggy. I'll often go to bind a key and it'll say it's used for something it isn't, so I'll assign it anyway. Then I'll locate in the list the macro that supposedly used that key and it is of course unbound, so I'll put the right keystroke back in. Then when I use that restored keystroke, it'll activate both macros at once.

    I've submitted bug reports on it. It usually happens after I've deleted a number of macros from the list (typically when copying/modding a settings file from one character to another). I'm surprised I haven't seen it mentioned.
     
  8. Petra Fyde

    Petra Fyde Peerless Chatterbox
    Stratics Veteran Alumni Stratics Legend

    Joined:
    Jan 5, 2001
    Messages:
    30,882
    Likes Received:
    5,165
    Thanks Fink, not quite the problem but it lead me to it. It's the mouse wheel click. Any macro I tie to it it's doubling up on. I guess I'll have to be careful what I use it for - or buy a new mouse.
    Grayghost, the macro is: 'kill' from the pet command icon set, added in 'wait for target' on your suggestion, then 'cursor target current'. It works now I've moved it to another key.
     
  9. Der Rock

    Der Rock Guest

    sometimes if i press ESC button a recall macro starts :(