1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. The Broadsword team is seeking alternative castle designs! Learn more and discuss here!
    Dismiss Notice
  4. Publish 97 is currently on TC1! They are currently focusing on the pet customization aspect of the pet revamp. Head to TC1 and send in your feedback or discuss here!
    Dismiss Notice
  5. Broadsword is hosting a 20th Anniversary Party for UO this September! Learn more here. Will you be there, Guest?
    Dismiss Notice
  6. A new State of Stratics is up. Check it out here!
    Dismiss Notice

Need link

Discussion in 'UO Siege Perilous' started by calaman, Mar 22, 2013.

  1. calaman

    calaman Lore Keeper
    Stratics Veteran

    Joined:
    Jun 1, 2008
    Messages:
    756
    Likes Received:
    66
    I'm trying to find a link that is the latest version of uo. The one I keep downloading says it missing files any help so i can jump back into uo ty
     
  2. Victim of Siege

    Victim of Siege Crazed Zealot
    Governor Stratics Veteran Alumni Safe Haven

    Joined:
    Aug 19, 2010
    Messages:
    3,288
    Likes Received:
    2,842
  3. calaman

    calaman Lore Keeper
    Stratics Veteran

    Joined:
    Jun 1, 2008
    Messages:
    756
    Likes Received:
    66
    yes but I dont have the upgrade for the high seas is that a problem then?
     
  4. Victim of Siege

    Victim of Siege Crazed Zealot
    Governor Stratics Veteran Alumni Safe Haven

    Joined:
    Aug 19, 2010
    Messages:
    3,288
    Likes Received:
    2,842
    no, it does not matter which expansion(s) you have purchased, that is the client you need to use