1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

OS-X WINE first problems

Discussion in 'UO Resources' started by Tewha7, Feb 19, 2015.

  1. Tewha7

    Tewha7 Visitor

    Joined:
    Feb 19, 2015
    Messages:
    7
    Likes Received:
    0
    Hi guys,

    It's been several years since I played UO, and I don't have a PC anymore. But I've read that it can be played on WINE, so I thought I'd give that a try. I signed up for a two week trial. I downloaded the installers, let them unpack, then copied the data1 directories into place and ran the patchers (serially, of course).

    Enhanced Client: This is fully patched, but it's just flashing boxes of bright colors. I can see the cursor move when I type, though. If I type my username and password, it shows something that looks like it's probably a server list. But this is totally unplayable, of course; I can't even read the version number.

    Classic Client: This looks way better, just like I remember. I type my username and password, but get this error "We are unable to authenticate your login. Usually, this means that either a newer client patch is now available, or that the account name or password you provided are incorrect. (etc)" The client reports itself on the login screen as "7.0.43.1 (Patch Unknown)."

    Any ideas for getting one (or, ideally, both) of these to work?
     
  2. deadite

    deadite Sage
    Stratics Veteran Stratics Legend It's My Birthday

    Joined:
    Jun 17, 2004
    Messages:
    570
    Likes Received:
    20
    What kind of Wine installation are you using? I have EC running nicely using Wineskin. The only other things installed in that bottle are Wine Gecko (32-bit) and Wine Mono.

    Anyway, Wineskin is by far my first choice for running PC games on my Mac. It's a bit of a learning curve, but so worth it.

    http://wineskin.urgesoftware.com/

    Only other thing I can think to ask is what kind of video card you're running? Is it an integrated card or discrete?
     
  3. Tewha7

    Tewha7 Visitor

    Joined:
    Feb 19, 2015
    Messages:
    7
    Likes Received:
    0
    I used Wineskin Winery 1.7, which means Wineskin 2.6.0 wrapper and WS9Wine1.7.36 engine. Is that what you're using? I tried Crossover and PlayOnMac as well, but I'm getting the same behaviour with the Enhanced client. Just a screen flashing through various bright colors. Though I noticed I have a mouse pointer, too!

    The system is pretty modest, but UO shouldn't require that much. It's a 2.0GHz i7 with a 1024MB Intel HD Graphics 4000.
     
  4. Tewha7

    Tewha7 Visitor

    Joined:
    Feb 19, 2015
    Messages:
    7
    Likes Received:
    0
    I'm in! I just forgot to install DirectX.
     
  5. deadite

    deadite Sage
    Stratics Veteran Stratics Legend It's My Birthday

    Joined:
    Jun 17, 2004
    Messages:
    570
    Likes Received:
    20
    Nice! Sorry I didn't remember having to do that step... It's been a while.
     
  6. Tewha7

    Tewha7 Visitor

    Joined:
    Feb 19, 2015
    Messages:
    7
    Likes Received:
    0
    For what it's worth, I still don't have the Classic client running. So if anything occurs to you, let me know!
     
  7. BrianFreud

    BrianFreud Lead Wiki Mod & Doer of Crazy Things
    Professional Wiki Editor Wiki Moderator Campaign Supporter

    Joined:
    Oct 2, 2013
    Messages:
    7,080
    Likes Received:
    2,907
    I play on Linux, not OSX. But I can say that classic works a charm under wine, at least on Ubuntu. EC is painfully slow, when it works, which isn't often, and forget about UOA + classic; I could never get UOA to be anything better than very crashy.