1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

[Tech Help] Resetting KeyBindings post-patch.

Discussion in 'UO Enhanced Client Discussion' started by Fink, Oct 24, 2009.

  1. Fink

    Fink Guest

    I got three options when the EC split set-ups on a per-character basis: Legacy defaults, MMO defaults, or my own settings. I chose to retain my own and, naturally, it buggered up my key bindings for every single character. Now I have to go through each one and individually correct the problem.

    Looking at the character data I see <KeyBindings> and <MouseOptions>. I gather I can simply copy these groups from one character to the next if I want identical settings? Just thought I'd check with you guys first. I could go and meddle with it myself, but I'd rather minimise headaches at this point.
     
  2. I've been waiting for this exact information before I patch... still running without either of the last two patches. I don't know the answer, but what I plan to do is copy my character files before the patch applies, and then probably either try pasting the old back, or manually editing the files... for me that's faster than resetting all the key bindings in game.
     
  3. Fink

    Fink Guest

    I only just backed up my stuff a week ago, so.. I'm okay there.

    I don't know why this couldn't have been handled better. What was ostensibly the proper choice wiped the settings it was supposed to preserve. :( ?
     
  4. Gildar

    Gildar Babbling Loonie
    Stratics Veteran

    Joined:
    Apr 22, 2004
    Messages:
    2,354
    Likes Received:
    4
    Ok... to prevent the migration...
    Before you enter the game as a character after the patch, open the settings file with notepad or wordpad.

    Look for the following lines:
    Code:
            <OverheadChat enabled="true" />
            <ScannedLegacyMacros enabled="true" />
    Add the following after those lines:
    Code:
            <QueriedLegacySettings enabled="true" />
    If you don't have the ScannedLegacyMacros line, add that too (adding this one will block the "You seem to have macros for the 2D client, migrate them?" question).
     
  5. Gildar

    Gildar Babbling Loonie
    Stratics Veteran

    Joined:
    Apr 22, 2004
    Messages:
    2,354
    Likes Received:
    4
    Nevermind, that doesn't seem to do it.