1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. The Broadsword team is seeking alternative castle designs! Learn more and discuss here!
    Dismiss Notice
  4. Publish 97 is currently on TC1! They are currently focusing on the pet customization aspect of the pet revamp. Head to TC1 and send in your feedback or discuss here!
    Dismiss Notice
  5. Broadsword is hosting a 20th Anniversary Party for UO this September! Learn more here. Will you be there, Guest?
    Dismiss Notice
  6. A new State of Stratics is up. Check it out here!
    Dismiss Notice

TECH PROBLEM: Involving Numpad

Discussion in 'UHall' started by jtw1984, Nov 5, 2009.

  1. jtw1984

    jtw1984 Seasoned Veteran
    Stratics Veteran

    Joined:
    Jun 12, 2008
    Messages:
    301
    Likes Received:
    1
    Is there a way to make it where all the numbers except 5 do not move your character?

    Maybe a file I can edit?

    Thanks!

    I got the new Razer Naga, and I can't setup macros on the numpad unless nums lock is on because it makes my character move.

    Thanks!
     
  2. Harlequin

    Harlequin Babbling Loonie
    Stratics Veteran

    Joined:
    Jun 11, 2008
    Messages:
    2,716
    Likes Received:
    32
    Those cursor keys movement control are hardcoded into the client. I have not come across any ini settings to disble them so far.

    I may however have 2 possible solutions.

    1 - Create 8 dummy macros in UO and assign these to the 8 affected numpad keys. Not sure if UO allows you to leave it blank, but you can always assign actions like set update range to default, toggle transparency etc.

    If it works anything like ctrl+q losing its defaut function when it is assigned to a macro, it should work in your situation.



    2 - If you have UOA, assign these 8 numpad keys to UOA functions you don't use, say play UOA macro 9 through 16. Then uncheck the "pass key to UO" box.

    I haven't tried doing either tho, so can't be sure. But let me know if either of these work for you.