1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

Very Specific Context in Which I am Experiencing Horrible Lag

Discussion in 'UO Enhanced Client Discussion' started by Llewen, Nov 21, 2009.

  1. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    I have isolated a very specific context in which I am experiencing horrible lag, and I am wondering if anyone else is also experiencing it. I have bug reported the hell out of it, but it might be worth finding out if others have any input or feedback on it.

    I lag horribly when I am in Fel, near high end pvm content, such as at a spawn, or near the turkeys, and I do anything with the cursor as a target option. I've noticed it specifically with spells and bandages.

    Needless to say it is incredibly annoying, and more than a bit hazardous. Nothing like having your fps drop to 1 or 2 when you are trying to cast invis to save yourself from a rampaging turkey...
     
  2. mr crabs

    mr crabs Guest

    yep it seems to hapen when i move my mouse from game window to hot bar menu. and ya after a time in fel around alot of pvp and or champ spwans
     
  3. aarons6

    aarons6 Certifiable
    Stratics Veteran

    Joined:
    Oct 14, 2007
    Messages:
    1,897
    Likes Received:
    31
    yep. because of this ive stopped using the ec for all pvm and pvp situations. :(
     
  4. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    No question, this is a game breaker. I still haven't gone back to the classic client, and I hope I don't have to, but I've certainly considered it.
     
  5. Cear Dallben Dragon

    Cear Dallben Dragon Babbling Loonie
    Stratics Veteran Stratics Legend

    Joined:
    Feb 17, 2005
    Messages:
    2,005
    Likes Received:
    17
    Turkey fights destroy me...
     
  6. lucitus

    lucitus UOEC Modder
    Stratics Veteran

    Joined:
    May 13, 2008
    Messages:
    1,426
    Likes Received:
    45
  7. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    I don't understand what you mean by "invisible windows".
     
  8. Merion

    Merion Lore Master
    Stratics Veteran

    Joined:
    Dec 1, 2009
    Messages:
    1,006
    Likes Received:
    9
    I don't get it either, but I can confirm the reproducable lag at champs spawns in fel. As soon as you move your mouse somewhere out of the game windows and over something that triggers a mouseover like a hotbar slot, item in backpack, something on the paperdoll, etc. I get lag for several seconds.
     
  9. lucitus

    lucitus UOEC Modder
    Stratics Veteran

    Joined:
    May 13, 2008
    Messages:
    1,426
    Likes Received:
    45
    Take a look on the screenshot in the black areas are two windows in the background, if you set them to 0.001 alpha they are invisible for you, but the system works fine ;)
     
  10. mr crabs

    mr crabs Guest



    what is this?? and where do u change it?
     
  11. lucitus

    lucitus UOEC Modder
    Stratics Veteran

    Joined:
    May 13, 2008
    Messages:
    1,426
    Likes Received:
    45
    Sry try to load my interface.

    Open the interface.lua with editor of your choice:

    There you can find:

    Code:
    	--CreateWindowFromTemplate("CorrectWindow1","CorrectWindow","Root")
    	--CreateWindowFromTemplate("CorrectWindow2","CorrectWindow","Root")
    
    change to:

    Code:
    	CreateWindowFromTemplate("CorrectWindow1","CorrectWindow","Root")
    	CreateWindowFromTemplate("CorrectWindow2","CorrectWindow","Root")
    
    Now it will create two normal windows in the background, but you have to put them into the right direction. First make them visible using this command

    /script WindowSetAlpha("CorrectWindow1", 1)
    /script WindowSetAlpha("CorrectWindow2", 1)

    next make them movable:

    /script WindowSetMovable("CorrectWindow1", true)
    /script WindowSetMovable("CorrectWindow2", true)

    then drag them over the black areas on your screen, resize them correctly and relogg your charcter, after reloggin the windows should be invisble again and at the location you dropped them.

    You can make that on each character, or copy the XML Settings of the Correct Window.

    Sorry i thought supreem would fix it faster, because of this i havent intigrated it to my interface directly. Iam considering doing that with the next release.

    If you need more than 2 correctwindows, add a correctwindow line in the Interface.lua.
     
  12. mr crabs

    mr crabs Guest

    bump
    bump
    bump
     
  13. Cear Dallben Dragon

    Cear Dallben Dragon Babbling Loonie
    Stratics Veteran Stratics Legend

    Joined:
    Feb 17, 2005
    Messages:
    2,005
    Likes Received:
    17
    yep this is horrible.
    After any decent amount of action in fel pvp or pvm. if my cursor does outside the game window. im toast. baaaad lag for about 8 seconds.
     
  14. Sturdy

    Sturdy Guest

    Add me to this bug list. I have the same problem. It is new as of last night for me. I have been playing on EC for four or five weeks with no trouble (I love the EC)

    It started after I popped in and out of the painted caves several times. I logged out and back in and it was fine for a few minutes then returned. Now I cant shake it on one of my characters but the other seems uninfected :confused:

    Please fix my bard :gee:
     
  15. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    Just a thought, but have you tried defragging the hard drive with your game install on it? Assuming of course you are on Win XP.
     
  16. lucitus

    lucitus UOEC Modder
    Stratics Veteran

    Joined:
    May 13, 2008
    Messages:
    1,426
    Likes Received:
    45
    This is a strange bug, i cannot define it exactly, but if you recall to trammel it is instaly lagfree again. It also is not happening everytime you are in Felucca and it is also not often in dungeons.

    But at all, the whole animation system is a bit buggy, look at the mirrors of monsters and players, the slow movement of other players if you stay.

    We cant change anything here and Mythic seems not really care about the Enhanced client, or would you say this is good support of a monthly paid game? Only things i hear of Mythic Devs is it is in testing and if it comes out it is buggy like everytime before.
     
  17. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    I notice it around Yew gate in Felucca, and definitely around boss level mobs in Felucca, or in locations where boss level mobs spawn. Sometimes restarting the client seems to help, sometimes it requires a complete reboot of my computer. And yes, it is frustrating that all these serious issues with the enhanced client seem to be receiving no attention.

    They had enough time to implement some useless items they sell for real $$, but don't have time to fix serious problems with what is supposed to be their next generation client. And they made an announcement before Xmas about third party cheat detection, and we've heard nothing about that either since.

    At least we didn't lose the EM's...
     
  18. lucitus

    lucitus UOEC Modder
    Stratics Veteran

    Joined:
    May 13, 2008
    Messages:
    1,426
    Likes Received:
    45
    Hey i have said it many times before, it is okay to earn bucks, i would also buy the new client for 29.90$ or something like that if it is finished and supported well.

    It feels like, a free client, then we have also nothing todo on it.
     
  19. jtw1984

    jtw1984 Seasoned Veteran
    Stratics Veteran

    Joined:
    Jun 12, 2008
    Messages:
    301
    Likes Received:
    1
    Hey sorry to bump this up. I looked for a interface.lua under Copper Enhanced and didnt see one. I found it other the other ones though.

    Could someone please tell me how to add the windows under Copper Enhanced? Which file I need to do? Thanks!
     
  20. mr crabs

    mr crabs Guest

    lucitus can u add the invs windows as a sizable window option then we can just geab a corner of the two windows and size it to fit our black areas?
     
  21. Cear Dallben Dragon

    Cear Dallben Dragon Babbling Loonie
    Stratics Veteran Stratics Legend

    Joined:
    Feb 17, 2005
    Messages:
    2,005
    Likes Received:
    17
    speaking of fel bugs. i JUST realized the landscape is 100% different in 2d and EC. to the point were come areas of land are full of trees that arent there in 2d. theres no blood or graves or bones in EC fel.
     
  22. Merion

    Merion Lore Master
    Stratics Veteran

    Joined:
    Dec 1, 2009
    Messages:
    1,006
    Likes Received:
    9
    *bump*

    This is still a major problem when doing spawns in the lost lands!
     
  23. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    It is still a general problem as well. I still have to restart the client fairly often, and sometimes I have to restart my computer because of issues with lag, something I don't have to do with any other game, not even Civ IV, which uses the same 3D engine.

    It's ridiculous. This was posted almost three months ago and I'm assuming it has been a problem with the client since it was first released.
     
  24. Storm

    Storm UO Forum Moderator
    Moderator Professional Premium Wiki Moderator Stratics Veteran Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    7,469
    Likes Received:
    361
    Just a suggestion Try putting a question about this in ask the devs! and maybe put a link to this post that they can come get more details!
     
  25. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    Done.
     
  26. Storm

    Storm UO Forum Moderator
    Moderator Professional Premium Wiki Moderator Stratics Veteran Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    7,469
    Likes Received:
    361
    well in ask the devs it appears they are aware!
    I went to fel for the first time in a long time and tried to reproduce this and was unable to myself!
    now I will lag with when a lot of mobiles are on screen like with some of the em events! other than that i have not seen this!
     
  27. mr crabs

    mr crabs Guest

    storm
    i can confirme it is still there. i dont notice it as much on my dexxer but any mage i take to fel withen a few min. it starts with the lag when i mouse over the black.
     
  28. Storm

    Storm UO Forum Moderator
    Moderator Professional Premium Wiki Moderator Stratics Veteran Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    7,469
    Likes Received:
    361
    Well at least we know they are looking at it! I wonder is it all shards ?
     
  29. Diggity

    Diggity Guest

    Same here. Can't reproduce on dexxer, but can on mages. Happens on both desktop (XP) and laptop (Win 7) systems. When I have time, I'll try either swapping the char's data files and/or blanking out the mage's to see if that changes things.
     
  30. Merion

    Merion Lore Master
    Stratics Veteran

    Joined:
    Dec 1, 2009
    Messages:
    1,006
    Likes Received:
    9
    Drachenfels here.

    It doesent happen everywhere to me and not immediatly, but If I go to terra sanctum and do a champ spawn there. It usually starts around lvl 3 or four. As soon as I move my mouse over something that triggers a mouse-over, my screen then freezes for up to 20 sec.

    Video card is a radeon HD 3650 1 GB with newest drivers.
     
  31. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    Windows XP Home SP3
    Athlon II X2 240
    4 GB OCZ DDR2 800 dual channel
    Sapphire Radeon 2600XT 500MB
    Creative X-Fi Gamer

    The character I was playing that led me to this post was a dexxer with no spell casting abilities, however it is a dexxer with the med skill. I have a mage/tamer that I experience significant lag with after I have been playing for awhile, especially in built up areas like Luna or around Yew gate in Fel, but I don't think that is the specific issue I posted about in the op, although it might be related.
     
  32. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    I don't know about anyone else, but I didn't have as many of my normal lag issues around Yew gate yesterday after the patch. This isn't the specific problem I was talking about in the OP, but maybe someone else has some feedback on that. Am I just imagining things, or has there been an improvement?

    Specifically after some time running the enhanced client it tends to bog down and I start getting fps in the teens and even lower than that. I usually have to restart the client at least every hour, if not more often than that. That didn't happen to me yesterday.
     
  33. Storm

    Storm UO Forum Moderator
    Moderator Professional Premium Wiki Moderator Stratics Veteran Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    7,469
    Likes Received:
    361
    while I have not had the big lag issues like some I have noticed it is running smoother for me! Crosses fingers it stays that way for us!
     
  34. mr crabs

    mr crabs Guest

    got it this morning was doing spwans in fel t2A AND GOT THE LAG WHEN I MOUSED OVER THE BLACK AREA HADE TO RESTART AND IT WAS GONE FOR A BIT
     
  35. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    So it appears that the overall performance has improved somewhat but the specific black screen issue at T2A champ spawns is still there. Well, still, it's an improvement and more than we've had in a while.
     
  36. Cear Dallben Dragon

    Cear Dallben Dragon Babbling Loonie
    Stratics Veteran Stratics Legend

    Joined:
    Feb 17, 2005
    Messages:
    2,005
    Likes Received:
    17
    this is freaking me out.
     
  37. mr crabs

    mr crabs Guest

    was also still present when we went back to the guild house to roll gh is in fell so it is still there in fel and t2a
     
  38. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    None of the performance problems have been fixed for me. I was hanging out in Yew today and in less than an hour my fps were dropping down to the teens and lower and I was lagging horribly. I had to shut down the client and clean up my memory to get it to run properly again.
     
  39. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    Well I just discovered today that I had inadvertently disabled my paging file. This might have something to do with the lag issues I have been experiencing (not the one in the OP though). I will post back with the results of re-enabling my paging file...
     
  40. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    Well it appears that might have helped. I'm still experiencing horrible fps drops but I don't seem to be lagging as much when that happens. I'll keep an eye on it and report back after I have some more run time with it.
     
  41. Storm

    Storm UO Forum Moderator
    Moderator Professional Premium Wiki Moderator Stratics Veteran Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    7,469
    Likes Received:
    361
    This was posted by Lucitus
    The next patch is out, i promised before 1.0 is comming until it, yes it is comming the settings are updated, the filter window for the Mobiles is in work.

    Also i have now an automatic fix for the lag problem in felucca, in the end of the week it should be ready to test for you all ;)
     
  42. Cear Dallben Dragon

    Cear Dallben Dragon Babbling Loonie
    Stratics Veteran Stratics Legend

    Joined:
    Feb 17, 2005
    Messages:
    2,005
    Likes Received:
    17
    what freaks me out is that the devs say they cannot replicate this?

    My guild just had a birthday party in our town in fel last night.
    We generally just maul each other for hours. after about 5 minutes EVERY person using the EC was having unbearable lag when their mouse entered the black space.

    Devs, get together after lunch. come to fel isle of the avatar, and maul each other for about 10 minutes. if you cant replicate this, the sky is falling.
     
  43. mr crabs

    mr crabs Guest

    they may not be able to reproduce it where there are ie setting on the servers
     
  44. Llewen

    Llewen Grand Inquisitor
    Professional Stratics Veteran Stratics Legend Campaign Supporter

    Joined:
    Mar 3, 2006
    Messages:
    4,699
    Likes Received:
    200
    There is hope!
     
  45. Cear Dallben Dragon

    Cear Dallben Dragon Babbling Loonie
    Stratics Veteran Stratics Legend

    Joined:
    Feb 17, 2005
    Messages:
    2,005
    Likes Received:
    17
    I have never had this problem in tram until right now. I just went and did a few levels of primeval lich and then moved on to rikitor valor spawn. for the first time in tram im dropping to about 5 FPS when my mouse is in the black space
    GAHHH!!H!!H MERGER GERGLE!
     
  46. Merion

    Merion Lore Master
    Stratics Veteran

    Joined:
    Dec 1, 2009
    Messages:
    1,006
    Likes Received:
    9
    Err... you realize that the primeval lich and infernal abyssal spawns are in felucca, right?!
     
  47. Cear Dallben Dragon

    Cear Dallben Dragon Babbling Loonie
    Stratics Veteran Stratics Legend

    Joined:
    Feb 17, 2005
    Messages:
    2,005
    Likes Received:
    17
    That there
     
  48. Hardy

    Hardy Lore Master
    Stratics Veteran

    Joined:
    Mar 23, 2009
    Messages:
    1,192
    Likes Received:
    129
    this is a nightmare, this is the 3rd EM event in a row i have had to leave due to my client locking up and crashing with unbelievable lag.

    I cannot put into words how mad i am without getting banded from the boards!


    /rant over