1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest! Tonights Maintenance is complete and the Stratics Community Wiki is now live. Please see this thread for more details.
    Dismiss Notice

[Tech Help] What is "Enable VSync"?

Discussion in 'UO Enhanced Client Discussion' started by Connor_Graham, Jul 25, 2009.

  1. Exactly what is it? I can't see what it does if enabled or turned off other than making my client appear to refresh.
  2. If you use VSync, it forces a full frame of graphics to your monitor before posting. This resolves some of the "tearing" that can be seen at times. There is a discussion of VSync in one of the other threads in this forum.

    A couple things you should know about VSync. If you are using an LCD monitor, set the game FPS to 60 and enable VSync. Since the default refresh rate of an LCD is 60 Hz, they sync up nicely (unless you've changed it in your monitor settings, in which case change it back).

    If you have a CRT monitor (old tube style) and have a refresh rate higher than 60 Hz (which we all used to do to get rid of the flicker), then you probably don't want VSync. If you monitor's refresh rate is higher than the game FPS, then your monitor has to wait part of a cycle to complete a full graphics page before posting it. The result can be an actual slow down of the video.

    You can get around this if you have a monitor refresh rate 2X the game FPS (say 80 Hz for the monitor and 40 for the game), or set both to 60 FPS and 60 Hz.

    For me, I saw a nice improvement with my LCD setting the game FPS to 60 and enabling VSync... everything looked "cleaner."
  3. Beastmaster

    Beastmaster Guest

    Got a screenshot of this "tearing"?

    Elaborate on "cleaner" please.
  4. Ok, after doing some playing around, I've found that my monitor can go up to 75hz, but seems to be set at 60, which is what the SA client was defaulted to. I'm having severe lag issues though. My character is skipping around all over the place. Part of this has to do with the housing cache, as anytime I go near any houses, I freeze for a split second as I go past each one. Running through Ter Mur was even worse. I was able to run KR with everything set to the max so I'm not understanding why I'm having issues with SA.
  5. Beastmaster

    Beastmaster Guest

    You are not alone. Alot of folks are skipping (aka rubberbanding) with this client. Like you I notice it around housing.
  6. This is starting to get ridiculous. Between trying to figure out the very unintuitive macro system and trying to figure out how to move without freezing up constantly I haven't been able to do anything in game for over 4 hours now. I'm just about at the "screw it" stage. It shouldn't take half a day to figure out how to use the damn client, much less get it set up.
  7. Fink

    Fink Guest

    I think that's going on my gravestone.
  8. I still haven't been able to get the client to run smoothly, and am about sick of all the rubberbanding and freezing.
  9. Mr.StinkyPants

    Mr.StinkyPants Slightly Crazed
    Stratics Veteran

    May 3, 2009
    Likes Received:
    did u turn the frame rate off>? it helped me dont rubberband anymore just lag a lot :wall: