1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

Windows 7 and 2d question

Discussion in 'UO Resources' started by Llwyd, Dec 5, 2009.

  1. Llwyd

    Llwyd Guest

    My new computer has Windows 7 Home Premium. I downloaded the 2d client and can play UO... however, whenever I quit the game the computer reverts to a message saying "UO is loading", and when I try to open the game again I get the message that another instance of UO is running.

    In short, once I quit, I have to restart the computer before I can play again. Does anyone know how I can fix this?
     
  2. Jonas123

    Jonas123 Guest

    Maybe you could just open the taskmanager pressing alt ctrl del and then quit the instance but have you tried setting the compatibility mode to the .exe you use to start your UO? To set that mode you need to right click the .exe and then go to properties -> compatibility and check the "Run this program in compatibility mode for:" and set it to Windows XP SP3 or similar.
     
  3. Llwyd

    Llwyd Guest

    I had already set the compatibility mode to XP, but that hadn't helped. I'll just go with the taskmanager solution I guess... that works fine. Thanks!
     
  4. Pawain

    Pawain Crazed Zealot
    Stratics Veteran Stratics Legend

    Joined:
    Nov 1, 2003
    Messages:
    3,694
    Likes Received:
    132
    Mine also does this. If I load another game, it goes away.

    I was wondering how to get to taskmaster.
     
  5. Spellbound

    Spellbound Lore Keeper
    Stratics Veteran

    Joined:
    May 12, 2008
    Messages:
    810
    Likes Received:
    89
    Hit Ctrl + Alt + Del and click on Start Task Manager. Click on Applications tab and hit End Task on Ultima Online.
     
  6. Schuyler Bain

    Schuyler Bain Lore Master
    Stratics Veteran

    Joined:
    May 19, 2008
    Messages:
    1,131
    Likes Received:
    1
    The image shows the settings I used to eliminate the issue you describe. Runs smooth as silk and no "UO Loading" bit after closing.

    Hope it helps

    [​IMG]

    I believe it has to do with the "visual themes" so you may be able to just play with those settings to achieve the same end results.
     
  7. Llwyd

    Llwyd Guest

    Those setting changes solve the problem. It changes the color settings to "Windows 7 Basic" (but reverts back once you close the program). Thanks! :)
    ______________________

    Note: If anyone else tries this (and plays like I do, using only 2d and the built-in macros), you'll have to reset all your macros after this change is implemented.
     
  8. falseprophet

    falseprophet Lore Master
    Stratics Veteran Stratics Legend

    Joined:
    Apr 29, 2004
    Messages:
    1,142
    Likes Received:
    12
    another way to close it is to hit alt+enter twice (toggles game between windowed/fullscreen)
    but if you go to compatibility and just check the "Disable desktop composition" option it will work without leaving UO.exe running and giving you that ghost box that just say UO