1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice

[Tech Help] Windows 7 and General EC Help

Discussion in 'UO Enhanced Client Discussion' started by jtw1984, Jul 10, 2010.

  1. jtw1984

    jtw1984 Seasoned Veteran
    Stratics Veteran

    Joined:
    Jun 12, 2008
    Messages:
    301
    Likes Received:
    1
    Hello all! I know these questions have been asked before, but I thought it would be nice to make a sticky thread of suggestions to make the EC client run better. I began playing UO on the KR client so I feel this is my native client and I love it. However, it runs so laggy on my system that I can't really pvp effectively. Let me give you my system specs and you guys give me some ideas to help run better.

    Before I begin let me say that I have everything in the EC client set to low settings. I have my Nvidia control panel set to performance over quality.

    Specs:

    Windows 7 Home Premium x64
    Intel Core 2 Quad Q6600 2.4 Ghz
    8 GB Ram
    Nvidia GEForce 9800 GTX

    Hmmm its late and thats all I can think of. I probably missed some specs, but if you need anymore I'll gladly post them.

    I appreciate all the help.
     
  2. Tazar

    Tazar Guest

    Based on the system specs I see, I think you should be doing fine. To dig deeper, there's a lot of questions to ask.

    How much memory is on the graphics card?

    What video resolution are you running in?

    Have you run any upload/download speed tests on your ISP?

    Have you updated all of the sound and video drivers?

    Try running it with all of the sound off and see if that helps (you may already have it off like many players).

    Turn off any other options (shadows, trees, etc) and see if that helps.