1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice

Abyss upgrade problem

Discussion in 'UO Stygian Abyss' started by promos1, Dec 19, 2009.

  1. promos1

    promos1 Guest

    I bought the Abyss upgrade yesterday from the EA link at www.uo.com. My purchase went through and they sent me an activation code.

    I entered it into my acct iupgrade and uo recognized it and it says acct upgraded. But, Ea has yet to give me a download capability. IT is not next to my order when I log into Ea store and When I log into EA downloader and put product code into activation screen it says it isn't a valid code..anyone having similar problems or know a solution. I put a ticket into ea yesterday and got a response that I would get a reply within 24hrs been 28 and still no word form them..Can anyone help here?
  2. Gelf

    Gelf Guest

    not quite sure what u mean. if u used the upgrade code and it worked all u should need to do is download SA and install. r u saying u need product code to download SA?
  3. Llwyd

    Llwyd Guest

    If you aren't switching clients, shouldn't the upgrade work automatically upon account upgrade without downloading a new client?

    Here's what the guide has:

    Upgrade Account
    To upgrade your account you will need to go to www.ultima-registration.com.

    1.Click on "Edit Account"
    2.Log in using your game account name
    3.Click on the "Subscription Info" tab
    4.Click on "Upgrade Account"
    5.Enter your Upgrade code in the box

    It doesn't say anything about downloading a new client.
  4. promos1

    promos1 Guest

    lol..Ya I guess I do have it for some reason I thought I would have to do a download to get the SA upgrade ..but guess not..as I am standing in Royal city now..thanks