1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Author Wes Locher has teamed up with Stratics for a giveaway of his new book Braving Britannia. This book explores the history and impact of Ultima Online and includes interviews from current and past dev team members as well as many UO and Stratics community members. Click here for more details!
    Dismiss Notice

Arg! Printing woes - new system

Discussion in 'UO Resources' started by Beer_Cayse, Aug 16, 2009.

  1. Beer_Cayse

    Beer_Cayse Guest

    Following the sample template as much as possible:

    Problem description: Printing to HP Deskjet 5550 via LPT1/parallel cable does not work for Windows apps.
    A) print from CMD shell - yes I can
    B) print from HP Utility - yes I can
    C) print test page from device properties - no I cannot
    D) print anything from Excel, Notepad, Word - no I cannot

    Printer will feed a page, do what I call pre-print calibration, then go back to home position and paper ejects. No printing on it whatsoever except in the successful stuff.

    Attempted fixes: Did the following:
    1 - Windows troubleshooter, even reinstalled latest drivers for the printer - from HP. Drivers dated Mar 2002 <shrug>
    2 - tried BIOS LPT port settings for SCP, ECP, EPP, ECP+EPP (DMA mode 1 and 3 both)
    3 - tried uninstall of drivers, setup printer to USB port; reinstall drivers - same results as in problem description.
    4 - toggled spooler off and tried immediate print. Same results as in problem description.

    Recent changes: New system - and mobo specifically ordered because it has an LPT port; have tried PCI-parallel cards on other Gigabyte and Asus mobo with no luck (see below)

    Operating system: Windows XP/SP2

    System specs:
    Case: Raidmax Smilodon 612-WBP, 500w PSU (same as Rykus but in blue)
    Mobo: Gigabyte GA-M61PME-S2P
    CPU: AMD Athlon 64 X2 6000+ (3ghz)
    RAM: Kingston DDR2-1066, 2x2gb
    VID: Asus EN8400GS (NVidia 8400) 512MB PCi Expressx16
    WD 320GB IDE using Vantec IDE-to-SATA converter on SATA Channel 1 (OS sees it as a USB device!!)
    Optical: LiteOn DVD/CD-rw combo drive on IDE as master device
    Optical 2:
    LiteOn CD/RW on IDE as slave device

    Prior efforts to use this printer were tried on:
    Asus M3A78-EM mobo with Rosewill PCI-to-parallel card and as USB.
    Gigabyte MA78GM-US2H mobo with same PCI/parallel card and USB.

    Neither was successful, nor was contacting HP. I got some fellow in some other country sent me the same instructions even after I specifically stated they failed. MS message boards also were no luck. I had done all that was suggested - including registry clearing AND install of s/ware.

    Printer successfully prints on old system (Asus A7N266-VM/AA mobo, AMD Athlon 64 2000+ (1.8ghz), 512 MB PC2100 RAM). This system is losing the PSU so is effectively dead.

    Any ideas?

  2. Harlequin

    Harlequin Babbling Loonie
    Stratics Veteran

    Jun 11, 2008
    Likes Received:
    So the printer currently can't print via LPT or USB to 3 different PCs.

    But at 1 stage in time it can print when connected to an old PC which is now dead.

    Did you manage to successfully print from MSOffice/test print using the old PC after failing to print on the 3 new PCs? If not, it's likely that the printer broke after your last successful print from the dead PC.

    Since LPT printing is fine (ie sending RAW text tothe printer), the PCL processor could be culprit.

    Trying installing the generic text printer drivers and see if it works. Or borrowing a printer to test on your 3 PCs.
  3. Beer_Cayse

    Beer_Cayse Guest

    In sequence tried:
    Printing from Asus board/system (system A) - with Rosewill card and USB - failure
    Old system back in action - can print - system A goes to son (his system blew the mobo and PSU)
    Printing from Gigabyte MA78GM-US2H (system B) - Rosewill card/USB - failure
    Old system back - can print as recently as the night before last
    Ripped down old system for drives to new system
    New system up in work area (near wifes network drop) - tested all except print
    Hooked up new box to my drop and started with printer woes.

    Most recent usage of printer - old system - Friday night - no problems.
  4. Harlequin

    Harlequin Babbling Loonie
    Stratics Veteran

    Jun 11, 2008
    Likes Received:
    I take it that all PCs are using the same O/S, patch and the same driver (check the driver version and file on the working PC if still possible).

    Things to try, (hook up to USB only first, btw on the old PC, was it connected to LPT or USB?)

    Test using a generic text printer driver

    Test using older drivers

    Test using drivers for older deskjet models (alignment may come out wrong, but we just want to test)
  5. Beer_Cayse

    Beer_Cayse Guest

    Re: RESULTS - sort of ...

    driver version - and I was wrong on date. It's 8/3/2002

    Old PC was parallel hookup as standard. Never tried USB on that one.

    Win-doze would not allow any setup without HP drivers - ie. using something like unidrv.dll as used to occur.

    See the following ...it's all the steps I went thru - lengthy, so get a beer or something! :pint: Bold/red results are changes from what has been happening.
    = = =
    1 - unplugged printer; delete it from Printers and Faxes
    2 - Uninstall all HP software/drivers via Add/Remove Programs
    3 - Regedit and searched for any HP or Hewlett-Packard keys and removed them
    4 - Ran RegClean utility, warm reboot of system; screwed around doing other stuff for a bit.

    Setup #1:
    5 - plugged in printer to allow Windows to detect it. Idea here was to force Windows to use an older driver or one of its own. Results: Windows would NOT set it up nor use any driver it might have available.
    6 - Installed HP drivers (ver
    7a - HP sample page from software - YES
    7b - Printer/Faxes test page - NO
    7c - CMD shell "echo HELLO {CTRL-L} > lpt1:" - YES
    7d - MS Word - NO
    7e - print from Notepad - NO

    Setup #2:
    8 - went to HP.com and downloaded drivers for Deskjet 460C color printer
    9 - Deleted printer from Printers/Faxes (again)
    10 - Logged off and then back on
    11 - Forced a printer addition using the 460C driver - printer states its a Deskjet 460 Series printer now.
    12a - test page when installing printer - YES
    12b - CMD shell "echo HELLO {CTRL-L} > lpt1:" - NO ... and printer "hung" with busy and no print. Shut off printer, waited and turned it back on (clear buffer).
    12c - print from Notepad - YES!!!
    12d - print from Word - 1 line in black, 1 in color - YES!!!

    So here I sit with a Deskjet 5550 that Windows thinks is a DJ 460 Series printer. What would you say is the issue?

  6. Harlequin

    Harlequin Babbling Loonie
    Stratics Veteran

    Jun 11, 2008
    Likes Received:
    The shop sold you a refurbished 460c, dressed it up as a 5550 and sold it to you at mad profits!

    J/k, heh.

    I think it's a driver issue. Specifically with the bilateral comms btwn your pc and the printer. On the other 2 pcs that still has the new drivers, see if you can find any options related to bilateral comms to play around with.

    I'd seen similar issues with old multifunction printers. But it was due to sharing over the network.

    Might also be good to call hp with your findings and see what they say.
  7. Harlequin

    Harlequin Babbling Loonie
    Stratics Veteran

    Jun 11, 2008
    Likes Received:
    Oh, btw, if you pipe output to lpt1 and it doesn't print, sometimes it's because the printer has not received a cr/lf signal.

    Try pressing ctrl+z in this situation. Or even ctrl+ c. Should force it to clear the buffer.