1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Author Wes Locher has teamed up with Stratics for a giveaway of his new book Braving Britannia. This book explores the history and impact of Ultima Online and includes interviews from current and past dev team members as well as many UO and Stratics community members. Click here for more details!
    Dismiss Notice

[Fishing] Boat commands

Discussion in 'UO Fishing and Treasure Hunting' started by goldandblack, Jul 22, 2009.

  1. goldandblack

    goldandblack Guest

    I'm having problems getting my ship command macros to work using the ingame macro system.Each time i input the commands using ctrl+Alt+NUMPAD 1-9 for the various directions the macros work fine till i log out, when i come back the commands have all gone from the macro list.When i make them i save them as ive always done and non of my other macros have this problem.Does the fact i use numbers make a difference, i have the Num Lock on for them and as i said they work fine when i put them in but they just wont save.Anyone got any ideas before i pull all my hair out in frustration!!!!!!.
  2. ok are you using 2d or KR? If KR we have to wait for someone to help you with that, but if 2d I look up the commands and the action they do, by putting that in you number commands you may get this fixed.


    Now this sample just shows one key, but using the number pad keys and alt you can get all the boat commands you need. Just be sure to click on apply and okay to save you work
  3. goldandblack

    goldandblack Guest

    I am using 2d ML and have tried all sorts of combinations using Ctrl + NUM PAD NUMBERS, Alt+NUMPAD NUMBERS and even Ctrl+Alt+NUMPAD NUMBERS.All work fine untill i log off and when i return the commands have all vanished,i clicked apply and save after making each one but they wont save, its getting really frustrating having to make them everytime i get my ship out or log off and back on.In the macro settings i put in the "say" option various commands like stop, back,forward etc and they work but only while the chr is ingame.
  4. Basara

    Basara UO Forum Moderator
    Moderator Professional Governor Stratics Veteran Wiki Moderator Stratics Legend Campaign Supporter

    Jul 16, 2003
    Likes Received:
    are you making sure that the "NumLock key" isn't activating/deactivating when you turn off the machine? The keys count differently, depending on whether Num Lock is on or off.
  5. goldandblack

    goldandblack Guest

    Ive tried with both NUM LOCK on and off with no success, it has me completely baffled as to why it works but doesnt save.
  6. Petra Fyde

    Petra Fyde Peerless Chatterbox
    Stratics Veteran Alumni Stratics Legend

    Jan 5, 2001
    Likes Received:
    I don't remember the details, but there's a file in the uo folder 'keysnames.txt'?

    English keyboards don't save them the same as American keyboards and it has to be edited - only I can't remember which way! lower case to upper case or vice versa.

    Mine reads:
    NUM 7
    NUM 8
    NUM 9


    Record the macro, then check your character's macros2d.txt file and edit the keynames file so that it matches the upper/lower case format that's been recorded.
  7. goldandblack

    goldandblack Guest

    Thanks for the various info, i still cant get them to save.The annoying thing is one of my other chrs has the ship commands and they work fine,ive tried copying the macro 2 d txt file into the other chr folders but that still doesnt work.How can it work for one chr and non of the others even with the same txt file.I noticed that the working chr had its own folder in the account folder as well as the shard folder so i copied another chr folder into the account folder to try but it still doesnt work.I have made all the Help options the same for all chrs too, theres nothing else i can think of that is stopping them working.Looks like im going to have to stick to dry land in my adventures.
  8. That is just plain weird? Maybe delete all of the commands in the macro options and start fresh? Take everything out and rebuild them?
  9. goldandblack

    goldandblack Guest

    Just one last theory, does the macros save in any other file in the chr folder besides the macro txt. i have noticed that the macro 2d txt file for the working ship commands chr does not have the macros included in it but the commands still work, i even deleted both macro txt files and the commands still worked, im thinking they must be part of one of the other files for the chr, could it be part of any of these files....chardata, Multicache.dat, skillgrp, uo or desktop.I'm assuming desktop is the layout for my screen layout and skillgrp is my various skills, but what about the others, as im not able to open these.
  10. I have no clue myself I am totally lost as to why you are having problems with this. Humm, maybe ask in game help [Game Master] to check your char? I don't know what to do, more then what I said above and here. Sorry I not much help here.
  11. goldandblack

    goldandblack Guest

    I have given up trying with the NUMPAD, i have made ship commands using a layout of Alt+ letter keys,they work fine even though i see they are NOT included in my macro txt files.But its extremely awkward as im right handed and using letter keys continuously during a sea trip just doesnt "feel" right but at least it works.Thanks for all the suggestions.