1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Author Wes Locher has teamed up with Stratics for a giveaway of his new book Braving Britannia. This book explores the history and impact of Ultima Online and includes interviews from current and past dev team members as well as many UO and Stratics community members. Click here for more details!
    Dismiss Notice

Cursor lag in 2D with new computer - Help!

Discussion in 'UHall' started by imported_GreatPumpkinator, Feb 8, 2008.

  1. OK, first, computer specs:

    Old System, where there were no problems:
    Inspiron 9200
    Pentium M 1.8 Ghz
    2 GB RAM
    128 MB ATI Radeon Mobility (shared an extra 128 MB for a total of up to 256 MB Video RAM)
    Windows Vista Enterprise (Ultimate)

    New System with issues:
    Inspiron 1720
    Pentium Dual Core 1.46 Ghz
    2 GB RAM
    128 MB Nvidia GeForce 8400M GS (shares and extra 767 MB for a total of up to 895 MB Video RAM)
    Windows Vista Enterprise (Ultimate)

    The problem is this: There seems to be "lag" with the cursor in 2D now. It's hard to explain...it's kind of like, when I move the cursor, there is a split second wait before it starts moving, and then when I stop moving the cursor, it moves for a split second longer. This ONLY happens in Ultima...other games like NWN2, Diablo II, Warcraft III, are not affected. It is VERY difficult to play because of it - you try targetting something [​IMG].

    Anyone else have a similiar issue, or know of a way to fix this? I've tried to have the mouse run is a separate thread in the options, as well as not, and I still get the same effect.

    KR is not effected, in fact, KR runs really sweet now, and looks pretty nice (though, the playability is still not enough for me too fully switch).

    Any help would be nice. Thanks in advance!
  2. Guest

    Guest Guest


    Try toggling Run Mouse in Separate Thread and see what that does for you.

    Should still be in the Options somewhere (been awhile since I've checked though).
  3. <blockquote><hr>


    Try toggling Run Mouse in Separate Thread and see what that does for you.

    Should still be in the Options somewhere (been awhile since I've checked though).

    [/ QUOTE ]

    Already tried that (mentioned that in my post actually)...
  4. Guest

    Guest Guest


    ahh, ok... missed it.

    In that case... *shrug*

    Sorry, that was the first thing that came to mind.
  5. I found the answer to my problem finally. For those of us with 2 or more processors...run task manager, right click on the client.exe process and select "affinity". Finally, uncheck all but the first cpu and click ok.

    You're all set - no more cursor lag!!!!

    ...This might be sticky-worthy information...no?
  6. Babble

    Babble Guest

    Good to know
  7. Guest

    Guest Guest

    How about a writeup of the scenario and the exact fix ... post it in Tech and I'll sticky it until I can splice it in where it would be better.

    Also, since this is Vista ... do you know if there would be a difference using XP on similar systems?
  8. I'll put a post in Tech...I imagine there won't be a difference between XP and Vista....it seems to be a problem with having multiple processors.

    It hit me to try it last night when I remembered a different game having issues with Dual Core systems...and that was the fix that stuck in my head.
  9. Guest

    Guest Guest

    Saw your Tech post ... it's locked/stickied and I posted a note to all that it's there.

  10. Initiated fix and whilst the problem improved - I'm still experiencing mouse stutter.
  11. Guest

    Guest Guest

    I have the "run mouse in separate thread" option selected in 2D. do you? I'm REALLY at work now and can't point directly to where it is, but see if that is turned on.