1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Author Wes Locher has teamed up with Stratics for a giveaway of his new book Braving Britannia. This book explores the history and impact of Ultima Online and includes interviews from current and past dev team members as well as many UO and Stratics community members. Click here for more details!
    Dismiss Notice

Dread Weapon?

Discussion in 'UO Great Lakes Trade' started by Quinn1969, Nov 14, 2008.

  1. Quinn1969

    Quinn1969 Guest

    Due to some glitch last night I was moving my dread weapon from my hand to my pack to repair and it disappeared. NO I didn't drop it :) . I tried everything from dying to logging and it is nowhere.

    It is a red Dreadhorn Katana. It is named Dreadhorn's Revenge or something of the sort. Does anyone have one? I know they are hard to come by but I would really like to replace the lost.

    PM me please.
  2. have you tried logging in and out? that usually fixes it for me...
  3. Quinn1969

    Quinn1969 Guest

    Yes I logged out then back in. Rebooted the game and then my computer. Went and got myself killed and rezzed. NOTHING! I had another problem last night as well. I could not get on my swampy either. It kept saying "I can't reach that". Hell I was right underneath him. I fed him, logged out a couple times...nothing. I finally stabled him and got him back out. Then I was able to mount.
    GEEZE! Damn buggy game!