1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Author Wes Locher has teamed up with Stratics for a giveaway of his new book Braving Britannia. This book explores the history and impact of Ultima Online and includes interviews from current and past dev team members as well as many UO and Stratics community members. Click here for more details!
    Dismiss Notice

EA-Land is back up!

Discussion in 'EA Land/The Sims Online Stratics Forums' started by Guest, Mar 28, 2008.

  1. Guest

    Guest Guest

    Just wanted to let you know it's back up! [​IMG]

    - Danny Banks
     
  2. Mr Me

    Mr Me Guest

    Up and Seems to be LAG FREE!!!!
     
  3. Guest

    Guest Guest

  4. Guest

    Guest Guest

    Shouldn't a dev have been the one to announce that? And what was going on with the game?
     
  5. PHREEKESIM

    PHREEKESIM Guest

    really? It's still not up for me. After I enter my log in info it gets stuck at 25% then to goes to 50% then back to the log in page. .... Anyone else getting this?
     
  6. Guest

    Guest Guest

    I got in ok ... for a short bit. Spent most of my playing time waiting for game that inexplicably went down to inexplicably come back up ... so my playing time was ohhh ... 15 mins tops.

    But I got in.
     
  7. Guest

    Guest Guest

    <blockquote><hr>

    Up and Seems to be LAG FREE!!!!

    [/ QUOTE ]

    Lets hope it lasts for the weekend.
     
  8. PHREEKESIM

    PHREEKESIM Guest

    ok, I'm in ...maybe there was a mad rush when I tried before
     
  9. Guest

    Guest Guest

    wow, with no lag at all, seems to be running smooth as silk