1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Author Wes Locher has teamed up with Stratics for a giveaway of his new book Braving Britannia. This book explores the history and impact of Ultima Online and includes interviews from current and past dev team members as well as many UO and Stratics community members. Click here for more details!
    Dismiss Notice

EA-Land... Subsciption problem.

Discussion in 'EA Land/The Sims Online Stratics Forums' started by Guest, Jan 19, 2008.

Thread Status:
Not open for further replies.
  1. Guest

    Guest Guest

    Basically I was skilling away in EA-land about 15 minutes ago, until my cat walked across my laptop and turned it onto 'sleep mode' - I started it up, logged in again and it says...

    "City EA is currently admitting paying customers only. Purchase a subscription from http://ea-land.ea.com. If you feel you being denied access in error please try again in 24 hours."

    So I checked my subscription... fine as I have always been for "TSO" but above it there is now a seperate "EA-land", and for that it says "Not yet registered"...

    I've tried resetting/both accounts. [​IMG]
  2. Guest

    Guest Guest

    you only need to be subscribed to tso right now, the ealand tab is not for us yet, as i hear
  3. Guest

    Guest Guest

    Yeah that's what I thought... but thought I might mention it incase it's useful. [​IMG]

    Anyway... I can get into TC3 and all other cities.
  4. grumbunny

    grumbunny Guest

    Same thing happened to me. One of my sims timed out and I logged back in and got the exact same message. Then my other sim crashed to desktop- something they often do when one closes- and now I am locked out of EA Land in BOTH my accounts. I can also get into TC3 no problem.

    You are not alone! And I am not happy! [​IMG] [​IMG] [​IMG]
  5. Lets hope it works after maintenance again today. It worked yesterday morning after the same problem 2 nights ago.
  6. mike1977

    mike1977 Guest

    Yeah, it's the first problem listed at tso-e.com that needs to be fixed before we can do sim move to EA-Land.
  7. Guest

    Guest Guest

    Aha! Thank you!

    Haven't been able to get onto that either... heh.
  8. Guest

    Guest Guest

    There is already a thread in the Tech Forum for this issue.

    Please add your information there, where Lee and team can see and answer it in one place.

    I am locking this thread now. [​IMG]
Thread Status:
Not open for further replies.