1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice

EC Bug - Legacy backpacks show no items

Discussion in 'UHall' started by Old Man of UO, Jul 23, 2010.

  1. I just discovered this while trying to stock my vendor. The legacy backpack shows no items, even if you drop something in it. When I toggle back to the grid view, all my items were there. It startled me a bit to see all my items "sold out" on my vendor! lol

    I'm using the Stone Enhanced mod, and haven't tried the default mod because the server went down for daily maintenance.
  2. Goonball FC

    Goonball FC Guest

    yes.. happens to me as well
  3. I fixed it. Load the default mod, open legacy backpack, log out, close and open the client, log in, then load back the original Stone mod. Log out to save the change. Sounds like a lot but takes 30 seconds to change.
  4. Fink

    Fink Guest

    No, no.. that sounds perfectly reasonable and obvious. :eek:

    How did you figure that out?
  5. BTeng_Mythic

    BTeng_Mythic UO Legend
    VIP Stratics Veteran

    Sep 2, 2008
    Likes Received:
    We haven't been able to reproduce this on our end. If this issue is still happening, please feel free to post more information about it.
  6. Logging in and out with the SA mod loaded didn't work, loading the Default mod didn't work. Then I remembered that the XML files don't save unless you restart the client. So it was just putting 2 and 2 together to get 3!
  7. Fink

    Fink Guest

    This has to be done with every character? :sad4:
  8. I only had to do that with one character and it fixed the problem for all of them... temporarily. The bug is back. I have no idea which file is causing the problem, or even if it is the Stone Enhanced mod.

    I never had this issue before the last patch, wondering if it has something to do with the way the user settings are now saved.
  9. Found the problem... I use a command script macro to open Legacy Containers. Using the command script to open a Legacy Backpack, which I use to stock my vendors, will result in an empty backpack. This command script worked without fail before this last patch. What appears to have happened is the second command got deleted with this patch.

    First command script:
    command > script SystemData.Settings.Interface.LegacyContainers = not SystemData.Settings.Interface.LegacyContainers

    Second command script:
    This command script was deleted:
    command > script UserSettingsChanged()

    Put the second command script back into a separate command and it will work once again.
  10. Fink

    Fink Guest

    Oh weird, because I restored all my saved files from backup as soon as I heard there was trouble with the patch. It should be there, but clearly something's not right. Good thing I gave up trying to reset things after two or three rejected attempts on the second character.

    So, basically any update to the client can potentially just delete portions of our settings or macros? Unbelievable.

    Thanks again for fixing the bug. You should be on the payroll.