1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Author Wes Locher has teamed up with Stratics for a giveaway of his new book Braving Britannia. This book explores the history and impact of Ultima Online and includes interviews from current and past dev team members as well as many UO and Stratics community members. Click here for more details!
    Dismiss Notice

EC Problems with High Seas

Discussion in 'Beta Testing Archive' started by lucitus, Sep 29, 2010.

  1. lucitus

    lucitus UOEC Modder
    Stratics Veteran

    Joined:
    May 13, 2008
    Messages:
    1,426
    Likes Received:
    45
    I dont want to paint the evil on the horizion but with the problems in this client is you are nearly unable to play.

    Houses and ships are not displayed probably sometimes your own ship disappear and you cannot move, there are some crash bugs, all in all it destroys the whole adventure for me.

    At the townhall video, i dindt see such bugs, what is wrong there in this client version?
     
  2. Storm

    Storm UO Forum Moderator
    Moderator Professional Premium Stratics Veteran Wiki Moderator Stratics Legend

    Joined:
    Mar 18, 2004
    Messages:
    7,482
    Likes Received:
    375
    Well i know we have reported these bugs at least i have and seen other posts it is beta and i hope they are fixing em