1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice

Galaxies crashes to the desktop after clicking play

Discussion in 'Tech Advice' started by Eucharistadorer, Nov 30, 2008.

  1. Hey all, I'm new to the forums and I have a question that maybe someone could answer.

    My cousin just got galaxies and updated it and everything, but he can't play the game itself. The Launchpad comes up and then he clicks play, then the Launchpad disappears and an hour glass pops up, but nothing happens. The game doesn't load after that point and hes left staring at the desktop. Does anyone know what this problem is, and how to solve it? If so, that would be great. He and I really want to play online, but obviously can't if the game won't even start for him.

  2. BadgerSmaker

    BadgerSmaker Guest

    Hi there Eucharistadorer,

    Sorry to hear about your cousins problems getting SWG to run.

    Crashing right after the PLAY button is pushed is usually indicative of corrupt or unsupported DirectX versions, outdated drivers, antivirus and firewall interference, or corrupted game files.

    First, check that you have DirectX 9.0c installed. This guide will walk you through getting your DirectX version number, as well as your graphics card and driver version numbers. You should also visit this page to verify that your graphics card is supported and your driver version is the one recommended by Star Wars Galaxies. You can download a new version of DirectX from Microsoft's website.

    If updating DirectX and your drivers does not solve the problem, please try removing some of the Star Wars Galaxies files specific to the graphics subsystem. This will replace these files with new, error-free versions. Please refer to this guide.

    You may need to disable your antivirus and firewall programs for Star Wars Galaxies to operate correctly. If you are unable to turn off these programs, you will need to contact your system administrator or the vendor of your specific software of instructions.

    Sometimes simply disabling the software does not solve the issue, as many of the program's processes still continue running. If disabling the software has not solved the issue, please use the configuration options for your software to add SWGClient_r.exe (usually located in C:\Program Files\Star Wars Galaxies\) and Launchpad.exe (usually located in C:\Program Files\Sony\Station\Launchpad\) to the real-time antivirus' exclusion list, as well as to the Firewall's own exclusion list (adding the rules to allow Full Access to the Internet for both of these programs). Please note that these are usually separate configuration panels within the software. If you are unable to find these configuration options, please contact the system administrator or software vendor for instructions.

    If these steps have not solved your problem, please post all of your system information and all pertinent information as described here.

    I hope that helps!
  3. I've tried everything: checked directx (which is the right version), updated the video card's driver, ran a full file scan, put the game in the exceptions list of both the firewall and av program, disabled both, etc. etc. etc., and the same thing happens every time. I also did that thing with the corrupt graphics files but it didn't work either, the only weird thing was that the options.exe file was nowhere to be found, which was really odd—could that be where the problem lies?

    What else is there for me to do? I can't think of anything else.This is getting so old....and what's even worse is that this is the purchased downloadable version, which is non-refundable.....we have to get to the bottom of this, or he's going to want his money back, and fast, which apparently they won't do.
    Here are his computer's specs if it helps:

    Here are the specs:

    Ram - G.Skill 4GB 240-Pin DDR2 SDRAM DDR2 667

    Hard Drive - 640 Gigabyte Western Digital Caviar SE16 SATA 3.0 Gb/s

    CPU - Intel Core 2 Duo E8400 @ 3.0 Ghz

    MOBO - ASUS P5QL PRO LGA 775 Intel P43 ATX

    GPU - Sapphire RADEON HD 3870 512 Mb

    Windows XP Home Edition with Service Pack 2

    As you can see, the computer is very up to date, graphics card and all, which is why its specs shouldn't be the reason this is happening. I've never encountered this before, it's very weird and isn't happening on my computer (which is about equal in terms of specs).
  4. BadgerSmaker

    BadgerSmaker Guest

    Did you try a "Full Scan" from the launchpad at all?