1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice

Gardening bugs (and I don't mean insects *lol*)

Discussion in 'UO Botany and Nutrition' started by Guest, Aug 23, 2004.

  1. Guest

    Guest Guest

    I was thinking - if we could get together a complete and thoroughly explained list of gardening bugs, perhaps then we could get a developer to look at the list and maybe just maybe get some of these bugs fixed.

    I'm going to start a list here (and edit it as we get more information). Please help me out by helping to complete this list (as in more information or ones that I've forgotten). Here is what I can think of so far:

    Plants lose their name/color when set to deco
    This happened with AoS - plants reverted to their original setup which works like this: Plant that is for example "a viabrant purple snowdrop" when set to deco will only say "a decorative plant". This is how they work now as how they worked originally. Sometime not long after plants were out they were changed to where when they set to deco they would say (using our example) "a decorative purple plant" - this was lost when AoS came out. By having the color name in them, it is less confusing on plants that do not hue well and look simular (for example water plants). This also helped in less scamming by people trying to sell a dark blue plant as black (which is worth much more).
    The Fix Ideally it would be nice when plants, when set to deco, would read exactly as they do when alive. Such as "A decorative purple snowdrop" however even to have the color tags back would be sufficient such as "A decorative purple plant".

    Bowl of lettuce and plant graphic can not be targetted with a cursor from a water pitcher
    Double click on a water pitcher and get a targeting cursor. With this you can then target the plant bowl and water *as long as* the plant is in the first 2-3 days of growth and at the 'dirt bowl' graphic. When the graphic turns to the 'lettuce bowl' graphic or the actual plant itself, you get a message saying "You can not fill this locked down item with liquid". (this was tested on the lettuce bowl graphic, not on a plant graphic). It will however work (plant can be watered) if the bowl is not locked down (just laying on the ground) or is in your backpack.
    The Fix Allow plants in the lettuce bowl or plant graphic to be watered with a targetting cursor from the water pitcher (such as is already allowable with the dirt bowl graphic).

    When single clicking on a plant or seed, a string of numbers is displayed rather than the plant name/color or seed name/color <font color=red>FIXED</font color=red>
    When a plant or seed is in the backpack, single clicking on it will give a string of numbers rather than a name. For example, clicking on a bright purple lillies plant I get "#1060822 bright #1060816 #1023211 plant". Clicking on a bright orange poppies seed will give the following "bright #1060817 #1023206 seed". Clicking an unknown seed will give the response "bright #1060814 seed" (&lt;-- this was done on a bright red seed of unknown origin). This occurs if the seed is in the backpack or a container in the house. The same is true with plants. Mouseover shows the correct listing of what the plant or seed is.
    The Fix It appears that the client (and/or server) are failing to recognize various number strings that should then translate into the proper name for the plant or seed. Apparently the "bright" or lack thereof portion is properly translating, however the state of the plant (first number), color of the plant or seed (first on seed, second number on plant) and type (last number on plant, last number if applicable on seed) are failing to correctly translate into their worded counterparts. I assume these translations need to be fixed.

    In some mouse modes, plants (among other objects) do not show prices on vendors
    This is most likely inter-related with the issue above about the # strings. In some mouse modes, most specifically single-click (not mouseover) mode, plants and seeds on vendors will not show the prices of that item once place on the vendor. The item is correctly being labeled for sale and at the price set, however the vendor owner (and/or shopper) can not see the price of the item unless they choose buy and see the price on the menu that pops up.
    The Fix Although this can be corrected by setting the mouse mode to one of the mouseover choices, ideally the solution would be to fix it so that prices once again show on single clicking in a vendor bag.

    When seeds or live plants are placed on a vendor, the set price msg is messed up
    This too might be inter-related with the above two problems. When placing a plant on a vendor (in this case a bright purple lilly plant) it will say "Type in a price and description for a `1_HEALTH` bright `2_COLOR` `3_NAME` plant [ESC = not for sale]". Placing a seed on the vendor (in this case a bright orange poppy seed) results in: "Type in a price and description for bright `1_COLOR` `2_TYPE` seed [ESC = not for sale]". Dropping in a seed of unknown type (in this case a dull red seed) results in: "Type in a price and description for `1_val` seed [ESC = not for sale]". However dropping in a decorative plant will result in the proper message "Type in a price and description for a decorative plant".
    The Fix Once again it appears that the client (and/or server) are failing to translate the plants status, color, and type into the message. This does not affect decorative plants since they currently do not say color or type. The solution is to fix it so that all the plant attributes are properly translated.

    Watering a plant or plant bowl gives an incorrect message <font color=red>FIXED</font color=red>
    Again most likely related or akin to the previous three problems. When applying water to a plant whether it is in bowl of plant stage, also whether locked down, in container, or in the backpack, the follow message is recieved: "You pour water over the #1023305" (a dirt bowl graphic used in this instance - if it is a lettuce bowl graphic it will say "#1060812" instead). When potions are applied they are labeled correctly.
    The Fix Correct it to read "You pour water over the plant" (or some such simular phrasing - I honestly forget how it read originally)

    the previous 4 bugs occured with the application of the emergancy patch to stop an exploit with pet names crashing servers

    When a plant dies, leftover bowl or twigs are improperly labeled
    When a plant dies while still in bowl stage, it will read as "A bowl of hard dirt" even though there is no dirt in the bowl (nor plant). When a plant dies after it has gone to plant stage it will turn to twigs but is labeled as "A bowl of hard dirt". This bug has been around since AoS.
    The Fix The bowl from the dead plant should read "An empty bowl" (or even more ideally it would be nice to see it make some reference to having been a plant that died such as "An empty bowl that used to have a plant in it"). The plants that die and turn to twigs should be labeled as "A dead plant".

    Having both a keg and bottle of potion in backpack causes plant confusion
    Whenever a person has both a keg of potion as well as a bottle of potion in their backpack and they click on the potion icon in the plant menu they will hear the sound of the potion being applied, however the potion counter does not change on the menu (the potion is not applied). I've not tested this personally but this bug has been reported for a long time now and I believe it's been narrowed down to this happening.
    The Fix When the potion is called for, the game needs to be able to decide which potion it will use (keg or bottle) and actually apply that potion. Right now it is taking neither.

    Plants set to deco proceed to die
    A plant set to deco will die - even though it should no longer take growth checks or progress in growth in any way. Some theories have that the plants undeco themselves and then proceed to grow to the point that they die - and are only noticed at that point as having grown again. This bug is very rare and elusive - no one has as of yet established a pattern or consistancy with how or why this has happened. It is even unsure that this is still happening (it is that rare). This bug has been around since the beginning of the inception of plants.
    The Fix Unknown.

    Security setting by the context menu has no effect on a plant
    The plant's own security setting always overrides any security setting the owner wishes to place on a plant using the context menu. Who locks down the plant determines exactly who can access it. If the owner locks it down, only the owner can access it. If a co-owner locks it down only that coowner and the owner can access it. If a friend locks it down only that friend, all co-owners. and the owner can access it.
    The Fix Either enable the security settings to be applied from the context menu, or disable the context menu from showing up when clicking on a plant. The last solution is probably the easiest, although the first would probably be more helpful to plant growers. Being able to set security by the menu would make things easier on them for who they allow to tend plants. It would also allow for multiple friends or co-owners to access plants where they can not currently, only the one locking it down.

    Some plants sink below floor tiles
    When some plants are placed on the floor, they have a tendancy to sink below floor tiles. This is most especially notable when placing plants on teleportars and front steps.
    The Fix I would guess that raising the heighth level of the problematic plants would stop this. Another poster mentioned that some plants have a zero heighth level and this is what causes them to sink below floor tiles (most notably campions, poppies, snowdrops, and lillies, although their are potentially others). I'm unsure if this is the issue, but it does sound reasonable. Currently I do not have an exact list of plants with this problem.

    Trying to plant a seed in a bowl with a seed already in it gives a string number instead of name <font color=red>(status of bug unknown) </font color=red> Simular bug to the other 4 of this nature - gives the number instead of name

    Opening more and more plant gumps causes more memory usage which appears not to be returned when gumps are closed <font color=blue>added 1/17/05</font color=blue>
    Each plant gump can be opened without losing the plant gump opened previously. This allows unlimited multiple gumps to be opened which eventually starts to slow down the game. It appears as these gumps are closed, the memory they use (?) is not being released thus slowing down the game and system. When the game is shut down and restarted, this memory can be regained sometimes - also though sometimes it appears that a computer reboot is needed. (this is all supposition based on eyeing computer performance)
    The Fix
    If there is a memory leak, then it needs to be corrected. Also a solution to multiple gumps using more memory should be looked into. One solution would be to allow only one gump at a time to be open but it should be noted that gardeners all over Sosaria would most likely hate this so this would probably be a case of the solution being worse than the problem.
    This does bring up a related problem/sort of bug:

    One plant can have it's plant gump opened multiple times <font color=blue> added 1/17/05</font color=blue>
    Double clicking on a single plant more than one time will bring up a seperate plant gump for each double clicking. This can cause problems because the multiple gumps do not update on water and potion usage as each is applied to one of the instances of the gump. This can cause over watering and over potioning if the gardener doesn't realize they have more than one gump open for the same plant.
    The Fix
    A plant should only be able to have one open gump associated with it. If another instance of the gump is opened, the previous one should close.

    That's all the bugs I can think of. I feel like I am missing something big but my brain is stuck now. If you have any you can think of or more information i can add to what is already here (most especially with regards to the prices not showing up on vendors which I have had the least experience with) - please post and I will revise this list. Hopefully we can get someone's attention with this. *crosses fingers*
  2. Guest

    Guest Guest

    WoW looks like you've got them all covered, even several I have never
    run into before..
  3. Guest

    Guest Guest

    You should post this in UO hall... everybody else is getting luvin on fixes and problems /php-bin/shared/images/icons/smile.gif
  4. Armageddon

    Armageddon Guest

    Most of these bugs are directly related to publish 25...since that is the publish that broke them. This should have been fixed in publish 26. /php-bin/shared/images/icons/frown.gif
  5. One more which is kind of a housing problem as well as a plant issue. I keep having my plants fall to the floor when the server resets. They are all locked down, but for some reason they fall below the floor tiles. I have had this happen at both my custom house and my castle and it mainly happens with the campions and snowlillies
  6. Guest

    Guest Guest

    Okay - finally found time to update the bug list (I won't mention the number of plants I've been tending the past month that is keeping me beyond busy ingame *mind boggles* heehe)

    I added in the keg and plant sinking bugs and I am happy to say that at least two bugs are now fixed, yay! Hope we get some more fixed too *smiles*.
  7. New one---when pouring water on bowls of hard dirt:

    What do you want to want to use this on?
    You soften the dirt with water.
    You fill the pitcher with water.

    I had hoped I found a way to have a neverending supply of water--but alas! The pitcher, despite being "refilled" by the dirt, still ran empty!
  8. Delmor

    Delmor Guest


    In response to the:

    Having both a keg and bottle of potion in backpack causes plant confusion

    bug, I had this happen a min ago:

    I missed watering a plant yesterday, so it was only healthy today.
    So you get the full facts, I was carrying 3 kegs of deadly poison and 3 kegs of greater cure, which I was going to take across to my vendors, once I healed this plant.
    Anyway, I always carry two empty bottles for starting off kegs and applying heals etc to plants I miss by mistake. Using these, I made 2 greater strength and applied these to the plant with no problem. I then made 2 greater heal potions. I tried to apply them, and got the message 'I apply the potion to the plant', but the counter did not increase, nor did the potion disappear.
    I kept retrying, moving floors in the house and logging out. But nothing helped, then one applied for no reason at all, but the second would not. I then decided to take my potion kegs to the vendor house. When I came back, I tried again and the second potion applied straight away.

    Hope that helps anyone with this issue.
  9. Guest

    Guest Guest

    Hail and Well Met!

    I've noted these gardening bugs. No promises on when I can get to these, but I just wanted you to know that I am lurking and paying attention.

    Excellent job on detailing and organizing this list!
  10. Guest

    Guest Guest

    yay! Thank you for the attention to them!

    I can definitely say the most annoying bug that everyone would love you forever for fixing is the deco names one. If plants, when set to deco, could say what color (and hopefully what type) they are we'd all be soo estatic!
  11. Guest

    Guest Guest

    I'll see what I can do about that.
  12. <font color=00008B>Thank you kittykat /php-bin/shared/images/icons/smile.gif Green thumbs up for your comprehensive list.

    Another buggy is the difference when working in 2D and 3D clients.
    In 3D you have to target the far right areas on the specific maintenance area.
    (Water pitcher is a little more flexible.)

    In 2D there seems to be less of this except my mouse doesn't always accept the water pitcher,
    it just bounces it to new location in backpack. I don't have this problem in 3D.

    Thanks again /php-bin/shared/images/icons/smile.gif
  13. Guest

    Guest Guest

    I started to list that one, but it's already slated to be fixed in Pub. 28 - I can still add it to the list as pending *smiles*
  14. Jonah-Fla

    Jonah-Fla Guest

    their is a bug that when you click on a brown bowl it reads "Bowl of Pototoes" and a split sec later it reads correctly

    their is a bug that when you click on a green bowl it reads "Bowl of lettace" and a split sec later it reads correctly

  15. Guest

    Guest Guest

    actually I believe that is because of the lag optimizations that Speedman put in with the SE server publish. My theory is that the server is sending smaller packets of information to your client at a time than before. Since a lot of those older items were just renamed base items (that is, ever item created in UO seemed to have a base name that the client recognizes, before the server tells it it's seeing something different - newer items created in the last year or so don't have this problem usually since they make new artwork on them) - anyway, since a lot of them are just renamed items, your client is seeing the base name of the item until you finally get the server packet that tells it "no, really this is a bowl of dirt" (or such) and then it's all good. /php-bin/shared/images/icons/smile.gif This is especially noticible on dialup since the packets come slower - and you can see it in more than just plant bowls - for example when you first step into a house, secure containers will just say things like "metal box" (for example) or if you recall to a busy bank and open your box - your gp check will read "deed" until the amount gets to your client.

    So, not really a bug, but just slow packet feed - IMO
  16. speedman

    speedman Guest

    You're actually not too far off at all. It wasn't for optimization, it was because busy areas and places with lots of items take a while to get you item information for everything. Instead of seeing a useless black box as in the past, you now see an item properties box with the "default" name of an item in it.

    The item data is sent in periodic batches so that it doesn't lag you to death when you walk into a busy area.
  17. Ierinn

    Ierinn Guest

    Gee, wouldn't letting all those hundreds/thousands of plants/seeds stack make this item lag problem less problematic? :p

    Btw, lifting the plants that sink under the teleports(another bug as far as I'm concerned, they should all be transparent same as all other tiles when I've got my transparency turned up) and steps doesn't work, it may hold them for the current session but even going upstairs and back down can knock them back under again.. /php-bin/shared/images/icons/frown.gif
  18. Kaeros

    Kaeros Guest

    Has anyone noticed that opening like 50 menus at once it causes the client to slow down...I suppose I might need more ram only 256 at the moment. Planning on getting more.

    What I find odd is after closing them the client still runs poorly until you close it all off and reopen it.

    Makes caring for lots of plants a little more of a pain.
  19. Guest

    Guest Guest

    oh good point, I hadn't thought about that as being a bug (just more the way the game worked) but I do believe you're right that it uses up the memory and doesn't give it back. (I notice it especially when I happen to have bingo (at pogo) running in the background and it slows down with the more plant gumps I open up) *goes to add that to the list*
  20. Krystl

    Krystl Guest

    Not sure if this is a bug or not, so I apologise if I've put it in the wrong place...

    I grow orange petals for a vendor and all of a sudden my petals are not stacking, but are appearing in my backpack as single items. So I collect all my petals and then have to spend WAY too long stacking them. Is this a bug?
  21. Erebor

    Erebor Guest

    Yep, it's a recent bug.
  22. Tamsin

    Tamsin Guest


    Having both a keg and bottle of potion in backpack causes plant confusion
    Whenever a person has both a keg of potion as well as a bottle of potion in their backpack and they click on the potion icon in the plant menu they will hear the sound of the potion being applied, however the potion counter does not change on the menu (the potion is not applied). I've not tested this personally but this bug has been reported for a long time now and I believe it's been narrowed down to this happening.
    The Fix When the potion is called for, the game needs to be able to decide which potion it will use (keg or bottle) and actually apply that potion. Right now it is taking neither.

    [/ QUOTE ]

    There is another variation of this problem. I only carry some greater strength in bottles since I use it so rarely. Normally I carry them in a seperate bag within my main back pack so I can just grab it from the chest. If I fill bottles and leave them in my main backpack I will run into the same situation as above. Similar potions but in two different places in my backpack. As long as I move them all to the other bag it fixes the problem.

    And along the lines of bugs with potions. I carry a keg of GP, GC and GH on me when I tend my plants. I noticed that when I was done and putting them back in the chest the weight wouldn't adjust. At times when I keg is low I want to take another full with me (my plants are on multiple floors - lots of them). I will be overweight because it still sees the used kegs as full.
    The Fix simply fill a bottle from the keg before you put it in your pack. The weight will adjust on the keg to what it should be.
  23. Guest

    Guest Guest

    OK, I didn't see these on the list... hehe...

    1) when openning the plant gump, then clicking on the water icon on gump to water... the plant gump is replaced with a target curser... many times I have been disturbed and when I come back to the computer, I can't seem to remember what I was to target (water or poison or cure)... It would be much better if the gump remained visable with a target curser... instead of either /or...

    2) It's possible to click the water(or any) buttons on the plant gump and target say poison and apply poison instead of water.... this action should generate an error and say "thats not water" or "thats not cure"... this is true with all the buttons on the plant gump, click cure and target water... it applies water, over watering your plant or over curing it...
  24. Guest

    Guest Guest

    One more....

    1) on the plant gump.... the +/- signs turn yellow and red...

    This is not a bug but needs fixing... the background color and the red +/- colors are too close and blend into one another... It's very hard to see the dark red +/- signs on a dark background...

    The +/- sign should be a brighter color red...
  25. DebiHIS

    DebiHIS Guest

    <font color="purple"><center>i keep my kegs in the bank on some shards, and the weight says 100 stones, but it also says 1/3 full.
    I also check my plants everyday, but sometimes the potions/water are not applied for a couple days, then i go the next day, and they are wilted. I thot they auto advanced every 24 hrs., but that is not always the case. If i lose a really expensive seedling because I couldnt save it......grrrrrr. </font>