1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice

[BUG] Last patch broke the Command Script macro for Legacy Backpacks

Discussion in 'UO Enhanced Client Discussion' started by Old Man of UO, Jul 27, 2010.

  1. Using the command script to open a Legacy Backpack, which I use to stock my vendors, will result in an empty backpack. This command script worked without fail before this last patch. What appears to have happened is the second command got deleted with this patch.

    First command script:
    command > script SystemData.Settings.Interface.LegacyContainers = not SystemData.Settings.Interface.LegacyContainers

    This command script was deleted:
    command > script UserSettingsChanged()

    Put the second command script back into a separate command and it will work once again.
  2. Goonball FC

    Goonball FC Guest

    mines borked
  3. Try deleting the old macro and recreating it. I just edited mine and it works now.
  4. Fink

    Fink Guest

    Copied/pasted it in all my macros, all better in less than two minutes. Thanks again for the fix.
  5. Glad it worked for you, Fink. It bugged me that BTeng said he couldn't duplicate the bug, and it took me a while to figure out what that meant and how simple a fix it is.

    I'm thinking that if you have any other macros with two scripts or additional lines, you might want to check them out.