1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Author Wes Locher has teamed up with Stratics for a giveaway of his new book Braving Britannia. This book explores the history and impact of Ultima Online and includes interviews from current and past dev team members as well as many UO and Stratics community members. Click here for more details!
    Dismiss Notice

Macro help?

Discussion in 'UO Players Corner' started by Dragonchilde, Jan 10, 2009.

  1. Dragonchilde

    Dragonchilde Guest

    The new Macro system is mystifying me.

    I tried to set up a basic mining macro like I used to have (Last Object, Wait for Target, Last Target (Or whatever the name of that one is now)) and it just... doesn't work. I get "you can't mine that" or something. I tried the repeat which took painfully long...

    I'm not interested in mass quantities of hands-free mining... I just don't want to aggravate my RSI. Does anyone have an effective in-game macro for things like mining and lumberjacking? What nuance of the system am I missing?

    I can't use any third party programs... this game barely runs on my Vista laptop as it is without adding more crap to it (it bothers me that I can run DAoC lag-free, but can't run UO without significant lag).
  2. Storm

    Storm UO Forum Moderator
    Moderator Professional Premium Stratics Veteran Wiki Moderator Stratics Legend

    Mar 18, 2004
    Likes Received:
    my mining macro is simple and it works for wood or mining
    last object
    last target

    thats it

    if using KR
    1) Use the "target resource" macro for the set up and tell KR to have it repeat. That gives you 10 quickchops per tree before pushing the macro again.

    2) When you find a colored wood tree you can open the map, either full or radar. Right click where it shows your at and create a waypoint for that tree. For example if it was Yew you can name the waypoint Yew and assign it to custom 1-10. Assign what icon you prefer by clicking on the icon it shows. And click create. Now you won't lose the tree you found. Make sure you go into map options and have the location show in game, by putting a check in the in-game box. It's really awesome having it show in game, you can't miss it.

    The macro to mine multiple times rapidly is similar to lumberjacking. You set it up the same way however it will chain 8-10 swings without another keypress due to shovels and picks having charges. To reload the macro when your shovels are used up you edit the macro, then once in (macro), you edit the target by resource. Which will open a new box where you can drop another shovel. You right click to get the menu, left click to select edit.
  3. Dragonchilde

    Dragonchilde Guest

    I don't know if it's the client I've got (KR) or just my computer's crap, or the lag, or what... Last Object just plain doesn't work.

    I even tried making a super basic macro... JUST last object. It doesn't work. If I'm using a shovel, and hit the last object, it'll say "you can't mine that" and I swear, I haven't set it to target anything! I don't know if I just need to switch to the 2D client anyway.
  4. Basara

    Basara UO Forum Moderator
    Moderator Professional Governor Stratics Veteran Wiki Moderator Stratics Legend Campaign Supporter

    Jul 16, 2003
    Likes Received:
    in KR, you have to right-click the macro's button on the hotbar, and it will give you the option for targeting (self, current, or to give you a targeting cursor). Right now, you've got it set to target an invalid target. once you set it to give you a targeting cursor, it will work fine.
  5. Dragonchilde

    Dragonchilde Guest

    That was it! Thank you so much! I'm now making cloth, mining, and chopping wood with ease!