1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Author Wes Locher has teamed up with Stratics for a giveaway of his new book Braving Britannia. This book explores the history and impact of Ultima Online and includes interviews from current and past dev team members as well as many UO and Stratics community members. Click here for more details!
    Dismiss Notice

macro troubles

Discussion in 'UO Crime' started by Guest, Dec 23, 2007.

  1. Guest

    Guest Guest

    hi im new to uo and i could use some help. I set up a macro to poison a dagger.
    i clicked on a keg, then hit poison skill, then clicked on poison potion, then clicked on dagger. This macro did not work did i do somthing wrong? If so can anyone tell me how to set a macr for poisoning. I`m using UOA. THANKS
  2. Guest

    Guest Guest

    No you really didn't do any thing wrong....

    Just need to make a couple changes to the macro....
    When you recorded the macro it should look like this:

    Use Item
    Use skill / Cast Spell

    Here's how you change the things...
    Highlight Use Item.... Right Click and choose Convert to Use Item Type
    Use Skill / Cast Spell .... leave as is
    Highlight the 1st Target .... Right Click and Choose Convert To Target Type
    The Last Target is Fine, but I would change it as above so it works on any dagger.

    When you done, your macro should look like this....

    Use Item Type
    Use Skill / Cast Spell
    Target Item Type
    Target Item Type

    Set your macro hot key and your ready to roll. If you are adding multiple instances, you will need to add a delay in after you poison the dagger and make the changes as above.

    The reason for making these changes is everything in UO has a unique ID. So, the first time you made the macro. It basically said....
    Use this Keg - (Would work until you needed a new keg)
    Use This skill
    Use this potion - (That exact potion no longer existed once you used it)
    Use This dagger - (could never switch daggers, which is fine, but it's just as easy to do any dagger)

    The changes make it say....
    Use any keg (of this poison type)
    Use this skill
    Use any bottle (of this poison type)
    Use any dagger

    Now as you switch thru the different levels of potions, you will have to right click on the sections you made changes on and choose Reset Item & Reset Target. When you reset the item / target it brings up the targeting curser. Just choose the new level of poison keg and the new level of poison bottle.

    That will allow you to use the same macro for lesser posion all the way thru Deadly poison.

    Hope that helps,
  3. Guest

    Guest Guest

    I tried what u said but i`m still having problems.
    First i right clicked on item type all i can do is reset item i cant convert item.
    Then i set the other lines the way you said, but when i ran it all it does is fill the potion bottle with poison. Its like it never ran the skill line. Q if you have any answers i would appriciate it thanks.
  4. Trukx

    Trukx Guest

    To alleviate the covert to 'item type' issue, before you record the macro use the UOA Macro for "count resources" (just push the button on the Resources tab). That fixes it for me every time. It may be that kegs cant be 'item typed' but I dont konw. If not, whenever you finish a keg you just need to 'reset target' on the line of the macro script to your new full keg.

    Mess with the delays, nothing should be longer than 1000-2000 on the delay gump; if you have a slow or choppy connection it may need to be longer, but not by much.

    May look something like this:
    Dlb Click Keg (use item) (reset to use item type) (should fill your bottle)
    Delay 500
    Use Skill (poison)
    Target (target your poison bottle)(convert to target item type)
    delay 1000
    Target (target your dagger)(convert to either 'last target' or 'item type')
    delay 1000
  5. Guest

    Guest Guest

    useing the count resources worked but uoa will still only fill the potion bottle,
    Then gives me a targeting icon(hand w/circle) but wont poison my dagger.
    i may have to poison one at a time i could gm it by xmas 08..
  6. Guest

    Guest Guest

    I created that macro and tested it just before posting. It worked fine for me. It could be a timing issue due to your connection speed. I have a pretty good connection here and no delays were necessary.

    You can also try this goto:
    C: > Program Files > UO Assist > UOA-Settings > Your Account Name >Your Chars Shard > Your Chars Name

    and open that folder. You will see all the macros you have set. They are numbered 1 thru 16. Choose the number of your existing poison macro. Cut the existing text out and Paste This In:

    [**Macro Data**]

    Thats a copy of the macro data from mine that works.

    My guess is that it is a timing issue. You get the target curser for which poison to use and for which item to poison. Hard to know where it is stopping. As mentioned above, add the delays in and experiment with them. I have seen delays as long as 5000 for guys playing off of satellite or horrendous ping rates (like I get to the asian shards)

    Hope that helps and Happy Holidays. Ohhh and before I forget ... Happy Poisoning
  7. Guest

    Guest Guest

    Thanks man the code did it. it was an eleven sec delay between skill trys that i needed to do to get it to work. So thanks again for the help