1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice

Naturalist Quest Problem

Discussion in 'UO Players Corner' started by Moss, May 18, 2009.

  1. Moss

    Moss Guest

    I need help. Apparently, once upon a time, I started the Naturalist Quest. I have since finished it, but am unable to recall which Naturalist gave me the Quest. I have tried:

    Galvin (Britain Public Library Tram)
    Errol (Britain Public Library Fel)
    Arlo (1st Library of Britain Tram)
    Ingram (1st Library of Britain Fel)
    Patton (Britain Sage Advice Fel)
    Vincent, Wilby (Jehlom Library)
    Jay, Franklin, Lorne, Chadwick (Lycaeum Tram)
    Jacson, Maynard, Averill, Douglas (Lycaeum Fel)
    Willem, Tanner (Ocllo Public Library)
    Elias (Wind)

    None are the correct Naturalist. Who am I missing? I have tried to cancel the quest, but there is no effect when I do. Is there anything left to try?
  2. Basara

    Basara UO Forum Moderator
    Moderator Professional Governor Stratics Veteran Wiki Moderator Stratics Legend Campaign Supporter

    Jul 16, 2003
    Likes Received:
    I think there might be a naturalist roaming the woods near spirituality shrine. I know there is on Lake Austin.
  3. Moss

    Moss Guest

    Thanks for the suggestion. This char is on Atlantic. I searched the area around the shrine pretty carefully, but did not come up with a naturalist anywhere in the area. Goes to show how alike and different the shards are!
  4. Dragonchilde

    Dragonchilde Guest

    check the quest log; doesn't it say who you need to return to?
  5. Silverbird

    Silverbird Slightly Crazed
    Stratics Veteran Stratics Legend

    Nov 3, 2001
    Likes Received:
    I had a similar problem with another quest .... I guess its not possible to finish the quest, after the NPC, from whom you got that quest, gets a reset. (And there were many resets while those invasions were active.)
    I simply cancelled my quest and started again.
  6. Moss

    Moss Guest

    It turns out that I was totally unable to cancel the quest using the KR client. Each time I tried, it still appeared. Finally, I loaded up the old 2d client, and voila!, I was able to cancel the quest! Thanks all for your help. Looks like a bug to me. I wonder, it there anyplace that actually lists the reported, unfixed bugs for any of the clients? It would be nice not to have to spin my wheels looking for solutions that don't exist. I can live with workarounds, if only I knew when to try to find them.