1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice

New to UO - Can't read char descriptions etc

Discussion in 'UO Resources' started by ipumuk, Dec 12, 2009.

  1. ipumuk

    ipumuk Guest


    I just downloaded the 14 day trial. I tried to create a character but I can not read the char descriptions and other letters.

    all I can see is strange boxes, where there should be letters.

    Does anyone know what to do?

    kind regards
  2. Lorax_Pacific

    Lorax_Pacific Lore Master
    Stratics Veteran Stratics Legend

    Sep 1, 2006
    Likes Received:
    Wheel of fortune. You have to guess the words. I guess the top word is Elf.

    You already try the simple things like exiting the client and restarting?

  3. ipumuk

    ipumuk Guest

    of course i did.

    i am running win7.

    i also tried xp compatibilty mode and admin mode.
  4. Experimental

    Experimental Lore Keeper
    Stratics Veteran Stratics Legend

    Jun 23, 2004
    Likes Received:
    Are all your drivers updated? Looks like a problem on your end, maybe data speed or graphics card.
  5. Tazar

    Tazar Guest

    I am moving this to the UO-Tech forum. The guys that hang out there are probably best equipped to help out.
  6. Cear Dallben Dragon

    Cear Dallben Dragon Babbling Loonie
    Stratics Veteran Stratics Legend

    Feb 17, 2005
    Likes Received:
    its a UTF language problem.
    the new client isnt set for all that right now or something.
  7. ipumuk

    ipumuk Guest

    it is really strange.

    because some letters are shown correctly and some are not.

    i updated my drivers. but as expected it did not help ;/

  8. ipumuk

    ipumuk Guest

    i solved the problem by chosing different languages in the game and then applying them.

    suddenly when switching back to english it worked.

    they really must fix that. i bet a lot of trial players quit because of that bug.
  9. Frarc

    Frarc Stratics Legend
    Stratics Veteran Alumni Stratics Legend

    Mar 18, 2003
    Likes Received: