1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Greetings Guest!!

    In order to combat SPAM on the forums, all users are required to have a minimum of 2 posts before they can submit links in any post or thread.

    Dismiss Notice
  3. Greetings Guest, Having Login Issues? Check this thread!
    Dismiss Notice
  4. Hail Guest!,
    Please take a moment to read this post reminding you all of the importance of Account Security.
    Dismiss Notice
  5. Author Wes Locher has teamed up with Stratics for a giveaway of his new book Braving Britannia. This book explores the history and impact of Ultima Online and includes interviews from current and past dev team members as well as many UO and Stratics community members. Click here for more details!
    Dismiss Notice

please help with lag!!!

Discussion in 'UHall' started by Snowlord12, Jun 29, 2009.

  1. Snowlord12

    Snowlord12 Guest

    running vista..

    in game i run 5 steps and freeze for 3-5 seconds. I've checked with my cable service provider and all my levels are good.

    anyone know what else I can do?

  2. Black Sun

    Black Sun Grand Poobah
    Stratics Veteran Alumni

    Mar 19, 2003
    Likes Received:
    Are you running any other programs in the background?
    Or if you're on a network, is someone else on the network hogging your bandwith?
  3. Storm

    Storm UO Forum Moderator
    Moderator Professional Premium Stratics Veteran Wiki Moderator Stratics Legend

    Mar 18, 2004
    Likes Received:
  4. Theres so much you can do to combat lag, one thing i always do is set my client.exe priority to high, i mess around with ingame options also,
    are you playing on an appropriate server for where you live? i know i get a little more lag because im in the UK and play on Great Lakes which is a USA server ;)
  5. EDA_GL

    EDA_GL Journeyman
    Stratics Veteran

    Oct 19, 2008
    Likes Received:
    If you noticed the lag after the ToTIII patch (the most recent one) try right clicking your UOA/UO icon and give it the 'run as administrator' property. It fixed my issue. HOWEVER, it will completely bunk all your UOA macros!
  6. EnigmaMaitreya

    EnigmaMaitreya Crazed Zealot
    Stratics Veteran

    May 12, 2008
    Likes Received:
    Your Cable Provider gave you information that is specific to the central node (I think is the term for Cable) to your house.

    The path from your house to a UO server is ... well much longer.

    There could be a router or routing issue past your Central Node. Based on their answer (what you posted) there could even be an issue in the Central Node.

    It is not an UNKNOWN thing that Cable Operators etc will prioritize message types, in your case downward.

    So the fundamental question is has this always been the case?

    If not, has there been a recent outage?

    Has something new changed?

    I dont use Vista (I use Windows 7) and I am not sure they distribute all the commands.

    There is a program called tracert that you should run, this tends to be able to identify any router that is ... well being a bottle neck for you.

    Somewhere, and I can look it up, if it is still in business, there is a Web based version of tracert and the reverse route (The two routes are almost never the same route) and often there is a problem in the return route (UO to you).
  7. Snowlord12

    Snowlord12 Guest

    Thanks for replys all... especially you EnigmaMaitreya, thanks!

    Yes, it's only been happening the last month and a half. Before that i had no lag. I've asked the cable provider if something has changed and they did not say it has, but it sure seems wierd. I'll try that traceroute program. I also tried a trace ping speed test with my cable provider while on the phone, using dos screen and typing; tracer www.google.com .... and the resluts did suggest that I'm losing connection from somewhere, but the cable guys are doing nothing about it. if i can get more evidenc e i will confront them again.

  8. EnigmaMaitreya

    EnigmaMaitreya Crazed Zealot
    Stratics Veteran

    May 12, 2008
    Likes Received:
    Them not doing something about it is the easy road for them. They may tell you a FORM of the truth and say it is not their equipment etc. BUT what they would NOT be saying is they partner with companies/institutions to form these routes. Such that they ultimately have the ability to reform a partnership that would remove the "Bottle Neck".

    The Tier 1 people can not and probably have no clue what the heck I just said. They are after all just reading from a script designed to solve the problem (a generic statement) and as such there is very little point in taking it out on them as they probably would get fired for deviating from the script.

    Now having said the above, you certainly can ask to talk to a tier 2 (ultimately tier 3) person or a Manager (and may still need to try to escalate it through the various tiers of the Network Technical Support Group).

    Having a tracert in hand that clearly shows the problem is an invaluable piece of evidence. Even if the person is not in your area the level 2 person should be able to log into the "Redback" you are connecting to and run the tracert and verify the problem. If this is accomplished and they see the bottle neck you have gone the limit. They will either repair/partner with some one or they are prepared to accept you moving to some other form of internet connection.

    Now to make sure that some areas of responsibilities are clear, EA/UO have no authority over or any responsibility for the inbound routing, in short they cant do squat about it (not literally their technical dept could talk to your technical group on your behalf but more likely than not it would just be a waste of everyone's time).

    Now if the problem were on the return leg, then Heck yea, EA/UO are responsible for that part and can indeed work tom solve the problem, if they wanted to that is.

    Understand this, all of the above is assuming that nothing has changed about your hardware or operating system, other than the periodic patch's by Microsoft. If you have installed new software or hardware, and it was on or around the time you started noticing this, then there is a possibility (albeit slim to none) that the change is the culprit and not the network. Again the tracert will clearly show this one way or the other.

    As an example only as I could NOT find the file that contains the uo server id's, if they even provide that any longer. I edited out the first five hops as they can not be relevant.

    Notice hop 11 is a no response, this is ok as often routers chose to not respond to a tracert.

    Notice the jump between 7 and 8, in this case that is no bid deal, but had it been for example, 6663ms and the next one had been for sake of argument 6673 followed by a 6683 etc, then that says that hop 7 to 8 is a problem, if one is looking for a lack of responsiveness in the connection. That is the kind of thing you would be looking for, it probably is not as exaggerated as my example, but it would be a noticeable sore thumb, it should stick out quite clearly. You may want to run the route several times at differing times of the day, and copying and pasting them into a document or how ever you want to organize your case. If your not familure with the Dos Box, then you can left click on the icon in the top left corner. Look for the Edit option and then do the mark option. This part can be tricky as it is not intuitively obvious how to do this part. Put the cursor in the dos box at the beginning of the area you want to copy, now use the cursor (left key down) as you would to draw/outline a rectangle. This will highlite an area to be copied. When you have the are highlighted hit the Enter key (the not so obvious part :) ), the area will be copied to the clip board and can be pasted as text.

    I hope all of this helps in resolving your issue.

    Tracing route to compassion.owo.com []
    over a maximum of 30 hops:
      6    11 ms    11 ms    11 ms
      7    11 ms    11 ms    10 ms  gar3.cgcil.ip.att.net []
      8    63 ms    64 ms    63 ms  cr1.cgcil.ip.att.net []
      9    64 ms    63 ms    63 ms  cr1.sffca.ip.att.net []
     10    63 ms    62 ms    62 ms
     11     *        *        *     Request timed out.
     12    62 ms    62 ms    62 ms
     13    64 ms    63 ms    63 ms  compassion.owo.com []
    Trace complete.
  9. Snowlord12

    Snowlord12 Guest

    thanks!... loved the intelligence and humor behind your reply.

    here was my result;

    1 * * * Request timed out.
    2 * * * Request timed out.
    3 * * * Request timed out.
    4 * * * Request timed out.
    5 * * * Request timed out.
    6 * * * Request timed out.
    7 * * * Request timed out.
    8 * * * Request timed out.
    9 * * * Request timed out.
    10 * * * Request timed out.
    11 * * * Request timed out.
    12 * * * Request timed out.
    13 159 ms 93 ms 90 ms od-in-f147.google.com

    Trace complete.

    but that was just to google.. must be one of my providers better companies, since they told me that one. I'll try some other trace routes. I may try taking my computer back a few months also and see if that works. But first i'll try and re-install UO.

    I'll let you know how it goes :).
  10. Sebrina

    Sebrina Guest

    Seems alot of wild pings all around which I can only attribute to sunspots at this time messing with the magnetosphere. What the heck???? - one minute my traces are great and the next, the lag monster gets me on a hub and devoures me. I have not checked SOHO yet, but indications from many pings in the last hour are not good.
  11. Bluebottle

    Bluebottle Guest

    I think it's a common problem right now - it's been intermittently VERY laggy and I'm on DSL so I suspect the connection is unlikely the problem here :(
  12. Bluebottle

    Bluebottle Guest

    Yup - looks like it's a problem with a failing (or overstuffed) router somewhere between the ATT Edge connection system to the EA front end - not a lot we can do about that. The usual trick for large orgs like ATT and EA is to blame each other while they actually figure out what the problem is :(

    Could be anything that is the actual root-cause from a wonky router, massive downloads of Michael Jackson and Billy Mays memorial videos to distributed denial of service (DDOS) attacks!

    (Asked whois.arin.net:43 about +

    OrgName: AT&T WorldNet Services
    OrgID: ATTW
    Address: 200 S. Laurel AVE.
    OrgName: Electronic Arts Inc.
    OrgID: ELECTR-60
    Address: 209 Redwood Shores Parkway
    City: Redwood City
  13. Harlequin

    Harlequin Babbling Loonie
    Stratics Veteran

    Jun 11, 2008
    Likes Received:
    You definitely need to do a few more tracerts at different times of the day. Either all 12 initial hops are configured to not respond to ICMP packets (ie ping/tracert traffic), or you are having a really bad day...

    Try a "tracert compassion.owo.com" instead. That's the patch server. To tracert to your shard, check this list for your shard:


    Tracert the dns address of your shard.

    Also, are you using a wireless network?
  14. Sebrina

    Sebrina Guest

    It's not just running Vista. I've been in touch with friends on many shards and several of them say (heck with this,) and time to go to bed anyway - see what morning brings. Me, I have some things to do tonight, but most of those involved dungeons, so I might settle on marking some non-dangerous runebooks.

    I can have 4 computers running on DSL in this house and normally don't have lag like this.